2

I upgraded a virtual machine from Windows 7 to Windows 10. Everything seems to work okay, except I'm unable to log into Minesweeper using my Microsoft account.

When I try it tells me "To use this app, you need to log in with the Microsoft account that was used to download it. Go to the Windows Store, select Settings, Accounts and Preferences, then sign in with the purchasing account. If this doesn't help uninstall and reinstall the app at the Windows Store."

I only have the one Microsoft account. The same one that I used to download the app, and the same one that I log into Xbox Live with.

I tried logging out and back in. To Windows. To the Store. To Xbox.

I tried removing the app and reinstalling it. More than once.

I installed Solitaire, logged in successfully and played a few games.

I even tried running Process Monitor to see if I could see where Minesweeper was retrieving the credentials that it was using to log in. As it only prompted me once and hasn't any subsequent time I open Minesweeper. I did not have much luck.

What am I missing?

0

There are a lot of random solutions out there, but this is what worked for me after trying other long winded solutions.

  1. Open Date and Time settings (Click on the time on the date/time on the taskbar, click 'Date and time settings'

  2. I had set time automatically on and set time zone automatically off, turn them both off.

  3. Try starting Minesweeper or Solitaire or whatever MS game you're having trouble with. Hopefully you can log in now.

  4. Change your settings back to what they were before for date/time. If your problem is like mine it should still work after changing it back.

Hope those steps work for you, or others with the problem. good luck.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.