41

I use an english version of Windows 10, but I have set the keyboard layout to German (Switzerland). This works fine if I am logged in with my user. The only keyboard available is my German(Switzerland) keyboard, which is exactly what I want.

On the login screen on the other hand there are three keyboards available (which would be okay too), but German (Germany) is the default. Since most of the special characters are on different keys, logging in is difficult, unless I switch the keyboard every time.

How can I change the default input method / keyboard layout for the login screen in Windows 10?

8 Answers 8

54
+50

I had the same question but with French being the default on Windows 10 rather than the one I wanted so I ended up here.

HoD is very close. I was able to use his suggestion to find the solution for me. This solution uses your current display and input language to change the Welcome screen and possible for new user accounts if you want. So make sure you have the display and input settings while logged in that you want to apply to the login screen before doing the steps:

  1. Click the language on the Taskbar.
  2. Then click Language preferences.
  3. At the bottom under "Related settings," click "additional date, time, & regional settings" which opens the control panel
  4. Click the "Region" option
  5. Then go to the far right tab "Administrative". (HoD's step 2)
  6. In the "Welcome screen and new user accounts" click copy settings. (HoD's step 3)
  7. Tick "Welcome screen and system accounts" (and "new user accounts" if you want it to be applied to those as well). (HoD's step 4)
  8. Click Ok. (HoD's step 5)

I was able to use HoD's suggestion to find the solution here. It's for Windows 8.1, but works on 10 so far.

Hope it will help you, too!

11
  • 1
    I don't have the language taskbar, but somehow managed to find the settings in the control panel. This works on my desktop machine, but for some reason it does not on my laptop.
    – Peanut
    Aug 23, 2015 at 11:59
  • The option is not there on your laptop? Or the change does not take effect after doing all of the steps?
    – Ender
    Aug 25, 2015 at 4:29
  • It does not take affect, I still have the three keyboards available with the wrong one set as default. I tried to reboot and repeating the steps twice.
    – Peanut
    Aug 25, 2015 at 6:18
  • 2
    The current user input method is different from the actual input method I'm using! So I can not copy the current user config, since it is wrong! How can I make the current user config match the current selected input method?
    – Pedro77
    Jan 29, 2016 at 12:52
  • 4
    Pedro77, I am guessing that means that you are using a different input method than the default for your current user. The current user input method listed should be the default for that user account. You can override the default input if you would like. That is what I ended up doing. Click start and type control panel. Select clock, language, and region. Next hit language. On the left-hand side select advanced settings. Here you can override both the default display language and the default input language. Change it to your desired one, and the current user input method should work.
    – Ender
    Jan 30, 2016 at 14:53
4

I'm on Win7 so I will check again tonight on Win10 to see if this is still correct. So first set up your own settings (language, keyboard etc) they way you want it. Then do this:

  1. Open Control Panel and open "Change Keyboard or other input methods"
  2. Open the tab 'Administrative'
  3. Click on "Copy settings..."
  4. Tick "Welcome screen and system accounts" and "new user accounts" if you feel like it.
  5. Click Apply and then OK
3
  • I can't find a tab named "Administrative". On Win7 there is one, you're right, but not on Win10
    – Peanut
    Aug 21, 2015 at 14:01
  • I'll be able to check it on Win10 in two hours when I get home :) I switch between Azerty and Qwerty so it's interesting for myself too!
    – HoD
    Aug 21, 2015 at 14:02
  • It's been a bit more than two hours, but it's still there in Windows 10 20H2, and probably hasn't moved since Windows 7: i.imgur.com/qm28IjD.png Mar 22, 2021 at 17:35
2

I am using Group Policy Registry settings to setup en-US welcome screen input language by default on domain computers. There are only two registry values in single key:

[HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]
"1"="00000409"
"2"="00000419"

I am sure that default input language is EN on welcome screen. It is very usable because usernames are also English.

But this policy doesn't work on Win10 by default, "from box". And that's why.

There is undocumented feature in Windows 8/8.1/10. It performs automatically copying user language settings to login screen. This feature can be disabled by Local or Domain GPO here:

Computer configuration/Administrative Templates/System/Locale Services/
Disallow copying of user input methods to the system account for sign-in

"This policy prevents automatic copying of user input methods to the system account for use on the sign-in screen. The user is restricted to the set of input methods that are enabled in the system account. Note this does not affect the availability of user input methods on the lock screen or with the UAC prompt. If the policy is Enabled, then the user will get input methods enabled for the system account on the sign-in page. If the policy is Disabled or Not Configured, then the user will be able to use input methods enabled for their user account on the sign-in page."

Just enable it, and you can control input language on welcome screen by only two registry values.

1
  • Ох, мужик, ты не представляешь как облегчил мне жизнь!
    – don Rumata
    Jan 10, 2021 at 18:37
2

The accepted solution from user Ender might not work because it lacks a final step.

As the answer from user Alexander Davidenko states, there is another option that will automatically revert the changes you just made if you only follow Ender's answer.

To counter this automatic reversion:

  1. Do every step from Ender's solution (8 steps)
  2. Type Windows key + R to open the "Run" window.
  3. Input "gpedit.msc" and hit enter to open "Local Group Policy Editor".
  4. In the left tree view, select Local Group Policy > Computer Configuration > Administrative Templates
  5. On the right pane, open System > Local Services
  6. Modify the setting "Disallow copying of user input methods to the system account for sign-in" to Enabled.

You should finally be able to use your current keyboard layout as a default input method in the Welcome screen!

3
  • In my case, there was no need to either change the registry or the GPs. And I don't see how the system account would play a role here.
    – Peanut
    Feb 16, 2017 at 9:47
  • I suppose it depends on each one's configuration as there might be several accounts created, several languages used, several keyboard layouts, different language&region settings and options selected or even different updates installed or not, etc... All those different factors might modify Windows behaviour. But in my case, I can assure you that I attempted 3 times Ender's procedure, rebooting each time, and it wouldn't work until I did what I explained above. As strange as it may sound. (I am no windows expert) Feb 16, 2017 at 11:01
  • Thank you, this was driving me nuts! That's a very counter-intuitive option, I'd expect it to do the opposite of what I accomplished using it!
    – Ben
    Aug 17, 2017 at 15:10
2

In addition to the accepted solution you should also save language for every application (when you switch between apps your language should also change).

Language preferences > Spelling, typing & keyboard settings (under "Related settings") > Advanced keyboard settings (under "More keyboard settings"). Set a checkbox "Let me use a different input method for each app window".

enter image description here

Now you will have English in a login screen.

4
  • 1
    Probably, this is the only working solution to always have English as the starting input language on the Welcome Screen of Windows 10. Many thx! Got tired to type passwords in a language I've logged out. It should be some pinned language, all the time.
    – it3xl
    Sep 9, 2021 at 17:11
  • 1
    @it3xl, agree with you! Also was frustrated switching to English every time on Welcome Screen. Thank you! А мы из одной страны.)
    – CoolMind
    Sep 9, 2021 at 20:10
  • 1
    Главное, что "всему миру" пох, а вот мы не можем мириться.) Регулярно сюда захожу, за выручалочкой, спасибо.
    – it3xl
    Sep 10, 2021 at 21:49
  • 1
    @it3xl, рад вас слышать! Смотрю, у вас есть даже более подробный ответ: superuser.com/questions/948660/…. Да, на Винде отожгли, эту галочку по умолчанию не включили.) Согласен, SO - это как соцсеть, любимый форум, каждый день тянет зайти, увидеть заветные +10 в репутации. Удачи вам!
    – CoolMind
    Sep 10, 2021 at 22:12
1

Win-X (or right-click the Windows icon in the taskbar)
Settings
Region & language
Related settings - Additional date, time & regional settings
Language - Change input methods
 If necessary, Options (to Add an input method)
Advanced settings
Override for default input method -> select desired main input language
Save
then follow the steps to save it to Welcome screen and/or New user

1
  • You answer does not improve the accepted one
    – yass
    Dec 7, 2017 at 18:45
1

If you use on windows 7 / server 2003 registry key

[HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]

for set keyboard layout for password prompting screen and this layout was not default for system, now on windows 10 / server 2012-2016 you must add another key for doing such thing:

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Control Panel\International]

Example: (for Russian user)

Windows Registry Editor Version 5.00

[HKEY_USERS\.DEFAULT\Keyboard Layout\Preload]
"1"="00000409"
"2"="00000419"

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Control Panel\International]
"BlockUserInputMethodsForSignIn"=dword:00000001

Save this as .reg file and start on every system, where you login.

0

I found the solution and it is even simpler than that. They just go to "language preferences". Left click on the language of your country, then options. If you go there there is a box that says "add keyboards". Add your custom layout and delete the default layout of it. And ready. When you start windows you will do it with the language of your country, but with your personalized keyboard. You didn't have to mess with so many settings. It was simpler. Search all kinds of forums and the answer was so obvious that no one saw it. Sorry if something is not understood, I speak Spanish and use the google translator to communicate this to you.

1
  • How is this better than accepted answer?
    – Toto
    Sep 10, 2021 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.