20

I want to disable Task View in Windows 10 completely. Is this possible?

Note: I know the button in the taskbar can be hidden by right-clicking it and unchecking “Show Task View button”. That’s not what I’m asking.

For example, when resizing and moving a window to the left half of the screen using Win + , Task View is also activated. I don’t want this. I want the old, Windows 7 behavior, where the window is moved and resized and nothing else happens.

23

If you only have 1 virtual desktop, taskview will not be active (default situation). So removing all virtual desktops except for the main one, and hiding the icon is all you need to do.

If you want to disable the overview screen, then go to start -> Settings -> Multitasking.

From the Snap menu, turn off When I snap a window, show what I can snap next to it

  • 1
    Why did this answer get a -1 vote? Please explain. It is the correct answer. Showing the desktop after you release the windows key is NOT taskview. – LPChip Aug 12 '15 at 11:43
  • @LFChip because this community is full of negative Nancy's – Ramhound Aug 12 '15 at 19:14
  • @Ramhound apparently... :/ – LPChip Aug 12 '15 at 19:28
  • It seems that my Ctrl + Win + Left/Right doesn't disable using this method. I would like to, if possible, turn off the feature that's bound to them. – user1182988 Sep 17 '16 at 1:06
  • Would be nice to have some further text that explains exactly what "Taskview" is. I've been a lifelong Windows user, and frankly I have no idea what taskview is. I just wanted to disable a feature that made all my Windows suddenly dissapear (I've never been a fan of virtual desktops anywhere). Edit: I assume I accidentally clicked (with my mouse?) on the "+ Desktop" thing which appears when pressing Windows key? – Svend Jun 15 '18 at 9:22
2

Not sure if this will apply to everyones situation but I believe I understand what you're asking.

I tried all the solutions provided in this thread and none of them worked for me.

On my laptop I had to go into the touchpad settings (I've got a Dell) and turned off "Gestures" and the task view no longer appeared when I didn't want it to.

  • Yes, turning off 3 and 4 finger gestures will prevent switching desktops action. – pollaris Jul 2 '18 at 8:26
  • I had the same issue as you that the previous solutions were already turned off. My Asus had a "swipe right from left edge" option marked that I need to remove! Thanks for the insight! – Guto Jul 13 '18 at 21:42
0

Keyword: Snap Assist. Disable it!

To disable Snap Assist in Windows 10, launch the Settings app from your Start Menu, or by searching for it with Cortana or Windows Search. From the Settings window, click System.

In the System Settings window, find and click Multitasking in the column on the left. Under the “Snap” category on the right, find the option labeled When I snap a window, show what I can snap next to it and set it to Off. This will disable Snap Assist in Windows 10.

Source: https://www.tekrevue.com/tip/how-to-disable-snap-assist-windows-10/

This same issue was driving me crazy too.

protected by Community Sep 14 '18 at 12:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.