3

I'm using windows 7 and I'm trying to connect to my router with telnet:

  • open cmd
  • type telnet xxx.xxx.xxx.xxx.

Result is could not open connection to the host, on port 23:connection failed.

What I have already tried:

  1. Control panel -> Program and Features -> Turn windows features on or off - Check telnet client box (I also checked Telnet server but it gives an error)
  2. Control panel -> Windows Firewall -> Advanced setting -> Inbound rules -> New rules -> Port 23, TCP - Allow the connection, domain/private/public
  3. I can't find Telnet as a service. I don't know how to uninstall, reinstall.

I tried cmd net start telnet - then I get: service name invalid

2
  • After you enabled telnet through the Windows Features, did you restart your computer? That could be why it isn't showing up in the Services program yet. If it is indeed enabled, it should show up in Services.
    – DrZoo
    Aug 12, 2015 at 15:42
  • @DrZoo The OP is trying to connect to a device with telnet - there is no requirement to install the telnet server service to accomplish this.
    – albal
    Aug 12, 2015 at 15:52

1 Answer 1

4

You don't need to do anything else to windows to get the telnet client working. You already get an error message from it saying could not open connection to host on port 23: connection failed - telnet client is operating, just not how you'd like. Either:

  • The IP address is wrong (can you ping the device?)
  • The device is not available at that IP (again can you ping the IP?)
  • Outbound connections on your Windows Firewall are blocked (outbound to connect to a device)
  • Or most likely telnet is not supported or turned on in your router (Which router do you have?)

If your router supports remote command line access (not all of them do) then it may be SSH (Secure Shell) on Port 22. If you are using Windows then a popular package is Putty - but there are other clients available.

4
  • i pinged and it worked. sent 4 and received 4. i don't know about outbound. i did same thing to the outbound rules as i did to inboud rule. i have at&t3600hgv.
    – Eric Lee
    Aug 13, 2015 at 2:42
  • and how can i put enter here?
    – Eric Lee
    Aug 13, 2015 at 2:46
  • You router does not support ssh or telent login to the device: forums.att.com/t5/U-verse-2014-Archive/…
    – albal
    Aug 13, 2015 at 8:29
  • dear @albal , my ping works. added outbound rule. inbound rule is already there. i have binatone wr1500n3. if done via command line says 'could not open connection to the host, on port 23:connect failed' instead of 'connection failed'. via PuTTY say 'Network Error: Connection refused'. Jan 13, 2016 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.