21

As we all know, items in windows file manager will change color when selected. But this feature seems go wrong on my windows 10 x64 computer lately: enter image description here

A reboot will fix the problem, but after couple of hours the highlight shall disappear again.

Is this another windows bug, or am i missing something?I don't think I have installed any software that may affect windows explorer.

  • I experienced this after using Remote Desktop (with Parallels Client for Android) – beppe9000 Feb 14 at 22:49
22

Do you happen to have a second monitor with different scaling? Switching between the two as primary displays seems to cause this.

Toggling High Contrast mode on and off seems to fix the issue temporarily so I don't need to reboot. A permanent fix is still required, but I hope this helps in the interim.

High Contrast Setting

Edit: it's possible also that changing theme colours also fixes the issue but I have not tried this yet; I'm waiting for it to break again.

  • 2
    Switching themes to another theme then switching back to my original fixes this for me. Thanks! – clav Jul 28 '17 at 1:04
6

I haven't got enough information to give a definite solution, but here are some things you can try to narrow down the possibilites or try to solve it

First thing I would try is to see if the problem is fixed when explorer restarts. Next time you get this issue, open task manager, go to more details and look under processes. Select Windows Explorer from the list and click Restart in the bottom right. See if the issue persists

It could be a problem with your graphics driver - try downloading the latest one from your manufacturer's website (but don't try installing one for a older version of windows as this could make the problem worse)

Another possibility is that some system files are corrupted. Have a look at this article to see how to run sfc to check your system files.

Does anything else happen at the same time as this (e.g. some stuttering or a black screen?) Check your event viewer and see if there are any errors happening at the same time as you get this bug.

  • Thx for reply. The sfc check showed no corrupted files, and I installed the lasted graphics driver (Intel® HD Graphics 5500). Still need some time to see if problem still exists. – mmjang Aug 12 '15 at 18:55
  • This happened to me, I did an sfc /scannow and it found and fixed some issues. I had to reboot the PC. Once back up, Explorer was highlighting correctly, and that other issue with refreshing with Explorer window went away. MS link: answers.microsoft.com/en-us/windows/forum/windows_10-files/… – JasonH Sep 25 '15 at 21:45
5

This problem seems to be occurring only after starting the system from sleep/ hibernate. Instead of restarting every time it occurs, you can rather Restart the Windows Explorer through the task manager. Task manager screenshot

Simple Fix: Restart Windows Explorer

  • 1
    Or you can press Shift + Left Alt + Print Screen twice in a row. – Maciej Swic Jun 22 '18 at 17:44
  • @MaciejSwic This should be the answer. Fixed it immediately for me. – Lews Therin Oct 2 '18 at 18:24
  • @LewsTherin Do not think so, it does not solve the problem, it is just a workaround. – Vojtěch Dohnal Jan 7 at 13:36
1

To color selected text or icon:

Enter to File Explorer, there:

View -> Options -> View

look for: "Use check boxes to select items" and UNCHECK it.

Click on "OK"

  • It would be helpful if you wrote a sentence on why this is needed. – r0berts Jan 21 at 17:03
0

I use one of high contrast in windows 10 setting and click apply button in setting, then switch it off by choosing None, then everything going as default.

Oh on more thing, this happen after setting double monitor.

0

Pulling the file explorer window into the view of the other monitor(s) appears to be a quick fix to this problem. It allows the window to resize itself and fix itself. It's then able to be placed back into view of your favorite monitor again. For me personally, it was putting the window onto the laptop screen and then back to the desktop screen.

0

what I did was I switched off the transparency effect in the theme settings.

0

In SETTINGS>COLORS>MORE OPTIONS>Transparency Effects - set it OFF. Problem solved.

0

I have a laptop. When docked, I do not see or use the laptop LCD. Instead, I use 2 external monitors. The monitors were defaulted to 100% scaling. When the laptop lid is closed the scaling for it does not show up on the display settings, but it was 125%. Even though the monitor was not active, its scaling affected the File Explorer highlighting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.