Up to and including Opera 30 you could follow this link here which simply directs you to delete some .json file containing the default search engines.

Starting today, with the latest Opera update 31.something, this trick does no longer work. If the default_partner_content.json file is missing (or things are deleted from it), Opera will complain on startup and ask for a reinstall. Putting the file back in place restores Opera to working, but the default search engines are there obviously...

Has anyone found a new way to get rid of the default search engines?

(If I accidentally search that ridiculous yahoo again instead of youtube, as configured by me, I will lose my sh**.)

up vote 31 down vote accepted
+50

Go to opera://about to display your installation paths

  • From [root]/profile :

Remove default_partner_content.json and copy siteprefs.json to [root]/[version]/resources

  • From [root] :

Remove default_partner_content.json then rename siteprefs.json to default_partner_content.json and set it read-only


As you may know, agreements with search engine providers are an important source of income for the company.

Opera & search engines

  • 4
    And forgoing configurability is an important source of driving away the user base of the few % of super users they still have... – fgysin Aug 13 '15 at 12:32
  • 2
    The default Amazon and Bing searches aren't secure (https) in v34.0 here so security would be a poor excuse. – contrebis Jan 18 '16 at 10:52
  • 1
    In fact, looking at the default_partner_content.json file, even more are redirected through http ad partner URLs so, yeah. Nice job Opera. – contrebis Jan 18 '16 at 10:58
  • On OS X 10.11.3 & Opera 35.0, installation root does not contain default_partner_content.json. How to adapt this process to OS X? – thSoft Feb 17 '16 at 12:44
  • 2
    This is not about privacy - it is about usability and configurability. I have seen big projects (even companies) fail because they drove away users by sacrificing usability to ad revenues... I'd hate to see Opera go down this road. – fgysin Aug 2 '17 at 9:00

It's a well known issue. It's driven a lot of people away!

Here's a 'hack' which involves changing the launcher in itself. It works though!

(Source: http://forums.opera.com/discussion/1848915/opera-25-remove-yahoo-from-default-search-engines/p1)

  1. Hit "WINDOWS KEY" + "E" (to) open the Windows Explorer - browse to your own files or where you want the script to reside
  2. Right click in that directory --> "New" --> "New text file" and name it "OperaLauncher.BAT.txt"
  3. Open that file in Notepad (or preferably Notepad++ if you got that) Paste the following code to it:

@echo off & setlocal  set "OperaProgRoot=C:\Program Files (x86)\Opera"
set "OperaLauncherExe=%OperaProgRoot%\launcher.exe"  set

"GetV=%Temp%\GetV.vbs"  echo Set
objWMIService=GetObject("winmgmts:{impersonationLevel=impersonate}!\\.\root\cimv2")>"%GetV%"
echo Set colFiles=objWMIService.ExecQuery ("SELECT * FROM CIM_Datafile
WHERE Name='"^&Replace(WScript.Arguments(0),"\","\\")^&"'")>>"%GetV%" 
echo For Each objFile in colFiles: WScript.Echo objFile.version:
Next>>"%GetV%"  set Version=  for /f %%i in ('cscript //nologo
"%GetV%" "%OperaLauncherExe%"') do set "Version=%%i"  if defined
Version echo %OperaLauncherExe% - Version %Version%  del "%GetV%"  IF
NOT EXIST

"%OperaProgRoot%\%Version%\resources\default_partner_content.json"
GOTO LAUNCH_OPERA  : RENAME_DPC  ren
"%OperaProgRoot%\%Version%\resources\default_partner_content.json"
"default_partner_content.json.BAK"  : LAUNCH_OPERA 
"%OperaLauncherExe%"

I then took that .bat file and assigned the Opera 'O' icon to it, and removed the original shortcut.

  • Wasn't able to make this work... Also this seems to be just a script for the old Opera-v25 hack, which, as the OP clearly states, does not work anymore on Opera-v31+. – fgysin Sep 7 '15 at 17:56

For Opera 36.0.2130.65 editing the %operaversion%/resources/default_partner_content.json succeed on Ubuntu and Windows.

Open the file in vim and remove lines, other than Google, from "search_engines": { constructs in that file, so it should look like the following:

{
  "version":8,
  "search_engines": {
    "location": {
      "at": {                  // a language code 
        "other": {
          "list": [
            "google_at",
            // yahoo and all others wiped there
          ],
          "speed_dial_index_list": [0]
        }
      },
      "au": {
        "other": {
          "list": [
            "google_au",
          ],
          "speed_dial_index_list": [0]

And so on in all language sections. Sorry I can not paste the whole file.

Edit this file, keep a copy and set the edited file to be read-only and/or set opera://flags/#first-run-partner-content-update to disabled.

  • 1
    Hmm interesting, so do you reckon they disabled the file consistency checks? From Opera 31 on a single byte change in one of the files lead to an error and aborted startup... – fgysin Apr 20 '16 at 6:07
  • I don't see Yahoo listed under the list for "us" and yet it's one of my default search engines. I don't care so much about removing it as I do about rescuing the "y" keyword, but searching for "yahoo" and changing keyword to "" doesn't work ... it just resets it to "y" upon startup, even with the flag you suggested set to disabled. – swrobel Jul 21 '16 at 21:26

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.