Is it possible to copy and paste inside a Remote Desktop Connection session?

  • For future readers, if none of the answers below helps, you can always rely on SSH. What I did is I install Bitvise ssh server on my server and the Bitvise SSH client in my PC. Then voila I can copy-paste FILES from and to my server. Bitvise is only free for personal use though.
    – Rosdi
    Commented Apr 9, 2015 at 7:38
  • 4
    @null that is not helpful if someone just needs RDP fixed. If the fix on this page doesn't help, you can kill/restart the rdpclip process: gfi.com/blog/…
    – degenerate
    Commented Jun 22, 2015 at 0:47

9 Answers 9


Assuming you're talking about Windows Remote Desktop Connection — before you hit Connect, click Options to expand the RDP connection window.

  • Click the Local Resources tab. Under Local devices and resources, click More.

  • In the new window, click Drives. Click OK to close.

  • Go back to General tab and click Save to save the settings for next time.

Barring any weird settings on the server side, you should be good to go.

Screenshot of invoking the options in the connection dialog for Remote Desktop Connection

  • 4
    Pretty much follow the same steps as technie007 suggests, but also notes the clipboard option.
    – huggie
    Commented Jan 14, 2010 at 7:06
  • 1
    This solution solved my problem but I don't like it. I don't want to give the remote computer (read/write) access to the whole drive(s).
    – Isaac
    Commented Dec 6, 2012 at 14:57
  • That is definitely a cleaner interface than copy-pasting through the rdp session, though it also verified my worry that the reason the other method didn't work is that this particular vpn connection just really doesn't like copying files. >.>
    – neminem
    Commented Dec 19, 2014 at 19:25
  • 2
    If you try this and it still doesn't work, you might need to kill and restart the rdpclip process. See here: gfi.com/blog/…
    – degenerate
    Commented Jun 22, 2015 at 0:47
  • @degenerate, Weird, I don't see a rdpclip process anywhere on the client. Which Windows are you using?
    – Pacerier
    Commented Aug 3, 2015 at 5:17

Even when you have the "Clipboard" option enabled, you may still have problems!

If that's the case, use Task Manager to kill and restart the rdpclip.exe process on local and remote machines.

More details on this blog post

The only way I really knew to fix the clipboard transfer was to close my session and restart it. That meant closing the tools I was using like Visual Studio, Management Studio and the other ancillary processes I have running as I work and then restarting all of it just to restore the clipboard. But today I found a good link on the Terminal Services Blog explaining that what is really happening. The clipboard viewer chain is somehow becoming unresponsive on the local or remote system and events on the clipboards are not being relayed between systems. It is not necessarily a lock being put in place but some sort of failed data transmission. It then goes on to explain the 2 steps you can take to restore the clipboard without restarting your session.

Use Task Manager to kill the rdpclip.exe process
Run rdpclip.exe to restart it

… and a pretty ridculous "explanation" from Microsoft.


If you have a shared clipboard problem, see if the following troubleshooting guide helps:

| Symptom                  | Possible Cause          | Possible Solution            |
| Remote-to-local copy and | RDPCLIP is not in the   | Kill and restart RDPCLIP.    |
| paste broken.            | clipboard viewer chain. |                              |
| Local-to-remote copy and | TS client is not in the | Close the TS client and      |
| paste broken.            | clipboard viewer chain. | reconnect to the session.    |
| RDPCLIP or the TS client | There is a loop in the  | Kill and restart RDPCLIP.    |
| is using excessive CPU.  | local or remote         | If this does not fix the     |
|                          | clipboard viewer chain. | problem, close the TS client |
|                          |                         | and reconnect to the session.|
  • 25
    I actually found restarting rdpclip.exe on both the client machine and the remote machine worked, the accepted answer didn't help me. Up voting your answer.
    – Shane
    Commented May 5, 2011 at 20:25
  • 7
    This should be the accepted answer. It's what actually solves the problem.
    – degenerate
    Commented Dec 8, 2014 at 1:23
  • 4
    @Roddy, Weird, I don't see a rdpclip process anywhere on the client. Which Windows are you using?
    – Pacerier
    Commented Aug 3, 2015 at 5:19
  • 5
    For those willing to try it out: Open CMD as Administrator and run: taskkill /IM rdpclip.exe /F (wait for the saying that it was terminated). Hit Windows + R (run window) and type : rdpclip.exe Done ;) Commented Dec 29, 2015 at 13:24
  • 1
    This is the right answer. I had the luxury of just restarting the server, and that fixed it also. Commented Jan 29, 2016 at 18:53

I struggled with this one... until I realized rdpclip.exe was a program running on the RDP session machine and not my local machine.

Once on the right machine, killing and restarting fixed it for me.


Note that if you're copy-pasting files, drag and drop might not work, you need to use Ctrl+C / Ctrl+V.

  • 1
    How to enable drag-and-drop too?
    – Pacerier
    Commented Aug 3, 2015 at 5:21
  • 1
    What if Ctrl+C / Ctrl+V doesn't work either ?
    – ABcDexter
    Commented Jul 18, 2016 at 19:43
  • 1
    @ABcDexter - see Ruddy's answer.
    – ysap
    Commented Jul 27, 2017 at 18:56

if you are SuperUser (Adminisitrator) on the Remote Computer do the followings;

  1. Click Start
  2. Administrative Tools
  3. Terminal Services
  4. Terminal Services Configuration
  5. Double click RDP-Tcp connection under Connections
  6. Click Client Settings
  7. Uncheck Clipboard under Redirection (if it is checked that means it is disabled)

This may solve your problem which solved mine.


Try pasting to the Desktop of the RDP machine rather than into Windows Explorer.

Maybe this was due to the particular folder in Explorer requiring Administrator permissions, and pasting doesn't appear to pop up the permission elevation dialog. Either way, this workaround did the trick for me.


I never managed to get it to work. So I open a Google Docs document, open two browsers in the remote and local machine, and copy'n paste texts using it. Stupid solution, but works.

  • I just discovered that the security department disabled it, forcing me to pass through a thid party service.
    – neves
    Commented Apr 15, 2020 at 3:57

Yes, copying and pasting is possible. If you're using Windows 10 to remote into the other machine, ensure you are using the app titled "Remote Desktop Connection". Windows 10 apparently ships with 2 separate RDP apps:

  1. "Remote Desktop" - a newer, shinier more "visual" version
  2. "Remote Desktop Connection" - the original, classic-style you saw in older versions of windows

I never could get any of the other answers to work for copying local / pasting remotely using the newer RDP app. The "Paste" option remained grayed out on the remote machine. But once I realized there were two separate RDP apps on Windows 10, and I tried using the other app (which turned out to be the classic version)... I was able to do so successfully without jumping through any hoops. It just worked.

  • Yes the "new" Remote Desktop app is a "trusted windows store app". Skype ships in both versions as well. Generally one should avoid the store version apps like the plague because they are useless (i.e important functionality has been cut out).
    – ChrisWue
    Commented Apr 11, 2018 at 22:28

Another option is that is turned off in your group policies. Open gpedit and check it:

Group policies

  • for anybody wondering, this is under the tree User Configuration -> Administrative Templates - > Windows Components -> Remote Desktop Services -> Remote Desktop Session Host -> Device and Resource Redirection. Disable the "do not allow clipboard redirection"
    – LarryBud
    Commented Oct 20, 2022 at 16:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .