11

I recently upgraded to windows 10 on my daily driver laptop and I have liked it so far except for one thing. Randomly the windows menu decides to stop working when I press the windows key or I press the button in the corner. Has anybody else experienced this problem? Solutions? Thanks!

9

Open Powershell as Administrator and enter this command:

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

This command disables development mode on the apps, and re-registers the manifest file for the app.

Taken from: http://forums.windowscentral.com/ask-question/370916-start-menu-not-working-windows-10-build-10240-a.html

  • 1
    What exactly does this command do? I just want to proceed with caution before using commands that I do not fully understand. – Nick P Aug 13 '15 at 19:00
  • @NickP It disables development mode on the apps, and reregisters the manifest file for the app. – geek1011 Aug 13 '15 at 21:22
  • OK. Thanks for the explanation. Just wanted to be careful. I'll try that. Why does taking them out of developer mode help with that? – Nick P Aug 13 '15 at 21:44
  • @NickP I do not know that, but it worked for me – geek1011 Aug 14 '15 at 12:06
  • 1
    How long is this task supposed to take? I seem to be hung at ` Deployment operation progress: C:\Program Files\WindowsApps\Microsoft.Appconnector_1.3.3.0_neutral__8wekyb3d8bbwe\AppXM...` for 10+ minutes – dlamblin Oct 26 '15 at 20:01
4

I renamed folder C:\Users\tim\AppData\Local\TileDataLayer\Database which crashed something, and now I can open the start menu but it's completely empty. Conculsion - win 10 is buggy and I should have stuck to windows 7. Or better still linux mint.

Clues from my event log:

svchost (1980) TILEREPOSITORYS-1-5-21-1122570970-1426555800-1633067203-1001: Database recovery/restore failed with unexpected error -501.

svchost (1980) TILEREPOSITORYS-1-5-21-1122570970-1426555800-1633067203-1001: Corruption was detected during soft recovery in logfile C:\Users\tim\AppData\Local\TileDataLayer\Database\EDB.log. The failing checksum record is located at position END. Data not matching the log-file fill pattern first appeared in sector 238 (0x000000EE). This logfile has been damaged and is unusable.

svchost (1980) TILEREPOSITORYS-1-5-21-1122570970-1426555800-1633067203-1001: The log range read from the file "C:\Users\tim\AppData\Local\TileDataLayer\Database\EDB.log" at offset 974848 (0x00000000000ee000) for 4096 (0x00001000) bytes failed verification due to a range checksum mismatch. The expected checksum was 15882041360721203292 (0xdc6858788dd9505c) and the actual checksum was 7776709318633315834 (0x6bec6bec2a9bddfa). The read operation will fail with error -501 (0xfffffe0b). If this condition persists then please restore the logfile from a previous backup.

log of the thing that crashed when I renamed the folder

Faulting application name: ShellExperienceHost.exe, version: 10.0.10240.16425, time stamp: 0x55bec5f5 Faulting module name: Windows.UI.Xaml.dll, version: 10.0.10240.16431, time stamp: 0x55c9bf27 Exception code: 0xc000027b Fault offset: 0x0000000000464bd7 Faulting process ID: 0xf70 Faulting application start time: 0x01d0fbbac66ae74a Faulting application path: C:\Windows\SystemApps\ShellExperienceHost_cw5n1h2txyewy\ShellExperienceHost.exe Faulting module path: C:\Windows\System32\Windows.UI.Xaml.dll Report ID: b26367c9-d409-4a01-a801-7d8b0870ebb0 Faulting package full name: Microsoft.Windows.ShellExperienceHost_10.0.10240.16384_neutral_neutral_cw5n1h2txyewy Faulting package-relative application ID: App

I suspect this means I'll have to create a new user profile and steal the folder from that. Or blow away the VM and rebuild from scratch (you don't think I let windows near my actual computer do you?!)

Based on the above I found http://forums.windowscentral.com/windows-10-insider-preview/337063-5.htm which lists the steps for replacing the corrupt db and a bunch of people saying it works.

  1. Login to your current profile
  2. Press WIN+X, and select "Command Prompt (Admin)"
  3. Enter the following commands, in this order

...

  1. net user "TempAdmin1" "password1" /add
  2. net user "TempAdmin2" "password2" /add
  3. net localgroup administrators "TempAdmin2" /add

  4. Press CTRL+ALT+DEL, click Sign Out

  5. Login to the "TempAdmin1" account using password "password1"
  6. Logout, and then login to the "TempAdmin2" account, using "password2" (note: you must fully sign out, not just switch users)
  7. Open File Explorer, select View, then check the box marked "Hidden Items"
  8. Navigate to C:\Users\TempAdmin1\Local\TileDataLayer (click "continue" to gain access when prompted)
  9. Right Click the folder "Database" & Copy
  10. Now, navigate to the same folder for your damaged profile (C:\Users\YOUR_USERNAME\Local\TileDataLayer)
  11. Right click "Database", and rename to "Database.BAD"
  12. Right click empty area in the folder, and select Paste
  13. Reboot, then sign back in with your original profile.

Now, assuming all is well, you want to delete the 2 accounts you created:

  1. Win+X -> Control Panel -> User Accounts -> Manage Another Account
  2. Select Account, then "Delete Account"
3

There can be multiple reasons for the broken Start Menu, one solution cannot fit everywhere. I tried to restart the Explorer shell first. However, it does not help and the Start menu still does not appear. Next, I tried to reboot the PC, but it too was not helpful to me.

Below the solution worked for me, you can try this to make the Windows 10 start menu work again:

  1. Open Windows PowerShell as Administrator

    • Right-click the Start button
    • Choose Command prompt (Admin)
    • Key in Powershell in the black window and then hit Enter
  2. Paste the following command in the "Administrator: Windows PowerShell" window and press Enter key:

    Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

  3. Wait for PowerShell to execute and complete the command. Ignore the few errors (in red color) that may pop up.

  4. When it finishes, try hitting Start and hopefully it’ll start working. If not, this solution won’t apply to you, unfortunately.

  • This worked for me, 1709 – Patrick Apr 20 '18 at 1:57
0

This issue was resolved for me when I prevented programs from automatically re-opening at login. To accomplish this I closed all open windows (Outlook, Chrome, etc...) then restarted the computer

To restart your computer using shortcuts (without a working start menu);

  1. press windows key+r to run a command
  2. type in shutdown /f /r /t 0 to immediately restart your computer

I am not sure if the restart command was the fix, or if the fix came from preventing applications from automatically re-opening after login. I haven't been able to test further.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.