10

In earlier Windows versions when updates were downloaded they were automatically installed the next time the PC was shutdown (and powered back on later). With Windows 10 this option seems to be gone. I can manuall trigger a restart and installation by using the button under "Windows Update" or I can let Windows reboot automatically when my PC "is not in use" (whatever that means) but I can't configure it so that the Updates get installed automatically the next time I shut down the PC.

Is there a way to get the previous behaviour back?

| improve this question | | | | |
8

If you hold shift while clicking the "Shut Down" button, it will install the updates on your next boot.

| improve this answer | | | | |
  • 1
    Does this apply to Windows 10? It doesn't seem to have any effect when I try. – thelem Oct 20 '15 at 8:41
  • This doesn't work on Windows 10 version 1709. After shutting down in this way and then booting, the update is still pending a restart. – Nicholas Jan 12 '18 at 9:27
  • Windows 10 Pro-64 user: It worked for me. On clicking shutdown, it gives no notification that anything happened, but on startup it installed the updates. Most importantly, it stopped giving me "A restart is required," when I've just booted up. That always seemed to be a dumb message. – Chuck Savage Feb 22 '18 at 22:54
6

You can enable the full shutdown (disable fastboot Option) in Windows 10, then it should install Updates on Shutdown.

You have to go to the Control Panel, search for and click on "Power Options", then on the left side click on the link "Choose what the power buttons do", then click on the link "Change settings that are currently unavailable" and then on the lower part of the Windows in "Shutdown settings" disable the Option "Turn on fast startup (recommended)"

| improve this answer | | | | |
  • 2
    Thanks. Worked for me. :) I was getting irritated by the fact that it wanted to install updates at 3.30am when the computer is off. So of course it wouldn't install updates. Eventually it started bothering me in the middle of my work saying it wants to restart for updates in 10 minutes' time. Um. No. I'm busy. Go away. – zaTricky Nov 5 '15 at 8:21
  • 1
    Yep, I was bothering of that because I never restart my PC, I just turn it on when I come home and turn it off when I go to sleep, so there is no change for a restart for updates. I need Windows to install them while a regular shutdown. It's just sad, that the only possibility to do so is to turn of the fastboot option... – Geco Mynx Nov 6 '15 at 14:48
  • 1
    I can't find such setting. – Dreaded semicolon Mar 14 '16 at 19:47
  • When you can't find the Option then you probably have installed some software that takes control of this settings, like the Samsung Magician Software. It controls this options depending on what profile you have activated. – Geco Mynx Mar 16 '16 at 13:31
1

Microsoft removed this option in Windows 10. Unless you are on a domain with WSUS, then you only really have these two options.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.