I have some aliases set in Current User, Current Host and Current User, All Hosts.
Starting PowerShell (i.e. outside of Cmder) loads those profiles and so aliases are available.
Starting PowerShell inside Cmder ignores those profiles.

Is there anyway to make Cmder PowerShell sessions to read either of those two profiles?

Thanks.

up vote 16 down vote accepted

The issue is that Cmder comes out of the box with the PowerShell tasks configured with the -NoProfile option. You can fix this through the gui (this shows I've already removed it...):

enter image description here

Or you can do it directly in the ConEmu settings, found in cmder\config\ConEmu.xml:

enter image description here

  • This really ought to be the default setup. Thank you for posting. – LexieHankins Oct 24 at 22:40

Run for check (outside of cmder of course, from Win+R)

ConEmu.exe -basic -cmd PowerShell.exe
  • Yup, running ConEmu like that does load PowerShell profiles. I'm guessing this is a cmder issue. – Francisc Aug 13 '15 at 8:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.