1

Here's my conundrum: I'm coming over from using an RV320 router from Cisco and had previously used WAN1 to connect to an ISP's given static IP:

IP: 215.114.xxx.xxx
Sub: 255.255.255.224
Gateway: 215.114.xxx.xxx

LAN setup:
192.168.1.x
255.255.255.0
Gateway: 192.168.1.1

This is simple on the RV320, you just enter these settings for Wan1. My problem is, when using the CLI for the 890 router, it seems like you almost need to use two fast Ethernet (wan ports) to do the same task. I can set the ip on fa0/0 to reflect the LAN network (able to ping internally) or the WAN (able to connect to ISP) but can't seem to accomplish this with a single WAN port as before. What am I missing here, how can I assign the router an internal IP without using a WAN port, and then just connect down to my LAN using the switch ports?

Edit and solve:

It looks like I've managed to sort through what my issue was, so I'll post for anyone that might be interested. It was a combination of two problems A) My DHCP pool was not accessing the correct router address I've since changed it to:

216.113.118.231

and B) I did not have VLAN1 up. I would love to here if anyone has any advice for my setup, but it looks like my initial question is solved.

Example Configuration (not real IPs) that I worked out in PacketTracer:

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

service password-encryption
!

hostname r1
!
!
!

enable password 7 0832494D1B1C11571F0F5E567B782726
!
!

ip dhcp excluded-address 192.168.1.1
!

ip dhcp pool LAN

 network 192.168.1.0 255.255.255.0

 default-router 192.168.1.1

 dns-server 8.8.8.8
!
!
!

username admin privilege 15 password 7 080A1D400E315407025B5F053E38
!
!
!
!
!
!
!

spanning-tree mode pvst
!
!
!
!

interface FastEthernet0/0

 description outside world

 ip address 216.113.118.231 255.255.255.0

 duplex auto

 speed auto
!

interface FastEthernet0/1

 no ip address

 duplex auto

 speed auto

 shutdown
!

interface FastEthernet0/1/0

 switchport mode access

 shutdown
!

interface FastEthernet0/1/1

 switchport mode access

 spanning-tree portfast
!

interface FastEthernet0/1/2

 switchport mode access

 spanning-tree portfast
!

interface FastEthernet0/1/3

 switchport mode access

 spanning-tree portfast
!

interface Vlan1

 no ip address

 shutdown
!

ip classless

ip route 0.0.0.0 0.0.0.0 216.113.115.249 
!
!
!
!
!
!
!

line con 0

 exec-timeout 0 0

 password 7 080A1D400E315407025B5F053E38

 logging synchronous

 login local

line vty 0 4

 exec-timeout 0 0

 password 7 080A1D400E315407025B5F053E38

 logging synchronous

 login local

line vty 5 15

 exec-timeout 0 0

 password 7 080A1D400E315407025B5F053E38

 logging synchronous

 login local
!
!
!

end
6
  • I think the RV320 is just confusing the issue as there are two "WAN" ports. You had the ISP settings on one of the WAN ports, and the LAN settings on the LAN ports. Now you have a router where this distinction isn't necessary. Use fa0/0 as the WAN ports, then create a VLAN that contains all the other ports, and assign the LAN settings to the VLAN (this was done automatically on the RV320) – Paul Aug 13 '15 at 3:41
  • @Paul Okay, how do I go about setting the lan settings for, I'm assuming the GI0-8 ports? Is it a matter of assigning the built switch ports to, let's say VLAN 3, and then creating a DHCP pool? – ParanoidPenguin Aug 13 '15 at 3:46
  • Yeah, that is right - though normally they default to vlan1 out of the box. Can you paste the config somewhere? – Paul Aug 13 '15 at 3:47
  • @Paul I've posted a quick configuration that I've come up with, as I'm no longer with the physical device. – ParanoidPenguin Aug 13 '15 at 4:15
  • 1
    No problem, though if you have identified the answer, please add it as an answer, and then accept it. That way it will help others. – Paul Aug 13 '15 at 5:12
2

It looks like I've managed to sort through what my issue was, so I'll post for anyone that might be interested. It was a combination of two problems A) My DHCP pool was not accessing the correct router address I've since changed it to:

216.113.118.231

and B) I did not have VLAN1 up. I would love to here if anyone has any advice for my setup, but it looks like my initial question is solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.