Here's what happens when I try to boot my PC: The fans spin, the HDD sounds normal, mobo light turns on, but monitor won't turn on.

At first I thought it was a problem with my monitor itself, but when I disconnect the VGA cable from the GPU, it shows the "No Signal" message. The moment I plug it back in, it goes blank and the power light (on the monitor) blinks steadily.

I tried connecting the VGA cable directly to the board but same output.

Then I thought it might be a problem with the RAM so I tried disconnecting one stick first, and booting. No beeps, fans spin, HDD sounds normal, mobo light's on, but monitor won't turn on.

Then I tried disconnecting both sticks. And, some-freaking-how, the same output! No beeps (no beeps!). Fans spin. HDD sounds normal. Mobo light turns on, but the monitor won't turn on.

What is going on here?

UPDATE 1: I just noticed the HDD activity light (on the front of the CPU) is not blinking when I try to turn the PC on. But, again, like I said, the HDD itself sounds normal. Spinning fine, no recurring clicks.

UPDATE 2: The PC turns itself off after a while; like maybe 15 seconds. I'm pretty sure this is a new symptom. Sometimes, it restarts itself, then switches back off another 15 or so seconds later. Sometimes, it stays off the first time. As of this moment, as I watch this happen, my RAM sticks are disconnected, my GPU is as well, and my monitor is plugged into the onboard graphics card. BIOS battery's in, BIOS jumper's in the right place (I'd tried clearing the BIOS earlier), and my HDD is connected.

Note: Still no beeping.

!!! UPDATE 3: I replaced the motherboard, and it started working !!!

Monitor's an LG

Board's an Intel DG31PR

CPU's an Intel i5 3337u

GPU's an ATI Radeon HD 4350

HDD's a regular Seagate 1TB

Please feel free to ask followup questions; I'm sure I've forgotten to include some detail or the other.

!!! UPDATE 3: I replaced the motherboard, and it started working !!!

  • 1
    Have you checked to see everything is plugged in? Specifically PSU power? Are there any bloated or leaky caps?
    – Journeyman Geek
    Aug 13, 2015 at 8:09
  • @JourneymanGeek: Erm. Caps? What do you mean? Aug 13, 2015 at 8:57
  • capacitors. On some older systems they often fail. Its a simple thing to visually inspect.
    – Journeyman Geek
    Aug 13, 2015 at 9:31
  • Does there appear to be any activity - does the hard drive make activity sounds, do the HDD lights blink, does the keyboard respond (e.g. caps lock)
    – qasdfdsaq
    Aug 13, 2015 at 11:08
  • I didn't see any bloated capacitors. Aug 13, 2015 at 11:30

5 Answers 5


Here is my suggestion for your problem:

1 To clarify things, dissconect all the components in your PC from the motherboard.

Those are: RAM sticks , the graphics card , all HDD/CD-ROM cables, leaving only the power supply cables on the motherboard

This is your buzzer. (this is your buzzer)

If the PC turns on, try adding one component at a time to identify the problem.

Before you go to the next step, consider replacing the power supply with a known good one, because a faulty power supply may cause the problem.

2 If it doesn't turn on, dissconect the PSU from the wall, remove the CMOS battery and hold the power button for one minute.Then connect the power supply to the wall and try to turn it on.

3 If the PC still doesn't beep, your motherboard may be the problem.To check if that is true, press with your thumb on the northbridge/chipset on your motherboard. While you hold your thumb over it not too hard (just enough), try to press the power button to turn it on.

If the pc turns on, your chipset solder is bad .In this case, contact a service or replace the motherboard.

Hope this helped you.

  • Weak chipset soldering's a new one. Sounds plausible tho
    – Journeyman Geek
    Aug 13, 2015 at 11:18
  • I did 1 and 2 already. I now wonder, though, if I didn't plug the "beeping" speaker's cable back in properly after. This is a picture (that I found on the internet) of my motherboard: media.karelia.pro/62/4624a99c2f063eb7d3f1d24e81f073c5.jpg And this is where I plugged the speaker in: dropbox.com/s/k5q8cs9yl7gcxae/f_audio.jpg?dl=0 It's at the bottom left. The red and black dots denote the wires that are on either side of the plug. Which looks like: dropbox.com/s/js8fpermsakcvz8/DSC_0074.JPG?dl=0 dropbox.com/s/12pg3d0hraqgfn5/DSC_0078.JPG?dl=0 Aug 13, 2015 at 11:46
  • Also, if a faulty PSU is the problem, how is anything else turning on at all? I'd assume nothing that's supposed to be powered by it would be. Like, the HDD, or the mobo light, or the fans. Aug 13, 2015 at 12:04
  • 2
    @NicholasRichards A faulty PSU can still make fans spin. I have experienced these problem twice. Both the times it was problem with PSU. Aug 13, 2015 at 16:29
  • 1
    @Nicholas Richards I updated my answer with a picture representing how your built-in buzzer looks like. You may not need another external one.And your thing is exactly the same thing (a buzzer).
    – snaks20
    Aug 14, 2015 at 8:02

I would also check the CPU. It can happen that it is not seated properly in its socket. The easiest test would be removing the cooler and CPU, see if there is dust or dirt on the cooler or on CPU pins or CPU socket, clean if necessary. Also check if there are any pins bent. Then put the CPU back into the socket, make sure it is arrested properly and re-mount the cooler. This is because for beeping, the motherboard needs a working CPU. Without that, it won't beep at all.

  • I tried this :/ Only to be thorough, though. I hadn't known there was a relation between the CPU and the beeping. Aug 13, 2015 at 12:14

It may be the motherboard, when everything like ram,hdd,psu,cpu works well but the bios may had got failed. So that it doesn't displays BIOS welcome screen on your display and BIOS performa the POST to verify every connected devices are working. After the POST conpletes and assume everything is fine then it will give a beep. In your case, the POST wasn't occurring so that no bios welcome message and beeps aren't found.


One thing i have done many times is removing the bios battery and removing the ram modules, cleaning the copper part of dust and reinserting them back. Sometimes this works.


I replaced the motherboard, guys, and it started working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.