30

For some reason, smooth scrolling (using the mouse wheel) was replaced on Windows 10 (in my case, at least) with scrolling of entire page and sometimes even more.

I see this on those apps for now:

  • IE
  • Edge
  • Android-Studio.
  • Chrome
  • Notepad++

Except for Android Studio, it's much worse, as it jumps more than a whole page.

That's even though I've set smooth scrolling on the mouse setting, and even on the apps themselves (including the special flag on Chrome).

How could it be? Is it a known issue? How can I fix this?

1
  • I had a similar issue. E.g. in Notepad++ it wasn't scrolling at all ... After some time Windows 10 changed something and it worked again as usual. Don't know what's up with Windows 10 ... – testing May 13 '19 at 10:52
32

Here are a couple of settings I found, which you can tweak in Windows 10 to create smoother scrolling throughout the entire OS:

  1. Method 1: Right-click on the Windows start button to start in the context menu and follow these steps: System > Advanced System Settings > Advanced > Performance > Settings > Uncheck smooth-scroll list boxes > Click Apply > OK > OK.

  1. Method 2: Open Control Panel > Mouse > Wheels tab. Here you can change the figure from 3 to 2 or even 1 if you wish. This will make any page or document to scroll 1 line at a time. If you change this setting, it would be changed system-wide, ie. for your documents as well as browsers.

  1. To accomplish browser-only smooth scrolling, try the following:

7
  • 4
    Method #1 seems to have cleared up 95% of the weirdness I was experiencing from scrolling. Additionally I'd already tweaked the setting described in Method #2, and I turn it up. I want fast but precise scrolling. +1 – Endophage Dec 23 '16 at 6:58
  • 3
    System > Advanced System Settings > Advanced > is missing a step, due to probably a few Windows update in the meantime. It is System > System info > Advanced System Settings > Advanced > – karatedog Aug 15 '19 at 20:08
  • #1 was under Adjust the appearance and performance of windows in my control panel. – Kashyap Nov 23 '19 at 11:36
  • It was Method #2 that worked for me. For some reason my setting for "lines to scroll" was very high (59). Adjusting it lower returned the effect of smooth scrolling. Thanks. – Dan Nissenbaum Feb 26 '20 at 13:32
  • The #1 setting got me 90% of the way there, but it took me way longer than I'd care to admit to find it. Easier way: type win+R > systempropertiesadvanced > Advanced tab > Performance > Settings... – robertkroll Mar 9 '20 at 20:16
0

I was facing the same irritating problem. I have the correct drivers and everything. However, I think scrolling one screen at a time is what was causing the problem. So here's how I updated that setting to make things nice again:

  • Go to the mouse settings window (follow sub-steps if you don't know how)
    • Click on the cog-wheel icon in the Start menu to access the settings
    • Click on Devices
    • Click on Mouse and touchpad
    • Click the link down below that says Additional mouse options
  • Click on the Wheel tab - it should appear if your mouse is properly connected and drivers are properly installed
  • Change vertical scroll from one screen at a time to a number of lines ata a time. I set it to 10, however, you can set it to anything you prefer.

Hope it helps! Happy scrolling!

0

none of the answers I found on Microsoft support or here worked, so I found this video and tried it out. https://www.youtube.com/watch?v=981KfZez7Ws

Even though my mouse was sparkling clean inside, rubbing alcohol with a cotton swab and carefully tightening the sensor with pliers worked A1 and solved (so far) my jumpy/jerking wheel mouse and improved scrolling.

Not the answer you're looking for? Browse other questions tagged or ask your own question.