5

We have an ASUS Zenbook UX305FA laptop running Windows 10 that is able to be woken from sleep with an external Keyboard and Mouse when they are plugged-in directly into their individual USB ports.

However, after plugging in a USB Hub and then plugging the external Keyboard and Mouse into the USB Hub, the laptop will no longer wake up from sleep with the external Keyboard or Mouse. It only wakes up if the built-in laptop keyboard is pressed. However, as this laptop is being used as a Desktop, the laptop lid is kept closed at all times, which is why we need to be able to wake the laptop using the external keyboard and mouse. We need the other USB ports on the laptop to be free, which is why we need to plug the mouse and keyboard via the USB Hub.

In Device Manager, the "Power Management" settings for both the external Keyboard and Mouse are set to "Allow this device to wake the computer" under "Keyboards" and "Mice and other pointing devices", respectively. Under "Universal Serial Bus controllers", the "Generic USB Hub" has that setting dimmed and cannot be set.

How can we get the Keyboard and Mouse to wake the laptop from sleep when plugged in via a USB Hub?

  • You may need to deselect the option "Allow the computer to turn off this device to save power" on the hub - not only in the generic hub section but also the composite device and root hub above it (some USB hubs contain both) – qasdfdsaq Aug 13 '15 at 11:16
  • @qasdfdsaq: We deselected that on all the devices under "Universal Serial Bus controllers" that have that option ("Generic SuperSpeed USB Hub", "Generic USB Hub", and "USB Root Hub (xHCI)"), but it's still not waking up. Any other ideas? – ProgrammerGirl Aug 13 '15 at 12:37
  • Can you confirm if the hub itself is still powered and active when the machine is in sleep? You can test with something like a phone charger cable and see if it outputs power, even if the device doesn't need to communicate. It could well be easier just to try a different USB hub, they're so cheap these days. – qasdfdsaq Aug 13 '15 at 13:09
  • @qasdfdsaq: Yes, the USB Hub is still powered and active when the laptop is in sleep mode. It has a blue LED light on even while sleeping. To be sure, we plugged the phone charger cable as you mentioned and it started charging the phone. So it is powered and active the entire time, yet the keyboard and mouse that are connected to it won't wake the laptop up when used. What should we try next? – ProgrammerGirl Aug 13 '15 at 16:14
  • @qasdfdsaq: Any other ideas we can test/try? – ProgrammerGirl Aug 14 '15 at 19:35
6
+100

Open an elevated command prompt (admin mode).

  1. Type in powercfg/devicequery wake_programmable

  2. Check to make sure the USB keyboard connected to the USB hub shows up on that list, which would confirm it can indeed wake up your laptop from sleep.

  3. To check what is already enabled, type in powercfg /devicequery wake_armed

  4. Type in powercfg /deviceenablewake "ExactKeyboardName" with ExactKeyboardName being the full and exact name (including parentheses, if any) of the USB keyboard that appeared in step 3 above (make sure the name is wrapped in quotes).

  5. If more than one USB keyboard showed up in the list in step 2, then repeat step 4 with each USB keyboard name.

Try now.

2

We had this same issue with some Dell laptops. Using a USB hub with an external power source solved this for us.

0

try this:

Follow the steps below to run power troubleshooter.

  1. Press Windows Key + W and type troubleshooting in the search box.
  2. Click on the Troubleshooting from the search results so obtained.
  3. Click on View all on the left pane on the next Window.
  4. Pick Power from the list so available, this would launch Power Troubleshooter
  5. In the Power Troubleshooter, you have to click Next option

This will start the automatic detection and fixing of issues,if it doesn't work,try uninstalling the USB hub driver then unplug and re-plug and check if the option is still grayed out.

  • I tried the above and the only issue it found was "USB Selective Suspend is disabled" and then "fixed" it (presumably by enabling it). Any other ideas? – ProgrammerGirl Aug 25 '15 at 23:49
0

I am using my dell XPS13 Win10 as a desktop with the same issue. I hit F2 for the boot options, and there is an option to 'wake from USB' - I selected the box (and changed the charging option to 'Primarily use on AC' to save the battery) - Issue resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.