2

TL;DR: How can I completely remove ALL remains of a (probably) broken Windows Git install so I can start fresh? Looks like something from the previous install is preventing a new one. The "Program Files (x86)\Git" folder was already removed, but nothing changed.

Using Windows 10 Pro 64-bit, I had git installed and it was working just fine. It was installed via Chocolatey, so I had the git, git.install, and poshgit packages. I was not using gitbash, the gui, or the menu integration - I was using it via powershell. I'm not an advanced git user, but I can do the very basic operations.

Suddenly, any git commands (clone, init, add, push) wouldn't execute, powershell would just go unresponsive.

I then uninstalled all of the packages, restarted the computer, and tried installing them once again. The chocolatey installer hangs while trying to install git.install while it shows "Git setup" and "Git for windows" executing in the task manager.

When trying to install using the windows installer, just to see if I can get it working again, it hangs at the end of the installation, with a "Git for windows" window open somewhere, but when I alt+tab to it, it won't come to the front.

I'm at a loss here, I had this working flawlessly before the Windows 10 upgrade, and it worked just fine too after it, for a while. It just stopped working.

  • This sounds no bueno. May I ask what choco client you used and what version? – ferventcoder Aug 14 '15 at 13:06
  • Choco v0.9.9.8, but your answer did the trick! :) – Mike Valeriano Aug 14 '15 at 16:56
1

For removing it fully, you may want to ensure that the packages are removed and it is uninstalled from the computer (programs and features). You may also need to head into the registry to see that it is fully removed from the Uninstall key, usually found at HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\Git_is1 (Windows x64) or HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Git_is1 (Windows 32-bit). I would back up the particular keys you are about to remove first and then ensure this key is removed. I would use this option as a last resort when the first two options do not work.

However, I'm curious, if it was working and then suddenly stopped working, what may have changed? Was there a Windows update (after your upgrade), or something else installed?

  • That did it! I didn't know I still had to remove/uninstall things from the Programs and Features setting, and the registry entry as well. After those and a reboot I could reinstall git/git.install/poshgit cleanly from powershell. Thanks! – Mike Valeriano Aug 14 '15 at 16:57
  • In choco 0.9.10 (coming at some point) you won't need to. In the 0.9.9 series you need to turn on the uninstaller - choco feature list and then enable the autouninstaller with choco feature enable autouninstaller. – ferventcoder Aug 14 '15 at 18:47

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.