0

So I just updated to the Windows 10 OS and now the scroll function on my touchpad does not work (cursor works fine otherwise). I have an HP Pavilion with a Synaptics touchpad, and even though a synaptics driver upgrade was included with the W10 install, I get nothing from the scroll bar. Furthermore, I don't have the synaptics control panel (I have no idea why not, I've never had it), when I click the synaptics button on my tray I just get the mouse properties window (I can't post images, but it's the one with the buttons, pointers, hardware, device settings, etc tabs). What can I do?

  • 3
    Try this search query and see if any of the questions are relevant to your situation. It's quite possible that this is a duplicate of an existing question on the site. – a CVn Aug 13 '15 at 19:03
  • ^ Synaptics has been causing a lot of problems... – MC10 Aug 13 '15 at 19:04
  • @MichaelKjörling I already checked all those, nothing listed in those answers has helped me. :( – Patience Aug 13 '15 at 19:27
  • Even uninstalling the driver? – MC10 Aug 13 '15 at 19:47
  • @MC10 I uninstalled and tried to reinstall, but kept getting a failed installation message. – Patience Aug 14 '15 at 2:23
1

Synaptics has a new windows 10 driver on their site. I've got a new HP Spectre x360 with a Synaptics touchpad (same as what most PC manufacturers have been using, Dell, Lenovo, ASUS, etc). There is some minor quirky behavior associated with the 3-finger swipe (which is REALLY useful in Windows 10...multiple desktop access for example). No guarantees but this may get you the working driver you need....and fix the issue with 3-finger swipe disappearing.

Download the latest Synaptic Touchpad driver from their website at:

http://www.synaptics.com/en/drivers.php

You'll need to pick the right one as I see two listed for Windows 10:

  • Windows 10 PS/2 and SMBus Devices v19.0.19.1
  • Windows 10 I2C Devices v19.0.19.1

For my laptop (and most PC's) its the PS/2-SMBus version. I also noticed that they've posted a more update version than the one I downloaded and installed (19.0.12.98), so things may have changed regarding this issue on the disappearing "3-finger swipe".

After downloading, install it. Restart your PC. Play with it a bit, including putting your PC to sleep a few times to see if the 3-finger swipe breaks. If it does:

  • Right-click on the Windows icon.
  • Select Task Manager
  • Click on the Services tab
  • Scroll down to the SynTPEnhService
  • Right-click on that and select "Open Services"
  • Scroll down that new list to SynTPEnh Caller Service
  • Select "Stop"
  • Test your trackpad for proper functionality.
  • If all is working well and your 3-finger swipe is now working, Change the "Startup type" from "Automatic" to "Disabled".

That's it. Play with it for a while. Restart your pc and do a little more testing by putting the PC to sleep and ensure that it's working properly.

0

I checked this out with Acer tech support on the 29th July after installing windows 10 They told me they are working on a driver that is compatible. However they couldn't say how long. Just to check out the support page every few days to see if there is any news!!! No news to date!!!

  • "They" as in Acer is working on a compatible driver, or Synaptics? – Patience Aug 13 '15 at 19:44
0

You should try to reinstall the driver using the latest driver on this page:

http://www.synaptics.com/en/drivers.php

(currently it's Windows 8/7/XP/Vista 64/32-bit Edition v17.0.19)

If it still doesn't work, you should wait until Synaptics release an official driver that supports Windows 10.

  • I hope they release a new one soon, I tried that and something goes wrong with installation, causing it to fail every time. – Patience Aug 14 '15 at 2:23
0

Even 2 years after your question the problem still exists. I didn't mind it for a long time, until today.

Before I fix the problem I had the latest driver update which is 19.0.xxx. I'm using Windows 10 btw. I tried many solutions but let's cut the preamble and come to the solution that worked for me:

  1. Uninstal Synaptic driver.
    • Go to Settings > System > Apps & features, uninstall Synaptics Pointing Device Driver
  2. Restart windows.
  3. Download version 18.1.7.8 here.
  4. Install the downloaded driver.
  5. Then here comes the hack:
    • Open Registry Editor (Windows + R, type regedit and hit Enter)
    • Go to HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPEnh
    • Create a new DWORD called UseScrollCursor with a value of 0.
    • Restart windows.

And done, you have a scrolling touchpad.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.