0

If I go to this link

http://www.moreshesashkenaz.org/mm/publications/MadrichEnglish.pdf

sometimes (maybe always), I get a 404 error

By luck one time I clicked it it managed to load.

Then I hit shift-F5 and it failed. Though now I find shift-F5 and it still loads.

When it hasn't loaded, i've had this message

enter image description here

Though sometimes it does load.

I haven't had it fail with wget yet though I guess that's just chance.

What might be the cause.. Maybe the server is under a huge workload?

I'd be interested if there is anything I can do my end to ensure the link loads though I guess it's an issue their end, and there's nothing I can do.. in which case i'd still be interested in what might cause that.

  • 1
    It seems like the message window covers the possibilities. Surely you aren't asking people speculate on what might be going on at the host? Why not just click on the home page and look for a way to contact the site administrator and ask about the link? – fixer1234 Aug 14 '15 at 5:12
  • @fixer1234 well yeah point 6 that an error occurred while processing the request, would cover anything, but that's obviously not what i'm looking for is it, It's no great revelation that an error occurred, is it. I suppose I could email the admin but maybe people here that run web servers might have some ideas what can cause the issue. I'm interested in what can potentially cause it. – barlop Aug 14 '15 at 5:19
  • 1
    Just a suggestion--asking what you described in your comment is a better question than asking about a specific link (which can be interpretted as asking people to speculate on why that link is misbehaving). The potential causes of a 404 is a much clearer, fact-based question. – fixer1234 Aug 14 '15 at 5:52
  • 2
    @fixer1234 The potential causes for a 404 are whatever the website designer wants them to be. He can return a 404 just because he feels like it or because Tim Post lost his keys ;) On a more serious note en.wikipedia.org/wiki/HTTP_404 answers that quite well. – DavidPostill Aug 14 '15 at 7:47
  • 1
    @Divin3 It is not possible to debug. We can't see the source of the website. how it is configured, etc. The Tim Post was a joke :/. It is a 404 error because the webmaster said it was. It this so difficult to understand? – DavidPostill Aug 14 '15 at 10:58
3

Why is the pdf at this link periodically giving a 404 error?

Short answer:

It is not possible to debug. We can't see the source of the website, how it is configured, etc.

Long answer:

There are commonly accepted reasons for 404 responses (see HTTP 404 for some examples) but a website can be configured to return 404 for any reason at all (depending on what the website author decided to do with a particular request).

There is nothing preventing the return of a 404 error because it happens to be Friday today (to give an example) or because Tim Post lost his keys.

It is entirely up the the author of the website.

As the website appears be be reasonably secure we don't have access to its configuration or source code so we have no way to find out.


What do we know about the website

It uses the following:

  • PHP
  • SSL
  • JavaScript
  • MooTools
  • Joomla

and a bunch of other technologies.

None of this is accessible from outside so it doesn't help to debug your issue.

Source Site report for www.moreshesashkenaz.org


Debugging with firefox

Request headers:

Host: www.moreshesashkenaz.org
User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:40.0) Gecko/20100101 Firefox/40.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-GB,en;q=0.5
Accept-Encoding: gzip, deflate
DNT: 1
Referer: http://www.moreshesashkenaz.org/mm/publications/
Cookie: 4957186c87cf302cf91cc7d50c18a108=S%2CSKrRvB%2CMirDEhhz%2CPgH2; jfcookie[lang]=en
Connection: keep-alive
If-Modified-Since: Fri, 14 Aug 2015 11:14:25 GMT

Response:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en-us" lang="en-us" dir="ltr">
<head>
    <title>404 - Error: 404</title>
    <link rel="stylesheet" href="/templates/system/css/error.css" type="text/css" />
    </head>
<body>
    <div align="center">
        <div id="outline">
        <div id="errorboxoutline">
            <div id="errorboxheader">404 - Component not found</div>
            <div id="errorboxbody">
            <p><strong>You may not be able to visit this page because of:</strong></p>
                <ol>
                    <li>an <strong>out-of-date bookmark/favourite</strong></li>
                    <li>a search engine that has an <strong>out-of-date listing for this site</strong></li>
                    <li>a <strong>mistyped address</strong></li>
                    <li>you have <strong>no access</strong> to this page</li>
                    <li>The requested resource was not found.</li>
                    <li>An error has occurred while processing your request.</li>
                </ol>
            <p><strong>Please try one of the following pages:</strong></p>
            <p>
                <ul>
                    <li><a href="/index.php" title="Go to the Home Page">Home Page</a></li>
                </ul>
            </p>
            <p>If difficulties persist, please contact the System Administrator of this site.</p>
            <div id="techinfo">
            <p>Component not found</p>
            <p>
                            </p>
            </div>
            </div>
        </div>
        </div>
    </div>
</body>
</html>

Note the css included in the response:

/templates/system/css/error.css

This includes the following comment:

/**
 * CSS Document for offline page
 * @version $Id: error.css 14401 2010-01-26 14:10:00Z louis $
 * @package Joomla
 * @copyright Copyright (C) 2005 - 2010 Open Source Matters. All rights reserved.
 * @license GNU/GPL, see LICENSE.php
 * Joomla! is free software and parts of it may contain or be derived from the
 * GNU General Public License or other free or open source software licenses.
 * See COPYRIGHT.php for copyright notices and details.
 */

Note the following:

CSS Document for offline page

The website is including this CSS because it has been coded (for whatever reason) to return this for "offline pages".

  • This is a really nice answer. Well composed. This deserves the +1 even for the effort You put in it. I miss only a single thing: You don't talk about the actual main question. What can be the difference between copy-pasting a link to the address bar of the browser or opening it trough a hyperlink? – Divin3 Aug 14 '15 at 11:48
  • I don't see this in your question (only in a comment to another answer). If you are referring to the link moreshesashkenaz.org/mm/publications then I've no idea. I cannot think of a way to debug this. It could just be a browser bug. – DavidPostill Aug 14 '15 at 12:08
  • I have tried that on different browsers and it acts the same, so it can not be a browser bug. – Divin3 Aug 14 '15 at 12:36
2

Personally I know only basics of html coding and web servers but let's see the facts what we can find out here:

  • If we open the link http://www.moreshesashkenaz.org/mm/publications/MadrichEnglish.pdf
    sometimes works, sometimes 404

  • If we open http://www.moreshesashkenaz.org/mm/publications/
    when I opened it first, the files were visible and the links were working, now they all disappeared EDIT: I realized it was working for me because after opening it, I have deleted the MadrichEnglish.pdf-ending and reloading the page (not by refreshing) makes it work.

  • Pinging www.moreshesashkenaz.org (66.33.211.53) gave a fine result so I don't think it is because the server is overloaded

  • I have left http://www.moreshesashkenaz.org/mm/publications/ opened when it loaded in a tab. The interesting thing is, that if I open it now, the list is empty, but from the tab where it loaded before, the links are still working fine.

  • It is getting more interesting as I keep testing because if I copy the URL of the tab where the list is empty and paste it into another tab, the list loads, but if I open it as a new link for example from this link http://www.moreshesashkenaz.org/mm/publications/ it gets empty again.

  • Also if I copy the link into a word document, and open it from there, the link is working again.

I hope these information will ring a bell for someone and give an appropriate answer, I can only guess that this has something to do with character encoding.

EDIT:

  • Tested the link with Internet Explorer, Chrome, Waterfox(*64 bit version of Firefox), on IOS with safari and - got the same results: Copying the link to a new tab makes the links load, opening the page as hyperlink doesn't load properly.
    Opening the link with the Stack Exchange app results the page to work properly and load the links as well. I also tried to open it with Facebook app and the links failed to load again.
  • So: just a crappy server. And no: surely not related to character encoding. Why would you think random behaviour would be caused by that? Also note that pinging does not actually hit the web server on the machine. – Arjan Aug 14 '15 at 8:40
  • @Arjan - That is no question that it is a crappy server. This is not random behavior, it is a bug. The URL is loaded if I copy the link and paste it to the address in the browser; and doesn't work as a hyperlink. My guess was the character encoding because copying the text might change it in a way that we do not see. You are right about the ping, we can not determine the server load after pinging, but the page loads every time if You copy-paste the URL, so it must be something else. – Divin3 Aug 14 '15 at 8:56
  • "The URL is loaded if I copy the link and paste it to the address in the browser" -- then cookies or REFERER magic. There's just too many options, but character encoding is not one of them. The URL has no weird characters at all. – Arjan Aug 14 '15 at 9:04
  • 1
    wget continues to not fail.. and you can do wget url --debug maybe a web browser extension can show what happens re headers, and will then show it when it doesn't work – barlop Aug 14 '15 at 10:16
  • 1
    @Divin3 Maybe i'll drop them an email some time.. and if I get a response i'll reply back here and @ you to let you know – barlop Sep 10 '15 at 5:19
-1

Try to add following into your .htaccess file :

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteRule !(js|ico|gif|jpg|png|pdf|css|swf|flv|libraries|maint|admin|login|logout|reg) index.php [QSA,L,NC]
</IfModule>

I had the same problem with PDF (and other file types), then my hoster informed me to add NC for RewriteRule

  • Please read the question again carefully. Your answer does not answer the original question. The OP is not the owner of the website, so he cannot change .htaccess – DavidPostill Apr 18 '16 at 11:00
  • @DavidPostill It may well answer it to an extent, in part, and in outline.. because if it is the case that the error is that that line should be ont the server and isn't, then that would in theory, be part of the way towards the answer, the other part would be if that is the case, then why, and he has suggested that he doesn't know why but his hosting provider has said so when he had that issue, which is fair enough. – barlop Apr 18 '16 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.