23

I have tried to setup VirtualBox on Ubuntu, but I get this error even though Intel virtualization technology (VT-x) is set to Yes in the BIOS:

Failed to open a session for the virtual machine Ubuntu.

VT-x is disabled in the BIOS for both all CPU modes > (VERR_VMX_MSR_ALL_VMX_DISABLED).

Result Code: E_FAIL (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

EDIT: according to SecurAble my system is able to handle virtualization:

Securable screenshot

  • That setting is disabled in your BIOS. You will have to enable it. – MC10 Aug 14 '15 at 14:01
  • 1
    possible duplicate of How do I enable VT-X? – MC10 Aug 14 '15 at 14:01
  • 1
    @MC10 --- Virtualization Technology setting is enabled in my bios. I already checked that. – user2676140 Aug 14 '15 at 14:03
  • 2
    Then have you enabled it in the VirtualBox settings itself? I can't think of where else it is going wrong. Maybe see the info here. – MC10 Aug 14 '15 at 14:07
  • 1
    @MC10 that was the case --- You are trying to allocate >3GB of RAM to the VM. Similar to the previous point, this requires: (a) a 64 bit host system; and (b) true hardware pass-through ie VT-x. – user2676140 Aug 14 '15 at 14:11
40

What solved my issue was using less than 3 GB of ram in the virtual box session. I was originally attempting to utilize roughly 6 GB.

You are trying to allocate >3GB of RAM to the VM. This requires: (a) a 64 bit host system; and (b) true hardware pass-through ie VT-x.

  • 3
    This is so weird, it used to work for me and I hadn't changed anything (I had RAM set to 4GB). Thanks for posting this. – naveed Oct 23 '15 at 21:05
  • 1
    Have the exact same issue. Been using my VM on 8GB for months and today for no reason it's complaining about VT-x even though it is enabled. Must be a bug in VirtualBox. Dropping to 3GB takes it further but I can't run my 64bit Guest OS now since it thinks it's on a 32bit architecture and is incompatible. :( – Jahed Feb 9 '16 at 22:11
3

In my case Memory(RAM) was not a problem, just VT-x wasn't enabled in BIOS. Or in some cases, CPU may not have support of VT at all.

To check whether your CPU supports it or not. try:

sudo apt-get install cpu-checker
sudo kvm-ok 

Second command will output if VT is enabled or not or if it's available at all.

If it does, go to BIOS and enable it. It should be named Intel Virtualization Technology, Intel VT-x, Virtualization Extensions, Vanderpool, or something similar.

1

My error was VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED). Result Code: E_FAIL (0x80004005) Component: ConsoleWrap Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Solution is you should switch on the virtualization in the bios of the host operating system(i my case it is windows)

  • Can you provide an answer for OP question? – yass Apr 12 '17 at 12:42
0

I've been dealing with this issue for a few hours, trying to solve it with probably all the answers I could find on the Internet.

What have worked for me was removing Hyper-V role from my Windows...

MJ

  • What was your VTX error you were getting? – user2676140 Jul 7 '16 at 13:42
  • Same for me. I was getting "VT-x is not available". Elaborated that here – eis Oct 25 '16 at 19:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.