12

I have a DELL E7450 laptop connected via an HDMI cable to a DELL UP3214Q monitor (which can display 3840x2160 @ 60Hz with a DP1.2 cable) . Ubuntu 14.10 uses the 3840 X 2160 resolution just fine - although @ 30Hz (which I don't mind). No drivers required. xrandr shows:

HDMI1 connected 3840x2160+1920+0 (normal left inverted right x axis y axis) 698mm x 392mm
   3840x2160      30.0*+   25.0     24.0     30.0     24.0  
   1920x1200      60.0  

Ubuntu 4K

But Windows 7 64-bit only sees 1920x1080 as the maximum resolution. The Intel HD Graphics 5500 settings allow for custom resolutions, but the maximum I could set was 2560 x 1440 @ 30Hz. Beyond that, everything would error with

The custom resolution exceeds the maximum bandwidth capacity

This error is obviously completely bogus!

Also, I accidentally managed to get 3840x2160 @ 30Hz as a regular resolution in Control Panel after I booted back from Ubuntu into Windows once. This trick didn't work after rebooting windows once again to install some updated. I hadn't installed anything else in Windows, or changed any settings. Before booting into Ubuntu, I had rebooted Windows several times, so I'd rule out rebooting itself as a solution. Could Ubuntu have written some information to the graphics card or the monitor?

Other things I've tried - nothing worked:

  • Installed the Dell Display Manager: it can't do anything about resolutions
  • Installed Entec PowerStrip. It detects the maximum resolution but can't set it, even after adding it from Custom Resolution. enter image description here
  • tried to install Intel's native HD Graphics driver, but is says "The driver being installed is not validated for this computer. Please obtain the appropriate driver from the computer manufacturer."
  • updated Dell's Intel HD video driver
  • I've already installed the monitor driver and the monitor shows correctly by name in Device Manager. Still, no native resolution shows up anywhere.
  • Custom Resolution Utility allegedly doesn't work on Intel graphics cards. I've run, and it gave no error about the graphics card being Intel. It flickered the monitor and ultimately reset it 1920x1080, but didn't help at all with 4K.
  • Display Changer - seems to just pick up whatever resolutions are in the Registry
  • disconnect the laptop's internal display, and only "connect to projector"

There's an Intel Community thread on the buggy "The custom resolution exceeds the maximum bandwidth capacity", but the Intel rep there isn't listening.

This is a nearly $2000 4K monitor that doesn't display 4K in Windows 7.

What else can I try?

  • This says maximum resolution is HDMI: 4096 x 2304, 3840 x 2160 @ 24 Hz / 24bpp. Not sure why it would be different in Ubuntu. Was the 60Hz actually there? – MC10 Aug 14 '15 at 16:25
  • @MC10: actually I didn't explicitly see 60Hz (added a screenshot), but never saw anything slower than I'm used to. By comparison, the 30Hz custom resolution in Windows was just bad - even the mouse moved visibly more slowly. – Dan Dascalescu Aug 14 '15 at 16:56
  • @BalaSivakumar: what do you mean? On the exact same hardware combination, Ubuntu handles the resolution just fine. I simply want the same in Windows. – Dan Dascalescu Aug 14 '15 at 17:05
  • Hmm that's weird. I wonder if there's some limitation of Windows that Ubuntu does not have. What does xrandr output for the Ubuntu? It should show a Hz value. – MC10 Aug 14 '15 at 17:41
  • @MC10 As indicated by the xrandr line, it’s 30 Hz. Which is what you could expect over HDMI 1.4. Sadly, I couldn’t get that resolution to run with my Sandy Bridge notebook. :( – Daniel B Aug 16 '15 at 10:13
2

The only thing that has worked so far was buying a Mini-DisplayPort to DisplayPort 1.2 cable. 3840x2160 @ 60Hz works great now.

It's disappointing that the Intel folks refuse to acknowledge the "maximum bandwidth exceeded" bug.

  • @fixer1234: I'm so incredibly frustrated by this. – Dan Dascalescu Aug 25 '15 at 15:53
  • "What doesn't kill you makes you stronger." :-) – fixer1234 Aug 27 '15 at 21:45
  • @DanDascalescu - Im not sure if this is one of the speed breakers but both DP & HDMI standards for 4K is kind of in flux these days - video cards, cables etc. Maybe that HDMI cable has limitations and is not compliant to the higher than 1080p spec or querying Display via it had issues . And maybe Ubuntu bypasses the querying. lots of such stuff on overclock.net forums – Alex S Aug 27 '15 at 22:25
1

The Intel HD Graphics 4000 drivers for Windows allow the creation of custom resolutions. (I know, why on earth would it not recognize the 4k standard like Linux does!?) Anyhow, on this dialog box create a 3840 x 2160 pixel resolution at 24Hz AND(!!) Select CVT-RB as the Timing Standard. It should ask you to confirm, then close that app. Next time you plug in the monitor (it does have to be rediscovered by Windows) and open up the Windows Display Settings dialog box, pick the 4k monitor, in resolution, you will have the option to pick 3840x2160 - it should even have the tag 'Recommended'.

  • You seem to be saying what to do but not how to do it. How does one create a custom resolution? (Also, the OP has already tried custom resolutions without success.) – Scott Sep 30 '18 at 18:11
  • the OP did do a custom resolution - and set it to 30Hz. I am informing that the correct setting is 24Hz, and to tweak the timing standard to CVT-RB. – Mark van der Pol Nov 29 '18 at 23:30
  • This worked for me. Right click on Intel Graphics in system tray, choose options, and custom resolution. The trick is to use a lower refresh rate, 30fps worked for me. Windows 10 and the same problem exists.... – wcndave Aug 14 at 13:48
-2

Intel HD Graphics 4000 can handle 4K @ 30p Hz with this steps and special Monitor

  • Mac Mini Late 2012 with "Intel HD Graphics 4000"
  • Boot Camp Installation of Windows 7
  • Install Intel HD Graphics 4000 Drivers version 9.17.10.3347 (Legacy) find this inside Boot Camp @ support.apple.com/kb/DL1720?locale=en_US Path: \BootCamp\Drivers\Intel\BootCamp5.1.5621.zip\BootCamp\Drivers\

  • Samsung Monitor 4K U28E590 This the the trick! This monitor have Picture in Picture Option.

  • From the windows Bar Open Intel Graphics Properties

  • Advanced Mode
  • Display --> Custom Resolutions
  • Width=1920, Height=2160, Color Depth=All Colors, Refresh Rate=30, Timing Standard=CVT-RB ---> Add
  • Restart your Computer.

  • Connect both cables Mini-Port--> HDMI, and HDMI-->HDMI to this monitor

  • On the monitor turn on Picture in picture and split in two the screen
  • On Windows, Rich click on the Desktop --> Screen resolutions and arrange both displays like this image

Hope this helps

Now I need to figure it out how to do this on OS X El Capitan, cause I know tha is a fact that this Video Card is fully capable of 4K with this Monitor :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.