34

I am running Windows 8.1 and am trying to download Windows 10 for installation on another machine. I have a brand new 4GB SanDisk Cruzer Blade USB drive that has been formatted.

In the Media Creation Tool, I select the options I want, Create installation media for another PC, English (US), Windows 10 Pro, 64 bit, USB flash drive. On the Select a USB flash drive step, I get the message "We can't find a USB flash drive".

I have tried the front and rear ports of the PC, formatted FAT32, formatted NTFS, quick and full format. Device properties shows Disk drive on USB Mass Storage Device. Drive is the default Windows driver, 6.3.9600.16384, 6/21/2006.

6
  • 2
    It could be that the size of the 64-bit installation is a bit larger than the formatted 4GB drive. There was a similar problem for 8.1. You could try using Rufus. – MC10 Aug 14 '15 at 16:30
  • docs say it needs an 8GB stick [can't remember where, but it does] – Tetsujin Aug 14 '15 at 16:32
  • 2
    Docs say 4gb – Moab Aug 14 '15 at 16:52
  • 1
    The Setup tool says "It needs to be at least 3 GB". I think this is based on options you select, choosing Both (32 and 64 bit) changes the requirement to 6GB. – user15741 Aug 14 '15 at 16:58
  • @Moab - my bad, thought it was 8. Checked my installer, says 3.11GB used [though it's on an 8GB stick, maybe that was my confusion] – Tetsujin Aug 14 '15 at 17:47
17

The Sandisk Cruzer usb drives use drivers that install through windows 7 and 8 as if they were hard drives. They are not in the removable drives section and that is why it will not allow you to select it.

5
  • I've noticed that there are different versions of the MCT - different sizes. The smaller versions won't work correctly with USB, where the larger do - to the exact same drives on the same computer. Believe it is more of a bug with the tool. I've created on Verbatim, Lexar, Sandisk USB drives. – Blackbeagle Aug 3 '16 at 18:24
  • 7
    This explains the cause of the issue, but it does not seem to provide a solution. – O. R. Mapper Oct 24 '16 at 9:48
  • I have a Sandisk Cruzer running on Windows 7. It is removable ... wmic drivetype is 2 (removable). – DavidPostill Nov 6 '16 at 20:38
  • It didn't work for me with Scandisk, so I bought a new 16GB Philips usb 3.0 and the same thing happens. I will just go with saving the iso and burning it with rufus. – samayo Dec 20 '16 at 12:41
  • Tried Lexar, Verbatim, SanDisk... ALL gave the same error on a WIn 7 platform. Doesn't appear to be maker specific. – Blackbeagle Mar 21 '17 at 19:14
27

Using a suggestion from MC10 in the comments, I downloaded the ISO and used Rufus to configure the USB drive as bootable. The configuration and install worked fine and there was about 700 MB free on the thumbdrive after configuring it.

I still could not identify the cause of the failure, whether the Media Creation Tool incorrectly viewed the USB drive as too small or if there is another problem that makes the USB drive not appear to be valid to the tool.

3
  • That Rufus was easy to use and did the trick. – James Dec 5 '16 at 7:21
  • Which on of the 3 options did you choose for the partition type? – samayo Dec 19 '16 at 16:20
  • Where do I send the case of beer to he who wrote Rufus (and saved me evenings of heartburn)? – smirkingman Mar 24 '17 at 22:17
6

I suffered the same problem with a Sandisk USB.

To fix: I followed the standard USB install instructions, with one deviation. I used Rufus to create the bootable USB.

  1. download Microsoft MediaCreationTool
  2. use the tool to create an .iso
  3. use Rufus to create a bootable USB with the .iso
2

From Windows 8 we don't have to create bootable pen drive with software. Just format your pen drive and copy paste all files of ISO to the pen drive. That's it. I used this method to install Windows..

Note: Use UEFI boot option instead of Legacy.

1

I had same porblem with external hdd and also with usb drive. I tried all USB 3.0 ports and it didn´t work so I tried to plug them into USB 2.0 port and it work perfectly. So you should try to plug it into USB 2.0 because windows creation tool probably have some problem with USB 3.0 ports.

1
  • This should be selected as the default solution - as soon as I plugged my flash USB in a 2.0 port it was properly recognized by the media creation tool. – scooterlord Jan 10 '18 at 21:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.