Windows 10 lets you 'schedule' a reboot for later. I want to disable it.

Evidently Windows scheduled itself for a reboot last night when I wasn't looking and just closed everything I had been working on the night before.

I reboot on the regular; I don't need Windows to do that for me.

Can I disable it completely? I don't mind if it downloads everything, and then says "hey, you should reboot," but it should never reboot itself, ever.

I'm using the "Pro" edition of Windows 10.

  • 37
    The "Anniversary Update" now has an option to have it install when you're not using the computer, but that's not really any better. Sometimes I leave downloads or long-running processes overnight which Windows murders and hides the results of. – mpen Aug 19 '16 at 16:02
  • 4
    There is another effective solution here: justpaste.it/HowDisableWindows10Update – Rob Aug 25 '16 at 5:54
  • 1
    A suggestion for MSFT . . . why not have a series of gradually more draconian notices. Like a "Delay for 1 day" option the first time; "Delay for 6 hours" the second time, then 3 hours, 2, 1. I get it; for security purposes, you need to have the update happen. But this is at least a bit more polite to users. – William Jockusch Dec 21 '16 at 15:51
  • 11
    Even worse, my PC wakes up from hibernate to perform this function, then sits there freshly rebooted for the rest of the night. Will Microsoft be paying my electricity bill? – Lightness Races in Orbit Jan 13 '17 at 10:02
  • 4
    Sadly the top voted answer by Windos is both complex, out of date and certainly does not work for the Home edition (it may not work for any edition for all I know). FYI Erwin's much simpler answer has worked continuously up to today (Jan 2018). There are other answers that look promising but I have not tested them. With 250,000 views this issue is obviously super-important to many people... I think the admins here should allow this question to be re-asked to ensure that the up/down votes reflect the current state of the answers. – Mick Jan 24 at 15:23

12 Answers 12

Note: Unfortunately this appears to not work on Windows 10 Home, and I'm note sure of a workable solution for users of this edition.


I posted this as an answer on another question, but as that appears to be a duplicate of this question I'll provide it here too:

You can edit your local group policy settings to force Windows update to only download updates, but wait for your input to install (and therefore reboot.)

Open you start menu and type Group, then click Edit group policy

Expand Computer Configuration \ Administrative Templates \ Windows Components \ Windows Update

Local Group Policy Editor - Windows Update

Double click Configure Automatic Updates and enable the policy, and configure it as needed.

Configure Automatic Updates

Head back to Windows Update and click Check for updates, once it is done click on the Advanced options

You should see your new settings being 'enforced.'

Enforced Windows Update settings

After applying this setting on a test VM, I left Windows Update open and noticed it start downloading.

Windows Update Downloading

When it finished downloading, you get a toast notification that there are updates and you need to install them.

Windows Update manual install

Note that you must click install now. Restarting or shutting down from the start menu does not appear to trigger the install process.


More info:

I'm not sure if editing Local Group Policy is an option in the Home edition of Windows 10, but the same result should be possible through the registry (I haven't tested this as I used the policy method myself.) Including this in case non-pro users come looking for an answer too.

  1. Press Win + R and type regedit then hit Enter
  2. Navigate to HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\WindowsUpdate\AU
    (you may need to create the keys manually if they don't exist)
  3. Create a new DWORD value called AUOptions and enter a value of either 2 or 3.

    2 = Notify before download
    3 = Automatically download and notify of installation

  4. Restart PC

  5. Check for updates
  6. Inspect Advanced Settings

Update following Anniversary Update (1607):

I've seen a lot a few comments lately from people saying this no longer works after the Anniversary Update.

I've been running some tests, detailed in the two blog posts here:

These tests have been running for nearly three weeks and I am yet to see any forced reboots.

In light of these results, it appears that this does still work.

Windows 10 Professions Screenshot - 20 Days up time

Things to keep in mind:

  • I did not set any settings around Active Hours or the Reboot Options.
  • DO NOT click the 'Install now' button within the Windows Update UI unless you're ready to install and reboot. Once the updates are installed, there is no stopping Windows from deciding to reboot.
  • Windows will nag you with Toasts, Action Center alerts and banners across your screen. As long as you don't install the updates you're fine (but do do them eventually.)
  • 6
    I used that settings on my Win10 Enterprise and it evidently restarted itself this weekend (Saturday 3:31 AM that was). There has to be an additional switch to disable that annoying behaviour. – mbx Aug 31 '15 at 6:17
  • 5
    @windows I already had "No auto-restard with logged on users for scheduled automatic updates installations" enabled in the group policy editor. Hasn't helped so far. – mbx Sep 1 '15 at 6:12
  • 3
    I'm not sure if this works any more in the Anniversary Update (1607), the interface and options have changed somewhat. Still testing. – Windos Aug 10 '16 at 9:36
  • 146
    Why is it not a simple checkbox in settings: "Don't destroy my work when I'm not looking" comes to mind as accurate verbiage. I'll even take "Don't restart while PuTTY is running" is a close second. Why always with the reg hacks. – Brandon Aug 29 '16 at 13:54
  • 22
    Consider this a 'me too' answer, but even with these changes made it still reboots (Win 10 Anniversary Update). Extremely frustrating. Work lost, session gone, infuriating. – Jeroen Ritmeijer Sep 1 '16 at 8:40

I have answered this as part of my attempt to fix another garbage setting in Windows 10 (the way it will wake your device up, and you in the process, to install updates you haven't approved.)

Please consult Step 2 of my guide here. It explains how to modify the "Reboot" task in the "UpdateOrchestrator" section of the Windows Scheduled Tasks list to disable it and stop Windows from interfering with it. With this task disabled, your machine will never reboot unless you instruct it to.

Cheers - Seagull

  • 16
    Your link is within the site, so there isn't much risk of it breaking. But it's still better to make answers self-contained. Consider adding the essential information here and leaving the link for attribution to the other answer. If you're just going to redirect the reader somewhere else, that can even be done in a comment. – fixer1234 Aug 31 '16 at 18:50
  • 1
    This is it! I was confused how the stupid thing managed to reboot my PC even when the service wasn't running, and this was the cause! Who'd of thought that some buried Scheduled Task that Windows Update would tweak was the culprit the whole time. Now the updates can be downloaded and installed, but I can reboot when I want to. Not whatever restrictive idea of "Non-Active Hours" Windows thinks I'm not using my computer. – japzone Nov 3 '16 at 22:54
  • 2
    Unfortunately this doesn't work anymore either. Windows will silently re-enable the task as well as ignoring the file permissions and resetting them too when an update is run. – qasdfdsaq Nov 5 '16 at 13:55
  • I can't verify that. – seagull Nov 5 '16 at 17:34
  • 1
    Still can't verify. I updated my Windows 10 to the latest version – 14393.447 – and my "Reboot" task has not had its permissions interfered with. Task Scheduler in Administrative Tools still says "disabled" for this task. – seagull Nov 10 '16 at 19:11

The best solution to this annoying problem is with Task Scheduler.

Click Start and type Task Scheduler

Navigate to Task Scheduler Library >> Microsoft >> Windows >> UpdateOchestrator

To disable automatic reboots right-click on Reboot and select disable.

enter image description here

Then be sure change the permissions. Should be set to Read & Execute

I also disabled automatic updates by disabling all the tasks in this folder.

  • Testing this tonight, but I think this would qualify as the best answer to the question how to disable just the reboots, not the updates. – Thomas Sep 30 '16 at 21:17
  • 5
    @ppvi I wish, but no, it still rebooted – Thomas Oct 4 '16 at 15:33
  • 3
    This didn't work for me either (with Windows 10 Home) because the system just re-enabled it. This other answer suggests that you do the same thing, but that you also have to change the permission to keep Windows from re-enabling it: superuser.com/a/1125051/139323 – orrd Oct 5 '16 at 7:15
  • 2
    qasdfdsaq is right. I had the task disabled for a week then last night my machine rebooted. Looked at the task and it was enabled. Just like the update service, if you disable it Windows will enable it again. Now I'm going to see what deleting it will do. I suspect it'll just get added back. Windows 1607 (14393.447) – Justin Emlay Nov 10 '16 at 14:04
  • 1
    nircmd is not a windows native messaging utility. For Windows 10, "msg" however is, so for those who don't want to download other tools, just use %windir%\system32\msg.exe * /SERVER:localhost "Windows needs a reboot to finish its updates, please restart ASAP." as the reboot action instead. I strongly suggest also you EXPORT the task first before making changes to it so you have a backup (always a good idea just in case). – James Wilkins Mar 29 '17 at 7:18
up vote 27 down vote
+250

You can try Windows 10 Reboot Blocker:

A simple Windows-Service that will update this "active hours" timeslot in the background.

It is free and works with the Anniversary update.

  • 2
    I like it. It seems well done, has installer and uninstaller and the executable has a valid signature. What it does is very simple and a good idea: it's just the same as if you were manually telling windows every hour that your normal working hours are the next 12 hours and it should not restart during this time. – maf-soft Jan 13 '17 at 9:39
  • 1
    I haven't tried, but I wonder if this can easily be done via the command line and a task scheduler. ;) – James Wilkins Mar 29 '17 at 7:26
  • 1
    Windows will install updates automatically but not reboot automatically behind your back (such a basic feature that is missing!). You can just check Windows Update to find out if a reboot is pending and do it when the moment is right. – Erwin May 12 '17 at 17:42
  • 2
    FYI... You don't need freeware non-Open Source 3rd party software to this though as per the link only answer you provided this may work for now but what exactly does this logic do behind the scenes we may not know 100% for sure. You can control when post Windows Update reboot operations occur as per superuser.com/questions/957267/…. Maybe not as simple as link only answer but native to Windows at least and you see and control exactly what it does. Once you get it setup, it is really simple though. – Pimp Juice IT May 18 '17 at 15:32
  • 2
    July 24th 2017: Since installing Reboot Blocker - two and a half months later I can confirm that my PC has still never rebooted without my consent. – Mick Jul 24 '17 at 12:03

You can use Windows' own tools against it to disable automatic reboots.

As some of the other answers have mentioned, Windows runs its reboots using the Scheduled Task called \Microsoft\Windows\UpdateOrchestrator\Reboot. However, if you open Task Scheduler and disable this one, Windows will happily reenable it the following day -- even if you change its permissions to make it read-only.

Rather than have to go into the Task Scheduler UI to disable the task every day, we can set this up automatically, using the schtasks command-line utility to modify tasks.


If a reboot is scheduled, the following command, run with administrative privileges, will disable the task:

schtasks /change /tn \Microsoft\Windows\UpdateOrchestrator\Reboot /DISABLE

Knowing this, you can create your own Scheduled Task to periodically run the above command and disable Windows' insidious little scheme. If you're familiar with how to use Task Scheduler, set up your own task.

Otherwise,

  1. Copy and paste the markup below into a text editor.
  2. Save it as an XML file.
  3. In Task Scheduler, click on Actions > Import Task... and select this file.
  4. Tweak the configuration as needed.
<?xml version="1.0" encoding="UTF-16"?>
<Task version="1.4" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
  <RegistrationInfo>
    <Author>http://superuser.com/users/1909/kpozin</Author>
    <URI>\SuperUser\Cancel Windows automatic reboot</URI>
  </RegistrationInfo>
  <Triggers>
    <CalendarTrigger>
      <Repetition>
        <Interval>PT10M</Interval>
        <Duration>P1D</Duration>
        <StopAtDurationEnd>false</StopAtDurationEnd>
      </Repetition>
      <StartBoundary>2016-11-16T18:30:00</StartBoundary>
      <Enabled>true</Enabled>
      <ScheduleByDay>
        <DaysInterval>1</DaysInterval>
      </ScheduleByDay>
    </CalendarTrigger>
  </Triggers>
  <Principals>
    <Principal id="Author">
      <!-- That's the SYSTEM user -->
      <UserId>S-1-5-18</UserId>
      <RunLevel>HighestAvailable</RunLevel>
    </Principal>
  </Principals>
  <Settings>
    <MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>
    <DisallowStartIfOnBatteries>false</DisallowStartIfOnBatteries>
    <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
    <AllowHardTerminate>true</AllowHardTerminate>
    <StartWhenAvailable>true</StartWhenAvailable>
    <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
    <IdleSettings>
      <StopOnIdleEnd>true</StopOnIdleEnd>
      <RestartOnIdle>false</RestartOnIdle>
    </IdleSettings>
    <AllowStartOnDemand>true</AllowStartOnDemand>
    <Enabled>true</Enabled>
    <Hidden>false</Hidden>
    <RunOnlyIfIdle>false</RunOnlyIfIdle>
    <DisallowStartOnRemoteAppSession>false</DisallowStartOnRemoteAppSession>
    <UseUnifiedSchedulingEngine>false</UseUnifiedSchedulingEngine>
    <WakeToRun>false</WakeToRun>
    <ExecutionTimeLimit>PT1H</ExecutionTimeLimit>
    <Priority>7</Priority>
  </Settings>
  <Actions Context="Author">
    <Exec>
      <Command>schtasks</Command>
      <Arguments>/change /tn \Microsoft\Windows\UpdateOrchestrator\Reboot /DISABLE</Arguments>
    </Exec>
  </Actions>
</Task>
  • 3
    This solution is by far the best and safest. Thanks man! – henon Nov 22 '16 at 9:15
  • 12
    The brain trust at Microsoft has been causing me grief since the 1980s. Back then, it was incompetence. Now they do it on purpose. – user184411 Dec 11 '16 at 7:04
  • Nope, can't trust this. Disabling the Windows Update service is the only reliable solution. It's the only way to be certain that Windows won't literally destroy everything you're working on when you least expect it. – Triynko Jan 10 '17 at 3:40
  • "Now they do it on purpose" LOL. I've coined a term I use: BOPs (bugs on purpose) - for any company that says it is "by design" (simple excuse not to change it). ;) – James Wilkins Mar 29 '17 at 7:31
  • Thank you, but why not simply set it to run on startup and then repeat every 10 minutes indefinitely? As it is set up now, the task will only run at 6:30 PM (and then repeat itself every 10 minutes), so if you (re)boot your machine at 6:31 PM, the task will only run at 6:30 PM the following day. Windows may still restart automatically during that time. – tomasz86 Apr 19 at 1:20

Controlling when Windows will Reboot after Windows Updates apply

You can control the time which you allow Windows to automatically reboot per Windows Update operations without disabling anything or forcefully stopping the Windows Update service.

This method will not prevent any Windows Updates from being downloaded or installed ever so OS security patches will still be applied to the system―you just have it reboot when you're ready.

Please note that rebooting may be required before any newly patched vulnerability becomes effective so you need to understand this and still routinely reboot when patches are applied in a somewhat timely manner to ensure your system stays secure.

I will explain with more detail below but essentially this uses a batch script to dynamically set and change the correlated registry values of the the Active hours settings for Start time and End time based on the run time it's executed while ensuring to increment the values to always be hours ahead.


This is a Native Windows Solution

Unlike the Windows 10 Reboot Blocker solution that tricks Windows, this is a 100% Windows native solution that tricks Windows that does not require any third party software to complete the task.


Scheduling with Task Scheduler

Simply schedule a single Batch Script (provided below) with Task Scheduler to run twice a day:

  1. once at 6:05 AM
  2. once as 6:05 PM

Each execution sets the ActiveHoursStart and ActiveHoursEnd times to values making Windows think you're always active and ensures no reboot occurs from Windows Update operations.

The batch logic and the scheduling of this process is simple to scale and adjust should you run into any issue (e.g. you run into issues with Power Saving modes such as Sleep or Hibernate.)


Batch Script

NOTES: The registry values are set in hexidecimal format. Also note that the logic example below expects the script to be executed at a frame of 6:00:00 AM - 6:59:59 AM or 6:00:00 PM - 6:59:59 PM only. This can be adjusted easily with the IF %HH%==XX portion of the logic though; you can also use this same logic to test this functionality to confirm it works as expected changing the value.

@ECHO ON

SET HH=%TIME: =0%
SET HH=%HH:~0,2%

IF %HH%==06 SET StartHour=06 & SET EndHour=13
IF %HH%==18 SET StartHour=12 & SET EndHour=07

CALL :ChangeActiveHours
REG IMPORT "%DynamicReg%"
EXIT

:ChangeActiveHours
SET DynamicReg=%temp%\ChangeActiveHours.reg
IF EXIST "%DynamicReg%" DEL /Q /F "%DynamicReg%"

ECHO Windows Registry Editor Version 5.00                              >>"%DynamicReg%"
ECHO.                                                                  >>"%DynamicReg%"
ECHO [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX\Settings] >>"%DynamicReg%"    
ECHO "ActiveHoursEnd"=dword:000000%EndHour%                            >>"%DynamicReg%"
ECHO "ActiveHoursStart"=dword:000000%StartHour%                        >>"%DynamicReg%"
ECHO "IsActiveHoursEnabled"=dword:00000001                             >>"%DynamicReg%"
GOTO :EOF

Hex values for decimal 0-255

enter image description here


The Registry

For some detail on the correlated registry settings this will change, below I'll reference the portions of A closer look at Active Hours in Windows 10 for what this method will affect.

Active Hours

Active Hours don't change that behavior, but they add a mechanic to the Windows 10 operating system that makes sure users are not disturbed by reboots during active hours.

Active Hours and the the Registry

  1. Tap on the Windows-key, type regedit.exe, and hit enter.

  2. Confirm the UAC prompt.

  3. Navigate to the following key using the tree hierarchy on the left:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX\Settings

The following options are provided here:

  • ActiveHoursEnd: defines the end time of the feature.
  • ActiveHoursStart: defines the start time of the feature.
  • IsActiveHoursEnabled: if set to 1, the feature is enabled. If set to 0, it is disabled.

If you want to change the starting or end hour of the feature, double-click on one of the entries. Switch to a decimal base on the prompt that opens, and enter the starting hour using the 24 hour clock system.

Please note that you cannot add minutes in the Registry only full hours.

source


Confirming

To confirm this works as excepted you will

  1. press the enter image description here key one time, and then start typing in Windows Updates until you see the Windows Update Settings options and then click on it

    enter image description here

  2. click on the Change active hours option within the **Update settings* section

    enter image description here

  3. take note of the Start time and the End time values in the Active hours windows and press Cancel and then close entirely out from the Settings screens.

    enter image description here

  4. run the batch script now ensuring the values are set in the variables accordingly for the time you run the script to ensure it sets the values for the Start time and End time accordingly and ensure it runs without error (run as admin if needed).

  5. Now do steps 1 - 3 again and confirm the Start time and End time values changed correctly.


Disabling

When you are ready to allow Windows Updates to reboot the machine per it's update operations, you can do so manually since this method does not stop Windows Updates from being downloaded and installed. If you need to disable this job though, that can be done by simply disabling the scheduled task that executes it with Task Scheduler.


Further Resources

  • 1
    I think this method is a great idea but it has a little flaw. If you turn off your computer at 7PM or later and then turn it on at 7AM or later the next day, you stay with active hours set to 6PM-7AM and even setting "Run task as soon as possible after a scheduled start is missed" to on in task settings won't change it. I think the conditions in batch should be changed to IF %HH% LSS 06 SET StartHour=12 & SET EndHour=07 IF %HH% GEQ 06 IF %HH% LSS 18 SET StartHour=06 & SET EndHour=13 IF %HH% GEQ 18 SET StartHour=12 & SET EndHour=07 to make it independent of the time it is executed. – Jojo Sep 8 '17 at 7:46
  • is this guaranteed to work? Reboot blocker tool didn't work for me - neither did most other things I tried before. Win10pro 1607 – Mikey Sep 16 '17 at 10:21
  • @Mikey Give it a shot and see if it works but at the time I wrote this, it worked for certain. It's possible that Microsoft applied updates that changed the way the functionality works but I don't have time to test and confirm with the latest Windows version right now. I did note that if your PC goes to sleep or hibernate that the scheduled example I created may not be enough but the scheduling for this and changing the frequency which it runs should be simple enough should you run into that problem to make the adjustments for frequents in case your machine is sleeping or in hibernate mode. – Pimp Juice IT Sep 16 '17 at 12:29
  • yes this is my problem, I'm safe unless I put my computer to sleep - but - I like putting it to sleep when I'm not using it ( I use sleep mode several times a day – Mikey Sep 16 '17 at 12:32
  • 1
    @MarianKlühspies I appreciate that!! I try to always write something someone can get some usefulness out of when I can. This process may be able to be turned into something easier to manipulate with less steps and thought but I haven't had time to try to develop something. Someone suggested about a GitHub app or something for one of my answers like this before but probably on another post entirely. The hex isn't too hard to figure out with a little effort it's not rocket science and really none of it is but you have to get complex sometimes I suppose to have more flexibility and robustness. – Pimp Juice IT Mar 30 at 23:31

Disabling Windows Updates in Windows 10 Natively

**** No third party software required for this method ****

For more control ensuring that Windows Update operations only apply to your Windows 10 OS when you want them to, see the below steps using two scripts and one scheduled task job.

This method will work regardless of any scheduled tasks or other processes that kick off Windows Update if it's setup correctly and the job is enabled and running at short enough intervals.

Essentially this will

  1. Check once a minute to see if the Windows Update service is running and take one of the two below actions whether TRUE or FALSE. . .
    • if it is running, then the service is forcefully stopped with NET STOP ensuring that no Windows Updates are applied
    • if it is not running, then the process ends until executed on the next scheduled trigger with Task Scheduler

You will need to do three things to ensure this works as expected

  1. create the simple Batch Script that'll check if Windows Update is running and kill it if it is
    • this is just a text document renamed with a .cmd file extension
  2. create the simple VB Script that'll execute the batch script but in a hidden manner so there's not a pop up every time it runs
    • this is just a text document renamed with a .vbs file extension
  3. create the scheduled task to run once a minute indefinitely with Windows Task Scheduler

Setup and Configuration

Below are the detailed steps to follow for setting up these three simple things.

1. Batch Script

NOTE: Save the below logic to a text file and rename to have an extension of .cmd e.g . DisableWU.cmd.

@ECHO OFF

TASKLIST /SVC | FINDSTR /I /C:"wuauserv"
IF %ERRORLEVEL%==0 GOTO :StopWUService
GOTO :EOF

:StopWUService
FOR %%A IN (wuauserv) DO NET STOP /Y "%%~A"
GOTO :EOF

2. VBS Script

NOTE: Save the below logic to a text file and rename to have an extension of .vbs e.g . DisableWUHidden.vbs. Also be sure that you put the correct full path and file name value where the batch file is saved in place of the C:\FolderPath\DisableWU.cmd value in the below logic accordingly.

Set WinScriptHost = CreateObject("WScript.Shell")
WinScriptHost.Run Chr(34) & "C:\FolderPath\DisableWU.cmd" & Chr(34), 0
Set WinScriptHost = Nothing

3. Task Scheduler Job

Press enter image description here + R, type in taskschd.msc and press Enter. Right-click on the Task Scheduler Library option in the right pane and then select the Create Task option.

From the General tab be sure the Run whether user is logged on or not and Run with highest privileges options are checked so both are enabled and effective.

enter image description here

From the Triggers tab be sure the Daily option is set with Recur every: 1 days and check the Repeat task every 1 minute for a duration of 1 day is set and specified and that the Enabled option is checked.

enter image description here

From the Actions tab be sure Program\script: points to the full explicit path of the VB Script, and be sure the Start in (optional): points to the folder path only where that same VB Script resides.

enter image description here

To finalize and save, press OK (maybe twice), and then type in the username and password credential information from an account that (1. has permissions to run Task Scheduler tasks, and (2. has execute and read access to the location where you saved the scripts it'll execute.


Confirming it Works

For a quick test to confirm this works as expected you can:

  • Press enter image description here + R, type in services.msc and press Enter
  • Scroll down to Windows Update, right click on it and select Start until you see the status go to Running
  • Now just press F5 every so many seconds to refresh the screen to see if the service status changes
    • Eventually you should see the status change to a Blank/Null/Empty/Nothing indicating the service is not running. If you refresh in the middle of a stop operation, you may notice a status value of Stopping for the service

This means whether you start Windows Update, a scheduled task starts it, or whatever other process(es) start it, it will be killed every 60 seconds if it is running when this job is enabled and running. This helps ensure Windows Update operations never have sufficient time to ever complete a download or install of any update.

Note: The scheduled interval can easily be adjusted to run more frequently than 60 seconds if that's not quick enough in some instances.


To Disable

You should apply Windows Updates periodically though at your regular scheduled maintenance intervals to ensure your system is up to date with the latest security patches and so forth. This is not a method intended to totally never apply Windows Updates as these are critical and necessary in many environments so this is intended to just give you better control to choose when you want to apply these updates in your environment.

To disable this process to allow you to manually install Windows Updates when you're ready, you will simply go to the job you scheduled with Task Scheduler, right-click it, and select the Disable option to disable the job and thus preventing the killing of the Windows Updates service.

enter image description here

Once disabled, just run through the motions of applying Windows Updates manually to patch the OS. Once the updates are applied and your power cycles are complete if applicable, simplly Enable the job for it to start running again.


Further Resources

Windows 10 rebuild his Windows Update Policies adding some diferences between previous versions.

Windows Update will force updates even if windows update service is off, that apply to Home users, since some update requires a mandatory restart, restart scheduler can't be turned off.

That don't mean you can not block the updates, maybe you could do a workarround as block updates servers, but that could be very annoying asuming you have hundred of methods to do that in whole internet.

A Newspaper with Reference Here

Updates. The software periodically checks for system and app updates, and downloads and installs them for you. You may obtain updates only from Microsoft or authorized sources, and Microsoft may need to update your system to provide you with those updates. By accepting this agreement, you agree to receive these types of automatic updates without any additional notice.

Source Windows 10 EULA

Some information about Windows Update for Business explaining the diferences between home users and advantages of enterprise update Here

  • Should have specified I'm using "Pro" edition. – mpen Aug 27 '15 at 18:52
  • 12
    Updating is usually not a problem, rebooting and destroying a user's work is. But who needs a user nowadays? – Michael Jaros Sep 30 '16 at 20:05
  • 1
    This answer is dead wrong. Disabling the Windows Update service ABSOLUTELY SOLVES THE PROBLEM. It's the only way to solve the problem. It's been months since I've disabled it, and my computer has never tried to restart itself. Don't just "stop" the service... stop and set it to "disabled". Problem solved. Enable it when you feel like installing updates. Rewriting the guts of your computer and killing all your work has NO BUSINESS being anything other than 100% manual operation. What Microsoft has done in Windows 10 is ******** disgusting and infuriating. – Triynko Jan 10 '17 at 3:42
  • 1
    Even when it's marked disabled, Microsoft still runs the parent svchost netsvcs wrapper and can start up and run windows updates on you. – Warren P Jan 24 '17 at 13:07
  • 27 June 2017 - been using this for nearly two months and still no forced updates. – Mick Jun 27 '17 at 15:59

It seems like "No auto-restart with logged on users for scheduled automatic updates installations" doesn't work currently with Windows 10, but according to this article on Lifehacker.com (http://lifehacker.com/enable-metered-connection-to-delay-windows-10-updates-1723316525), enabling metered connections in Windows 10 might stop or at least further delay Windows Updates.

Windows 10 comes with a feature that allows you to specify that your internet connection is capped, throttled, or handicapped in some way. You may be tethering to your phone, on a public Wi-Fi network, or just have a crappy data cap on your home network. By enabling “Metered connection,” Microsoft will respect that by waiting to force a download. To turn it on, follow these steps:

  1. Search in the start menu for “Change Wi-Fi settings”
  2. Click Advanced Options.
  3. Enable the toggle under “Metered connection.”

The one major downside to this method is that it only works if your computer is connected via Wi-Fi. For some reason, Windows 10 doesn’t allow you to specify that your connection is metered when connected via ethernet (despite the fact that many home internet connections have data caps). However, this should help many typical users.

  • 3
    Just disable the service altogether. Disabling windows update is the only solution. As far as I'm concerned and as a matter of actual fact, Windows Update's automatic restarts have caused more destruction of work and more agony in 2 months than any virus or malware I've ever encountered in the past 20 years combined. DISABLE THE WINDOWS UPDATE SERVICE. PROBLEM SOLVED. – Triynko Jan 10 '17 at 3:46
  • @Triynko I hope you've changed your mind now that WanaCrypt0r has made its appearance. In any case, it's been less than 20 years since SQL Slammer took down tens of thousands of systems, and Microsoft had released a patch fixing that problem 6 months prior to that worm's release. – Twisty Impersonator May 13 '17 at 19:10

According to this answer, two actions are both required to disable forced reboot while the user is logged-on. The answer is based on an article (in Italian).

The two required settings are :

  1. Set the registry item NoAutoRebootWithLoggedOnUsers
  2. Set the policy of Configure Automatic Updates policy

I do not have the capability to test it in all Windows versions, nor can I guarantee that it will still work tomorrow. But here is how to set these two settings.

Disable forced restarts after updates (registry)

This registry modification will disable forced restarts as long as some user(s) are logged-in.

  1. Click Win+R, type regedit, and hit Enter
  2. Navigate to the key
    HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU
  3. If either WindowsUpdate or its subkey AU do not exist, create them manually by right-click on the right-hand panel, then New -> Key, type the missing key name and press Enter.
  4. Once positioned into the AU key, right-click in the right-hand panel, select New and then DWORD (32-bit).
  5. Type NoAutoRebootWithLoggedOnUsers and press Enter
  6. Double-click on the item, change its value to 1 and press OK.

image1 image2

Modify Windows Update settings (Local Group Policy)

  1. Press Win+R, type gpedit.msc, and hit Enter.
  2. Navigate to Computer Configuration -> Administrative Templates -> Windows Components -> Windows Update.
  3. Locate the Configure Automatic Updates policy on the right pane and double-click it.
  4. Select Enabled and Options to 2 (Notify for download and notify for install).
  5. Click Apply.
  6. Press OK to save the changes.

Finally, reboot the PC.

enter image description here

Note about Windows 10 Enterprise

I am running Windows 10 Enterprise with deferred updates. For what it may help, here are my registry settings from HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU :

enter image description here

And in the Local Group Policy Editor, Configure Automatic Updates is set to Enabled with Option set to 2.

Up until last night, I had prevented my computer (which hosts services requiring it to be on 24/7 unless I specifically scheduled downtime) from automatically applying updates and rebooting. I had done this by disabling the Windows Update service—one of the answers here.

This morning, I discovered that it had rebooted automatically and that the Windows Update service had been re-enabled. This is not behaviour that Windows 10 has ever exhibited for me before. I can only assume that something has changed in 2018, and that Microsoft has rolled out an update this year (which I would have applied when manually updating my system) that re-enables the Windows Update service even if you've disabled it.

I have since disabled the Windows Update service once more—but now also removed all inherited permissions from HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\wuauserv, and given only myself anything other than read-only access to it.

In addition, I have taken ownership of C:\Windows\System32\sihclient.exe (the binary responsible for background updates), removed all permissions to it aside from myself, and renamed it.

I will not know if this is successful (one or the other or both) until one or more months have passed.

  • 1
    Consider creating a script for these solutions you provide if applicable and you can to make it easy for others to apply via command line for all the operations you state or at least some screen shots of the operations. That may make it easier for people to apply the fix and follow along after applying updates manually each time in case they get reverted back post manual Window Updates. – Pimp Juice IT May 29 at 18:57
  • @PimpJuiceIT I'll think about that once I can verify if my solution is actually effective. :) Unfortunately, unless somebody has definitive information on this, it's now just a waiting game. – Jason Bassford May 29 at 19:03
  • No problem... just remember that some non-technical people might read your answer for such a solution (once verified of course) and they may need some hand holding and there's nothing better than holding someone's hand than some step-by-step detailed instruction, or some screen shots or detailed instruction for the steps involved or a little automation where applicable. I have plenty of patience so no worries with that regard—I look forward to hearing from you on your results the month after you manually update if this works or not. – Pimp Juice IT May 29 at 20:09
  • 1
    Hey, Jason, welcome to the site. This is interesting information, but maybe premature for an answer. It might be better to wait until you confirm that it works. – fixer1234 May 29 at 22:36

If you absolutely must not allow your system to reboot due to Windows Updates without it being "controlled" when you are present, schedule down time for maintenance, or whatever the case, then you could disable the Windows Update service.

Manually Controlling Windows Updates

This would mean that this machine would not get critical security updates, etc. unless you re-enable and then manually download, install, reboot, etc. and then disable once the patching is complete.

WARNING: This could be dangerous and is not recommended and especially in a home network environment. In a business or data center environment though, it is normal for companies to control when they will make changes, install security updates, patch OSes, and so on.

Turn off Windows Updates in Windows 10

You can do this using the Windows Update service. Via Control Panel > Administrative Tools, you can access Services. In the Services window, scroll down to Windows Update and turn off the process. To turn it off, right-click on the process, click on Properties and select Disabled. That will take care of Windows Updates not being installed on your machine.

enter image description here

But since Windows is a Service now onwards, you have to keep your computer updated. To be able to install the next set of features or a newer build, you will require the earlier updates to be installed. That’s why if you use the above workaround, you will have to go to the Services and turn it on once in a while to download and update your copy of Windows.

Manually Starting Windows Updates and Running it

After you turn on the Windows Update service, when you open Windows Update in PC Settings, you will see a message that updates were not installed because computer was stopped. You will have to click on Retry so that all the available updates are downloaded and installed. This may take two or three “Check for Updates”. You will have to keep on clicking “Check for updates” until it says your computer is up to date. Then you can go back and turn off the Windows Update service until next time you feel you are free enough to spend time updating your copy of Windows 10.

source


Disabling Task Scheduler Jobs

It seems that there are some scheduled tasks related to Windows Update scheduled to trigger Windows Updates perhaps.

Press enter image description here + R, type in taskschd.msc and press Enter. Navigate to Task Scheduler Library > Microsoft > Windows > WindowsUpdates, and then right click and select the Disable option for the job named Scheduled Start.

enter image description here


Further Resources

protected by Community Jul 22 '16 at 6:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.