I got a hold of Blackbox because I felt like GNOME was eating up too much RAM.

The problem is, if I reboot, login with GNOME's login screen, and select Blackbox as the window manager, I don't have internet. The routing table is empty and I can't get an IPv4 address with DHCP.

I can then log out ( from the session with Blackbox ), select GNOME, log in, and my internet is all set up. Everything works.

I can then log out of the GNOME session, select Blackbox, log in, and my internet works.

So... I have to log in with GNOME just to get internet for some reason, but I don't know where to look. How could I get internet with Blackbox without logging with GNOME first?

  • Do you really mean "can't get an IP address", or do you actually mean "won't get an IP address"? In other words, are you manually starting a DHCP client from Blackbox, or are you expecting that to happen all by itself? Aug 14, 2015 at 19:29
  • Well, I tried to get an IP address with dhclient( ie. manually ), but there's no offers. So, I was wondering how GNOME did it automatically, so I can put something together that runs when I start with Blackbox. Aug 14, 2015 at 19:32
  • Are you talking about WiFi or Ethernet here? Aug 14, 2015 at 19:33
  • Ethernet, dhclient eth0, when run with Blackbox, doesn't get offers.... That doesn't mean to imply Blackbox is stopping it, but somehow, GNOME can get internet, but Blackbox can't. Aug 14, 2015 at 19:34
  • What do you use for the network in GNOME, then? NetworkManager? Aug 14, 2015 at 19:35

1 Answer 1


Make sure NetworkManager.service is active/running. My guess is that it's not "enabled" for automatic startup, but GNOME still launches it via DBus (but Blackbox of course doesn't).

nm-applet is optional, but still recommended, since it handles interactive prompts (e.g. Wi-Fi password prompts).

  • It seems, with Blackbox and my computer, service network-manager start results in [ ok ] Starting network connection manager: NetworkManager already started. but still no internet :( might work for someone else though :D Aug 14, 2015 at 19:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .