13

I would like to configure this windows 10 machine to not ask for a password when resuming from IDLE, but still ask for a password when resuming from STANDBY or HIBERNATE.

The screen needs to turn off after 5 minutes and NOT use a screen saver.

The only information I can find is about disabling the lock screen password entirely - which is not what I want. Whether the lock screen continues to show or not is relevant as long as it doesn't require a password.

Version is Windows 10 Pro. It is also connected to a SBS2011 domain.

4
  • Have you tried disabling the screensaver? (Set to None) Mine does not ask for password when resuming from idle. – Moab Aug 15 '15 at 13:21
  • Screen saver is already set to none, also the checkbox for displaying the login screen is not checked. – Nicholas Aug 16 '15 at 2:45
  • By reviewing the "late answer", I was able to see this question. Have you messed with any settings in the Power Options? From there you can tell it screen to shut off after X minutes of inactivity, and set the Require password for wake up to no. I believe this would still make you enter a password after resuming from hibernate and standby. If this works, comment so we can move it into the answers. – DrZoo Oct 13 '15 at 20:28
  • Turning OFF `Require Password for wake-up' in the power options unfortunately also turns OFF the ask for password on resume from standby. – Nicholas Oct 14 '15 at 23:27
7

Using gpedit, set the "Allow users to select when a password is required when resuming from connected standby" policy to "Enabled" under "Computer\Administrative Templates\System\Logon\"

OR

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System] "AllowDomainDelayLock"=dword:00000001

reference: https://social.technet.microsoft.com/forums/windows/en-US/20847146-a4ff-4b88-9bab-ccc70b5d1554/do-not-require-password-after-display-off

In my case, after enabling this policy, the screen just stays on (ignoring my screen timeout setting) presumably until the sleep timer triggers. I am unable to find a location to set the 'Require a Password after the display is off for...' timer that was previously available in Windows 8.1 Accounts>Sign-in Options.

6
  • 1
    To get tips on obtaining rep you can look here. Don't take tip #1 too serious. Providing very weak answers will cause people to downvote your answer, therefore taking rep away from you. Edits are the easiest way to obtain rep, but it is rather slow. +2 rep for each edit. – DrZoo Oct 13 '15 at 20:30
  • @goofology The registry key addition you described seems to work just fine for me. Thanks. – Nicholas Oct 15 '15 at 0:39
  • Nice! I must have some other setting misconfigured on my machine. Thanks for getting back to us! – goofology Oct 15 '15 at 0:41
  • @Nicholas, where did you change the screen timeout for the lock-screen specifically, after setting this registry key? – goofology Nov 6 '15 at 22:46
  • it worked for me too on Windows 10. Changed to policy and didnt have to do anything else – Flion Aug 7 '16 at 12:10
2

Just wanted to share my workaround... I worked off of windows 8.1 settings to change the lockout value in the registry ...

In your registry, navigate to: [HKEY_CURRENT_USER\Control Panel\Desktop]

Then change the value to the desired timeout period (use Decimal to specify the time in seconds). I have it set to 6 hours "DelayLockInterval"=dword:00005460" (21600 decimal)

My workaround is based off of what was posted here for windows 8.1:

http://www.eightforums.com/tutorials/28485-password-require-after-display-off-windows-8-1-a.html

1
  • You can freely edit your own posts but for your protection, this must be done under the original user account. It looks like you have created a second account. See Merge my accounts to get your accounts merged, which will solve the problem. – fixer1234 Dec 8 '15 at 18:31
0

Run CMD as administrator and type :

REG ADD "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Personalization" /v "NoLockScreen"   /t REG_DWORD     /d "00000001" /f

After PC restart, LockScreen should be disabled.

0
-1

Aside from other tips, in Screen Savers put "Blank" instead of "None", then it won't ask for login credentials.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.