21

I have two computers that came with Windows 8.1. I recently upgraded them to Windows 10. I've been trying to configure the machines for remote access but am having limited/no luck.

The RDP connection fails when specifying either the hostname or the IP of the target machine.

I have tried the following to attempt to solve the issue:

  • Checked that the target PC has Remote Desktop enabled. The Allow this computer to be controlled remotely checkbox under This PC -> Properties -> Remote Settings -> Advanced is indeed checked.
  • Disabled Windows Firewall in case this is causing connection issues.
  • Use a wired, rather than wireless, connection.
  • Verified that both machines could ping each other successfully (they could).
  • Verified that Remote Desktop is attempting to listen on port 3389 by checking the registry value at Computer\HKLM\System\CurrentControlSet\Control\Terminal Server\WinStations\RDP-TCP\PortNumber (this value is indeed correct). As it turns out, Remote Desktop is actually NOT listening on this port (or apparently any port). I was able to find this information by running netstat -a | findstr 3389.
  • Toggling the Remote Desktop checkbox (see above) and then restarting, per a suggestion I found using Google. I tried this in various ways, including:
  • Disabling Remote Desktop and then restarting. Then enabling Remote Desktop and then restarting.
  • Disabling Remote Desktop, then enabling it, then restarting.

    None of these cause Remote Desktop to start listening on this port.

  • Putting the two computers in a homegroup together, per another suggestion. After doing this, the two computers share files and other resources.

How can I fix this issue with Remote Desktop and allow the target machine to be connected to remotely?

As you can see, I've tried a lot of things to solve this issue. Hopefully I've missed something that somebody can spot!

migrated from serverfault.com Aug 15 '15 at 3:28

This question came from our site for system and network administrators.

  • Have you tried RDPing both with the IP and Hostname? – Michael Bailey Aug 15 '15 at 7:16
  • Yes. I failed to indicate this, but this was part of my earlier attempts to connect to this other machine. – Beta033 Aug 16 '15 at 5:05
  • 4
    What edition of Windows 10 do you have? Is this home? Home Edition has only remote desktop client and you cannot connect via RDP to it. – Volodymyr M. Aug 19 '15 at 6:57
  • @Volodymyr I'll review this. Now that i think about it, i didn't know that Home Edition didn't allow remote connections...I think it would be nice if MS did disable a feature, the UI selections to enable/disable it would have some indicator of this besides simply not actually toggling the functionality... – Beta033 Aug 20 '15 at 17:23
  • Any update on your issue @Beta033? It sounds just like what I'm running into, except IDK if it is Home Edition (yet). – Adam Spicer Sep 9 '15 at 0:50
5

Did you add your user to the remote user list

Did you add your user to the remote user list?

This PC -> Properties -> Remote Settings -> Advanced -> Select Users ... And select the users.

Also, Did you allow the incoming connections on port 3389 TCP?

Control Panel -> Windows Firewall -> Advanced settings -> Inbound Rules -> New Rule ... And follow the wizard to add the port.

How to add a rule or port to a Windows 10 firewall

  • 1
    How does one add the user to the remote user list in specific detail? – Ramhound Jan 7 '16 at 20:02
  • @Ramhound ? What do you mean? With an administrative account you just go to computer properties, remote access, select users, and add As the pictures shows. – Roy Calderon Jan 7 '16 at 20:17
  • 1
    I personally know how to do it. Your answer does not explain how to do it. The author might not know how to do it. Anyone with this same question as the author, is not likely to know, how to do it themselves. – Ramhound Jan 7 '16 at 20:25
  • 1
    Right, there is more information now ;) – Roy Calderon Jan 15 '16 at 9:16
  • The lower box with the "select users" button is not present on my Remote tab... :( – Luigi Plinge Jan 22 '16 at 12:43
0

You can telnet the PC to check whether RDP port is opened.

Telnet tserv

It should make communication and get a response.

Source - https://support.microsoft.com/en-hk/help/187628/using-telnet-to-test-port-3389-functionality

Also, a few points to consider. 1) Network Level Authentication 2) Firewall settings or personal firewall and AV settings - that might block incoming RDP requests. 3) User/Group permission 4) Check the remote desktop service

More detailed information available here in fixing RDP issues in Windows 10.

  • Why would telnet help, especially without specifying the RDP port? – RalfFriedl Jun 22 at 10:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.