1

I'm trying to get a useful Fedora 22 installation running on my Lenovo yoga 3 pro Laptop.

I have done a full fedora installation to a USB3 flash drive, and it runs well, but I don't have any networking. I purchased a D-Link DUB1312 USB Ethernet adapter, but discovered I need to compile drivers for this. I downloaded the driver source and tried to make. Here i discovered I needed to kernel-devel sources.

So I switched to windows and downloaded to USB what looked like the right package from here: http://rpm.pbone.net/index.php3/stat/4/idpl/29666225/dir/fedora_22/com/kernel-devel-4.0.4-301.fc22.x86_64.rpm.html

Switched back to Fedora, mounted the USB drive, and tried to install the package:

[root@localhost DUB-1312_A1_Linux_Driver_v1.4.0]# dnf install /mnt/kernel-devel-4.0.4-301.fc22.x86_64.rpm 
Error: Failed to synchronize cache for repo 'fedora' from 'https://mirrors.fedoraproject.org/metalink?repo=fedora-22&arch=x86_64': Cannot prepare internal mirrorlist: Curl error (6): Couldn't resolve host name for https://mirrors.fedoraproject.org/metalink?repo=fedora-22&arch=x86_64 [Could not resolve host: mirrors.fedoraproject.org]

I don't exacctly understand what's happening here, but clearly looks like dnf is trying to connect to the internet - I have no internet connectivity.

So, I'm kind of stuck. I can't build the driver for my USB Etnerenet adapter without kernel-devel. Any hints here on how to install the kernel-devel package from USB drive without networking?

Thanks in advance,

| improve this question | | | | |
1

The solution was to use the --disablerepo argument for dnf. It looks like dnf comes configured out of the box to search for "fedora" and "updates" repos.
The command that worked for me was:
# dnf --disablerepo fedora --disablerepo updates install kernel-devel-4.0.4-301.fc22.x86_64.rpm

Note that I then needed to install GCC, and binutils, etcetra. In the end I discovered I could tether to my android phone and get connectivity through USB and the phone's wifi. All went smoothly after that.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.