2

I'm using Arch Linux with KDE Plasma 5 desktop environment. Unfortunately, I've been having this odd issue with my monitors waking up after going into screen energy saving. I haven't figured out all the things that cause this to happen, but I can confirm that every time I get a chat message through GChat my monitors will turn back on.

My question is, how is this screen energy saving thing work? Is it controlled through X server? Second, how can I make it less sensitive to wake-up events? Ideally, only striking a key on my keyboard should take me out of screen energy saving mode.

Here is some information that might be relevant:

X Server Information

Server Version Number: 11.0
Server Vendor String: The X.Org Foundation
Server Vendor Version: 1.17.2 (11702000)


$ uname -a
Linux caladan 4.1.4-1-ARCH #1 SMP PREEMPT Mon Aug 3 21:30:37 UTC 2015 x86_64 GNU/Linux

Finally I'm using the following NVIDIA Drivers:

NVIDIA Driver Version: 340.76

1 Answer 1

0

I've experienced similar issues, and there are several possible causes:

  1. Mouse

Some mice, specially the gaming mice, are especially sensitive. Small vibration may cause them to be active, and wake up the system. It's also possible that when they become inactive after a period with no activity, they also wake up the system. To check this, you can power off the mouse, and see if it still wakes up.

  1. Notifications

On my KDE system, notifications will wake up the system. You can check this by checking whether there is a new notification whenever your monitor wakes up.

For me, the time to enter energy saving mode is controlled by xscreensaver. There are many possible things to control this, you may check your power settings in the system settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .