141

I installed Windows 10 on a physically German keyboard, then installed a Window English software keyboard and bought some little stickers to make my keyboard look OK.

However, Windows shows 2 keyboards installed & occasionally toggles back to German.

Note that I am not talking about removing a language (which is all that I can find when I Google).

How do I remove the German keyboard layout?

9
  • 1
    Anything you can remove in Device Manager?
    – Mokubai
    Aug 15, 2015 at 7:51
  • 25
    This is a bug. Add the German Keyboard layout and remove it again. Press the Windows key, type "Edit Language and keyboard options", left click on English --> Options. "Add a keyboard", scroll to German QUERTZ and add it. If you now remove it, it should be gone for good.
    – Jubei
    Jul 9, 2018 at 14:52
  • 5
    The previous comment should be a seperate answer – this was the only one that solved it for me. Jun 20, 2019 at 9:27
  • 2
    Yep, @Jubei comment is the RIGHT answer.
    – nephewtom
    Jan 10, 2020 at 11:23
  • 3
    @MawgsaysreinstateMonica apparently I don't have the necessary reputation for that...
    – Jubei
    Jan 17, 2020 at 12:12

8 Answers 8

114
+50

To remove a keyboard under Windows 10 is done this way :

Method 1 : Settings

  1. Select the Start button
  2. Go to Settings > Time & Language > Region & language
  3. Under Languages, click your language
    image1
  4. Click Options
  5. Under Keyboards click your keyboard
  6. Click Remove
    image2

Method 2 : Preloaded

  1. Use regedit to navigate to following registry keys, where you will find there the list of keyboards that are preloaded at boot.
  • HKEY_USERS\.DEFAULT\Keyboard Layout\Preload
  • HKEY_CURRENT_USER\Keyboard Layout\Preload
  • HKEY_USERS\.DEFAULT\Control Panel\International\User Profile
  • HKEY_USERS\.DEFAULT\Control Panel\International\User Profile System Backup
  1. Find the keyboard identifier among the list of Keyboard Identifiers

  2. Delete the key.


Update January 2022:

The language settings are now found in Settings > Time & Language > Language.

21
  • 19
    The Remove button is disabled. Isn`t it? Nov 13, 2018 at 14:15
  • 3
    The question was how to remove the keyboard layout which is the last for the selected windows language. So I was wandered of this picture... Nov 13, 2018 at 14:21
  • 12
    Only method 2 works for me, ty!
    – xxxbence
    Mar 2, 2019 at 6:07
  • 13
    I used method 2, but it was back after reboot. I had to delete C:\Windows\en-GB and "Preload" registry key in HKEY_CURRENT_USER and registry key "Control Panel\International\User Profile\Languages" in both HKEY_CURRENT_USER and HKEY_USERS, finally it's gone. Thanks Microsoft! Jul 17, 2019 at 7:32
  • 5
    Preload? This is nasty, who designed it?
    – Al Kepp
    Dec 5, 2019 at 17:48
32

Edit: This section of the control panel has been removed from newer versions of Windows 10. You need to use the settings app instead.

Open Control Panel, under the Clock, Language and Region heading click Change input methods, you should see your language, click on Options, in the Input method section you should see two entries, remove one.

control panel for keyboards

11
  • 24
    In Widows 10, on the Control Panel, I do not see "Clock, Languages and Regions". I see Language and Region as two separate items, but I don@t see the option that you mention. Aug 16, 2015 at 8:16
  • 17
    The system installs "English (United States) US Keyboard" even though none of my input methods has that keyboard listed in the options. How can I get rid of it then? Dec 9, 2015 at 16:00
  • 38
    I have two languages (EN + CZ) and had two keyboard layouts for Czech language (QWERTY+QWERTZ). I wanted to get rid of Czech QWERTZ layout. Although there were both layouts shown in system tray, there was only QWERTY in Input methods section. Probably caused by bug in Windows. Solution: add QWERTZ layout in Input methods section and then remove it. Apr 13, 2016 at 11:09
  • 2
    @Mawg I don't have "Clock, Languages and Regions" either. For me, the solution by Johannes Rudolph below worked.
    – user4954
    May 31, 2018 at 14:57
  • 3
    I have no such section in settings either, there is NO WAY to remove a keyboard layout/input method in settings, it's ridiculous
    – szx
    Sep 23, 2018 at 8:40
17

Posting @Jubei's comment as an answer.

Due to a bug in Windows, the keyboard layout might not appear in the languages list in the Settings app.

To remove it, you need to add that language and that keyboard layout to the Settings app yourself, then immediately remove them, as described in https://superuser.com/a/1025157/338981.

1
  • The only thing worked for me. Jul 20 at 2:35
13

I finally managed to solve this. Go to Settings, Time&Language, Region&Language:

Language Settings

I had German (Deutsch) as the default language, with English US as display language. Then: - Click on English and select Options - Add a Keyboard in your preferred layout (Swedish, German, whaterver) - Then remove the US Keyboard Layout for english language

The language selector (win+space) now shows like: English US - German Layout German - German Layout

It's not a 100% solution but at least it will fix random keyboard layout swaps.

2
  • Do you have any idea about where this VIE IME come from? Imgur
    – Luke
    Jun 25, 2018 at 9:06
  • 3
    'Region and Language' is now gone in Windows 10. In the end I went to Language, had to re-add the keyboard that wouldn't go away, then remove again. finally fixed.
    – niico
    Jun 11, 2020 at 8:39
10

In Windows 10, on the Control Panel, I chose "Languages". There was a rectangle labelled English and next to it was some text saying "keyboard layout: English, German".

I clicked on that box and then there was an option to remove each keyboard.

I have searched through every possible selection under Language and Region and this is the only way that I found to remove keyboard.

4
  • 26
    I am using english display language but a swedish keyboard layout. However my keyboard switches to english all the time and i cannot delete the english layout. When i edit the layouts i can only see the swedish keyboard, but when i click "ENG" in the system tray i can pick between both keyboards. Its driving me insane! May 16, 2016 at 15:37
  • 2
    I have the same problem. In system tray i see ENG. But I dont have english keyboard layout. Found this post and it works, for now... superuser.com/questions/685078/… Jun 20, 2016 at 7:32
  • 2
    This works, but the problem is that you will also remove the language. In my case, I only wanted to remove the EN keyboard but keep my OS in English - and this side effect might actually be more annoying than having an extra keyboard
    – Żubrówka
    Aug 31, 2018 at 13:51
  • There is, alas, an arrogance/blinkered Weltanschauung in some developers that simply cannot see why anyone would ever want to remove "English". Almost inevitably, that means U.S "English" :-( Feb 15, 2021 at 9:31
8

1. first thing to check:

open settings -> language settings -> Administrative language setting -> welcome screen and new user accounts -> copy settings.

make sure non of the settings is set to the undesired language.

thanks it's 42

2. another reason why display languages keep adding themselves to keyboard layout lists:

1) press winkey+R

2) enter lpksetup and press enter

3) choose "uninstall display languages"

4) choose the language you want to remove and click "next"

5) restart your computer

answer taken from this thread

3. When the two solutions above don't help

open registry editor (WinKey + r -> regedit), edit Languages under Computer\HKEY_CURRENT_USER\Control Panel\International\User Profile\ to list desired keyboard layouts and restart computer.

4. This is a really dangerous option, use it only as last resort

Go to C:\Windows, look for a folder named as the layout you want to remove (en-GB in my case) and remove it / change it's name.

restart your computer

1
  • 1
    thanks for the answer with lpksetup! I tried everything and only this works.
    – emnha
    Nov 27, 2020 at 15:37
4

I don't know why but I don't have any of the above options in the Control panel.

I have Clock and Region (no Language mentioned) and inside cannot set the language.

If I click the ENG on the language bar in the tray I finally get: Language Preferences. Choosing that, takes me to the Languages control panel.

I cannot delete the UK keyboard (I have Israel and the US keyboard set, and Hebrew as a second language). Standing on the UK keyboard the Remove button is disabled.

Deleting the UK key (809) from the registry Computer\HKEY_CURRENT_USER\Control Panel\International\User Profile\Languages should do the trick (in older versions it was a different key with a dword for each language: 409 was English US, 40d is Hebrew, 809 is UK) Thanks Ohad!!!!

I had to go under the Region and Languages Settings panel, Advanced Keyboard Settings, and Override for default input method.

Changed from Use Language List (recommended) to Hebrew

Rebooted and all's ok now.

1
  • you have edited the wrong registry key, see my answer
    – Ohad Cohen
    May 25, 2018 at 18:23
4

This solution worked for me:

  1. Open registry Editor (Win+R -> regedit) as Administrator.

  2. Navigate to Computer\HKEY_USERS\.DEFAULT\Keyboard Layout\Preload

  3. Delete the unnecessary keyboards based on the language codes

To prevent these from re-appearing:

  1. Right-click on the "Preload" branch and choose "Permissions".

  2. Click on "Advanced".

  3. Click on "Disable Inheritance" and confirm disabling. Then click "Apply" button.

  4. In "Group or user names" in the Security tab, if the user names disappeared, add back yourself and the administrators. Make sure that "Permissions for system does not have write access.

Not the answer you're looking for? Browse other questions tagged or ask your own question.