Launching Chrome as default browser for links in Windows 10 doesn't work.

enter image description here

Setting any browser as default, including Edge and Internet Explorer, works.

This may be a side effect from the fact that I deleted the following entries according to a very popular fix for the "Chrome class not registered" error.

This question, might actually be how to fix the above fix... any ideas how I can restore those Chrome registry keys?


Installing Google Chrome directly over this solved this issue including after doingn the class registry hack. Make sure to select "Set as default browser" at the pre-download page.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.