I'm using Windows 10 x64 Pro and I'm unable to preview or install fonts.

When I try to preview a font (double click or Right Click >> Preview), I get an error message that reads "The requested file <font file> is not a valid font file" as shown in the screenshot below:

enter image description here

When I try to install a font (Right Click >> Install), another error that reads "The file <font file> does not appear to be a valid font" is shown (screenshot below):

enter image description here

Things I've checked:

  • I have UAC enabled in my registry but set to lowest setting "Never Notify". I thought UAC had something to do with this, but the behavior is the same whether or not EnableLUA is set to 0 or 1 in registry.
  • I have checked the Event Viewer (Application and System sections) for hints to the problem, but this error is not reported at all in the logs from what I see. This seems strange.

Why can't I install fonts on Windows 10? I verified the behavior with several downloaded otf and ttf font files. So I'm fairly certain the files are not corrupted.

EDIT

When I go to the Fonts section of Control Panel, I do not see an "Install Font" option in the "File" menu, as shown in the screenshot below.

enter image description here

  • Have you tried following Microsoft ? – pun Aug 16 '15 at 2:45
  • 1
    I don't see an install font option in step 2. See my edits to my original post for screenshot. – void.pointer Aug 16 '15 at 3:30
  • Next procedure works for me: download dejavu-fonts-ttf-2.35.zip ==> RightClick, Properties, Unblock, OK ==> Extract all.. Then navigate to dejavu-fonts-ttf-2.35\ttf folder, select (something or even all), RightClick the selection, Install – JosefZ Aug 16 '15 at 8:01
  • @JosefZ I don't understand what that accomplishes. I used 7-Zip to extract the archive, and from the extracted directory I attempt to install the fonts. Your solution also does not explain why "Install Font' option is missing from the Fonts folder. – void.pointer Aug 16 '15 at 12:36
  • Interestingly, this problem also makes loading web fonts fail with error code CSS3111 "unknown error" when using @font-face in IE11 (but not Edge!). Enabling the firewall helps there, too. – fpbhb Oct 16 '15 at 15:48
up vote 156 down vote accepted

After a week of trying everything. The answer as weird as it sounds is to enable the windows firewall. I know, makes no sense right? It's not connected to font settings, however once "On" I was able to fix my issue with installing fonts on windows 10 and without an error message!

  • 23
    What the freak? – void.pointer Aug 17 '15 at 20:57
  • 37
    Wow incredibly surprising and scary. I enabled Windows Firewall service and fonts are working perfectly again. I'd love to hear a logical explanation to this from someone. This is madness. – void.pointer Aug 18 '15 at 1:33
  • 7
    Yep can confirm this works – Riz Aug 25 '15 at 19:53
  • 11
    that's not a valid question. It is a firewall, it has a specific function - allowing or blocking network traffic. If it can be disabled, the system shouldn't start falling apart. And I'd like to know why securing network traffic and local font installation are connected in any way. – Dirk Trilsbeek Sep 10 '15 at 15:14
  • 6
    Theoretically a possibility, but if that's the case then why not say 'Please enable the windows firewall before installing fonts for security reasons' with possibly a button to ignore the error and install anyway, instead of some random error that is caused by something seemingly unrelated – RyanTimmons91 Sep 10 '15 at 20:21

I met this problem as well through my git repositories hosting font files. Here's a weird solution that worked for me. Copy (and yes its Ctrl + C not Ctrl + X for cutting) the file somewhere else or even in the same directory and the copied file will work.

Also the top solution does not work for me. My firewall is already activated.

Further digging showed that copying did not change any of the file contents. Both are the same, I ran sha1sum on both files, and their hashes matched.

Later checking the security properties on the original font file, Windows popped up with "The permissions on X.ttf are incorrectly ordered, which may cause some entries to be ineffective.". So it looks like my git cloning of the repository is causing some messed up permissions to be set upon placing the font file in Windows. In that case, it does have some relation to the security and permissions system on Windows. That just means the error that font viewer application is giving back is very badly worded.

  • 1
    yup, i can confirm this too, also, installing fonts from removable media will surely fail without any error message. after copied the fonts to local disk, i can install it – am05mhz Jul 31 '16 at 6:43
  • did not work for my DroidSansMono.ttf font! :( – ShAkKiR May 30 at 6:58

protected by Community Sep 11 '15 at 18:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.