How can I force this to uninstall without the MSI? The MSI is not on the website and I tried extracting the MSI... even installing with the EXE gives the exact same error below:

enter image description here

  • There is another answer on Stackoverflow that might help you: stackoverflow.com/questions/1547809/extract-msi-from-exe – mark Aug 16 '15 at 9:57
  • @mark I tried, I was getting some source files, not any MSI. – Ahmed Aug 16 '15 at 15:08
  • Can you install the driver again, then uninstall? – Moab Aug 16 '15 at 17:52
  • @moab I tried that using the EXE and it asks for the MSI – Ahmed Aug 16 '15 at 17:53

Error shows that uninstaller was unable to find FLUSBVGAx64.msi in the computer & you could not find the .msi in website.

If you cannot find FLUSBVGAx64.msi in computer then you must look for other ways to uninstall the software.

You cannot force a non existent .msi to uninstall a software

Try one of these :

  1. Microsoft Install/Uninstall Fixit
  2. Revo Uninstaller

Note : I am not affiliated with any of these tools & recommending purely based on personal experience

  • 1
    If I am not using Microsoft fixit for some reason i do the manual job of removing the entries from Windows installer, then remove file associations if any, remove registry entries and then files from disk. if that sounds a lot to you, check if Revo uninstaller or iObit uninstaller works with Windows 10 – pun Aug 16 '15 at 19:43
  • 1
    Revo works. So remove all the registry entries via Revo uninstaller? And then try to install? – Ahmed Aug 16 '15 at 21:00
  • 2
    Yes. But revo also tries to call the built in uninstaller first and then you may get the sam error. you can ignore it and proceed with the removal of registry entries and then files from computer. Re-install after this should work fine. – pun Aug 16 '15 at 21:03
  • 2
    Ah geez, I had done the Basic Revo uninstall instead of the Advanced... anyway, I gathered the rage to do the Advanced uninstall and install and external display works now! Thank you for your guidance. – Ahmed Aug 16 '15 at 21:13
  • 2
    A forced uninstall via Revo and then a registry clean via CCleaner for good lucked worked for me. – Matthew Lock Jun 16 '16 at 6:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.