Last night I fiddled around with some settings, and now Windows 10 refuses to search my settings. If I search "Settings" it returns a result, if I search Notepad and Chrome - it works fine. But if I search "Activate" or "Update" or "Personalization" - it returns nothing until I press enter and wait a while. How can I restore the settings?

The settings I fiddle around were indexing settings. There's only one item checked now - "Start Menu", and the rest of the settings seem fine, but obviously something's wrong. How can I solve this?

10 Answers 10


Ran into the same problem after upgrade from Windows 8.1 Pro. Since there is no official method to reset Indexing Options to the defaults, I just removed the corresponding registry branch. After the whole procedure, Windows restored the branch in its pristine state and the indexing resumed to work properly.


  1. Stop Windows Search service:

    Win + R, services.msc, Enter

    Find the Windows Search entry, click on it, and choose Stop from the left column.

  2. Remove the following registry branch in its entirety:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\CrawlScopeManager\Windows\SystemIndex

    You can use the free home edition of Registrar Registry Manager for this.

  3. Follow the step #1, but click Start instead of Stop this time.

The service will start and re-create the missing registry branch. This action will effectively set the Indexing Options to their clean default state.

The Control Panel (or Settings) items are now shown in the search results, immediately, but if you feel like to, you can set your own exclusions via the usual Indexing Options interface and even rebuild the index.

  • There is no CrawlScopeManager on Win10, unfortunately.
    – Jack
    Aug 27, 2015 at 15:18
  • What did you use to open the registry? What the top existing key do you have in the aforementioned branch? Aug 30, 2015 at 18:51
  • I used regedit, but it didn't work, so I had to install the program that you recommended. And actually this time around I DID find the key in the registry. I'm not sure why I didn't the last time I looked - either it for some reason wasn't there or I overlooked it somehow. Either way, the search is working perfectly now, thank you!
    – Jack
    Aug 30, 2015 at 19:29
  • For some reason, the system regedit sometimes is unable to show certain registry keys (for example when it is run by some system user). I think this is a permissions issue. Third party registry editors to the rescue. Aug 31, 2015 at 7:58
  • 4
    Some people might have been browsing for HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft/ Windows \Windows Search\ which does exist and is why they didn't see the registry key.
    – Randy Levy
    Mar 19, 2016 at 16:21

I had one user account this was working for (User1|) & a newer one that it wasn't working for (User2). Copying the files from




& then rebuilding the index in Indexing Options resolved the issue for me.

  • 2
    I elaborated on this answer over here superuser.com/questions/950102/… … since this seems to be the primary solution. These questions and answers should be deduplicated over time... – Wouter 1 min ago edit
    – Wouter
    Feb 23, 2017 at 16:47
  • Thank you very much....... I fixed multiple things this way. Both start menu search and settings search. The folders that I copied from another local users were: windows.immersivecontrolpanel_cw5n1h2txyewy Microsoft.Windows.StartMenuExperienceHost_cw5n1h2txyewy Microsoft.Windows.Search_cw5n1h2txyewy
    – COOLak
    Nov 11, 2023 at 18:56

I think I've found the solution to this issue:

Run Lpksetup /u and uninstall any possible duplicate language you find there, restart Windows and wait a few minutes.

Edit: this worked for another user https://superuser.com/a/961510/485791

  1. Pin any of the Settings pages to Start.

  2. From Indexing Options, Advanced Options, click Rebuild to begin reindexing. Then restart Windows.

  • There's only US English there, so unfortunately it won't work in my case, but maybe it'll help someone else.
    – Jack
    Aug 23, 2015 at 0:28
  • Add another language from the Control Panel and then remove it. Also, pin any icon from Settings to Start, rebuild the Search Index and restart Windows. Aug 23, 2015 at 1:55
  • I tried with pinning - didn't work, as for languages though - I cannot add any other language, there is just English. My installation was single-language.
    – Jack
    Aug 23, 2015 at 3:57
  • This worked for me <3
    – pulsejet
    Sep 12, 2016 at 10:06

Don't know if it will help anyone else but I just got around this by pinning the Control Panel to the Start Menu and then re-indexing everything.

I then removed the Control Panel from the start menu and I could search the control panel from the start menu.

  • That's a creative way to solve it!
    – Run5k
    Feb 20, 2017 at 13:21
  • I tried all of the above, but this was the only thing that worked. Thanks!
    – Jordy
    Apr 2, 2017 at 22:02

Check if you have disabled indexing on your C: drive.

Also, in my case search didn't look into control panel until I simply pinned it to the start menu. That is search for Control Panel, right click it, select "Pin to Start".

  • Indexing of Start Menu is on. Pinning it didn't help either, I reindexed it, but it still refuses to search Control Panel, unfortunately.
    – Jack
    Aug 18, 2015 at 13:28

This is the only thing that worked for me:

Click on the Windows start button and locate Cortana. Right-click > More > App Settings. Click the 'Reset' button.


I had this problem and it was solved by aligning the input and display languages. Until I applied this fix the search box in Settings would return no results, even if the Start menu search (Cortana) would return correct results (ie. the index was fine).

This appears to have happened because I had regional settings for Australia, display language English (UK) and input language English (US). By simplifying this setup to use English (US) for both input and display, Windows can now find search results in the Settings app. [NB: I have to keep Australia regional settings to avoid dates being displayed as M/D/Y and imperial measures).

I have upvoted the answer above which hints at this solution without directly giving it.


Had this issue for a while and tried everything, what fixed it for me was following:

Disabling Bing search for the Start/Search box circumvents the problem.

  1. Open Regedit.exe and navigate to the following key: HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Search

  2. Create a new DWORD (32-bit) Value, and name it BingSearchEnabled

  3. Leave the BingSearchEnabled value data to 0.

  4. Below BingSearchEnabled registry value, double-click the CortanaConsent value and set its data to 0.

  5. If the value CortanaConsent doesn’t exist, create it manually of type DWORD (32-bit). Exit the Registry Editor.

  6. Exit the Registry Editor, logoff and login back for the change to take effect.

Found the fix from winhelponline.com


You cant uninstall Cortana if you want Search to work in Settings. It doesnt have to run, but it must be installed.

Windows 10 Settings not indexed has correct steps for reinstalling Cortana.


What language are you using? As I was using English (UK) and the control panel items led me to the settings program and the settings program was unable to search. On converting everything to English (US) - the same as my control panel indexing file (C:\Users\username\AppData\Local\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState\Indexed\Settings) language - the indexing worked fantastically for everything.

Hope this helps as it worked for me after looking through forums with similar suggestions to those above.

  • I'm using English US. The problem somehow solved itself it seems however. Now it's back again, but I'm having other problems with my system and I'll reinstall it soon anyway.
    – Jack
    Mar 24, 2016 at 22:10
  • this seems to be the problem for me. What do you mean by "convert everything to en-US" please? Rename the folder? May 4, 2016 at 23:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .