I am not turning laptop off, but rather putting into hibernation, as it starts much faster and I can continue working without starting all apps again.

It was working long time from Windows XP to Windows 8.1.

However now (after upgrade to Windows 10), when I just take my laptop out of the bag after a travel, it was quite hot. I've realized that it is turned on.

In the event log I have found that it was installing updates and before that there was the following log:

The system has returned from a low power state.

Sleep Time: ‎2015‎-‎08‎-‎16T12:55:18.180075900Z Wake Time: ‎2015‎-‎08‎-‎16T12:55:17.852758500Z

Wake Source: Unknown, but possibily due to timer - Windows will execute 'NT TASK\Microsoft\Windows\UpdateOrchestrator\Reboot' scheduled task that requested waking the computer.

When I located the task above in the task scheduler, it has trigger in that time, however the "last run time" is day before. So I do not know what to believe "last run time" or the wake source from the event above?

How to find out what is waking the computer from the hibernation (it is possible?) and how to prevent it?

up vote 66 down vote accepted

This has worked for me so far. Go to:

Control Panel\Hardware and Sound\Power Options\Edit Plan Settings

Click "Change advanced power settings"

Go to "Sleep->Allow wake timers" and change the setting to Disable.

power options screenshot 1

UPDATE: As Erik pointed out, there can be two options:

power options screenshot 2 with 2 options

Disable them both.

  • 10
    Didn't work for me, that was already disabled, and Windows update woke up my PC anyway – Erik Sep 10 '15 at 6:15
  • 2
    Use "powercfg -waketimers" to check for presence of any other wake timers. Some versions of Spotify and TeamViewer are reported to create wake timers as well. However, I also have issue of Windows 10 ignoring disabled wake timers. – voldemarz Sep 23 '15 at 21:53
  • For anyone reading this, Spotify fixed the bug that made it create wake timers a few weeks ago. – Godsmith Nov 2 '15 at 20:38
  • 5
    @Dan: Thanks, but I prefer not to rearrange my life arround MS's incompetence. ; - ) – Nick Westgate Jan 8 '16 at 0:42
  • 2
    @Dan: I'm away from my computer for a few days at a time and I sometimes need to access my computer remotely. If it's in sleep state I can send a WOL packet, to wake it and put it to sleep when finished. However, I don't want it waking up by Windows Update and wasting power for days. – user33339 Apr 22 '16 at 20:12

On WIN 10 there is an option in Local Group Policy Editor to set up it easily:

  1. Search: Local Group Policy Editor (you can launch gpedit.msc)
  2. Navigate to: Computer Configuration / Administrative Templates / Windows Components / Windows Update
  3. Double click on: Enabling Windows Update Power Management to automatically wake up the system to install scheduled updates and set it to "Disabled".

Figure for Local Group Policy Editor setting:

enter image description here

  • 7
    IMO this is the correct solution. To disable wake timers completely is not always desired. – JeffRSon Apr 19 '16 at 9:33
  • 1
    +1, but I don't want it to wake up (at night) for any reason! There is a new setting for Allow wake timers: Important wake timers only. No idea what it does. Hopefully MS themselves will wake up and allow us to specify the time range during which wakes are allowed. Oh, and Windows 10 Home users don't have gpedit but apparently can use a registry hack. – Nick Westgate May 28 '16 at 12:27
  • I've disabled the policy, but the windows task was still registered (checked with "powercfg –waketimers"). Had to go and manually disable the windows task as pointed out in superuser.com/a/958264/267379 to get it working. Hopefully the combination of two will work :D – Sean Feldman Apr 19 '17 at 16:33
  • 2
    I cannot confirm that this policy works. I had already set this policy to disabled since weeks, and yesterday evening the task "UpdateOrchestrator\Reboot" woke the computer up from sleep. – Thorsten Albrecht Jun 15 '17 at 10:20
  • @ThorstenAlbrecht Same here. I'm running 64-bit Windows 10 Pro v1703 (Build 15063.540) and the UpdateOrchestrator\Reboot scheduled task resumed from hibernation this morning even though I have this policy set to Disabled. Actually, I'm surprised my Local Group Policy settings didn't get blown away by the Creator's Update like most everything else did. At the very least I'll try unsetting and resetting this policy and see if that has any effect. – BACON Aug 18 '17 at 17:51

After upgrading to Windows 10, the computer in my bedroom kept waking me up at 3AM. Disabling Wake the computer on the Microsoft\Windows\UpdateOrchestrator\Reboot scheduled task didn't help. Windows turns the flag back on periodically. Even disabling "Disable wake timers" in Power Options didn't help. The UpdateOrchestrator kept orchestrating midnight alarms.

As a solution I've added a powershell script that removes wake settings every hour.

  1. To allow running powershell scripts: run powershell as administrator, and run:

    Set-ExecutionPolicy RemoteSigned

  2. Create a file called "disable_wakejobs.ps1" that contains one line of code:

    Get-ScheduledTask | ? {$_.Settings.WakeToRun -eq $true -and $_.State -ne "Disabled"} | % {$_.Settings.WakeToRun = $false; Set-ScheduledTask $_}

  3. Open Task Scheduler and create a scheduled task.

  4. In the "General" tab, set the user account to "SYSTEM" user (or you'll have to update a saved password every time you change your own password.)
  5. In the "Triggers" tab, create a trigger that runs the job daily and repeat every hour.
  6. In the "Actions" tab, create an action to "Start a program", with "Program/script" set to "PowerShell.exe", and arguments -Command "c:\tools\disable_wakejobs.ps1" (change the path to where you stored disable_wakejobs.ps1 in step 2.)

The PowerShell commands come from this blog post by Reidar Johansen.

  • I get an error running this: Set-ScheduledTask : The parameter is incorrect. At C:\Users\Filip\scripts\disable_wakejobs.ps1:1 char:123 + ... Disabled"} | % {$_.Settings.WakeToRun = $false; Set-ScheduledTask $_} + ~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : InvalidArgument: (PS_ScheduledTask:Root/Microsoft/...S_ScheduledTask) [Set-ScheduledTask], CimException + FullyQualifiedErrorId : HRESULT 0x80070057,Set-ScheduledTask – Godsmith Oct 6 '15 at 16:33
  • None of the other solutions worked for me so I'm hoping this does the trick! Hacky, but whatever I can do to not have my PC turn on in the middle of the night, I'll do. – GotDibbs Dec 1 '15 at 1:10
  • 10
    How crazy is that? You cannot even rely on the settings anymore and they got resetted. Is microsoft out of their mind? It's totaly unreliable. – t3chb0t Dec 8 '15 at 13:51
  • I see no way to set the user account to "SYSTEM" user in step 4. – Castaa Dec 12 '15 at 0:46
  • @Castaa- bit later, but you change it by selecting Change User or Group, and then typing in System and then press check name. End result should look like this: puu.sh/mOIX4/58082e816e.png – Paul Jan 30 '16 at 0:10

This should solve your problem:

  1. Search Task Scheduler
  2. Navigate to Task Scheduler Library\Microsoft\Windows\UpdateOrchestrator\Reboot
    Note: Reboot is just a file, but you need to go inside all those folders
  3. Right Click Properties then click Conditions
  4. Uncheck Wake the computer to run this task
  • I have change that, hopefully it will not run again. – TN. Aug 17 '15 at 8:02
  • 11
    This is not the solution; Windows will re-enable the checkbox again next time :-( – kipusoep Aug 19 '15 at 6:57
  • I did this, but Windows turned the flag back on. Windows even ignores the "Disable wake timers" setting. Here's a blog post that shows how to uncheck the "Wake the computer" from a scheduled task. – Andomar Aug 20 '15 at 4:54
  • Yes, the checkbox is enabled again... – TN. Aug 20 '15 at 11:22
  • 2
    Not only that WIndows resets this option, it even fails to enter it as a reason so that the user knows why the computer rebooted: When I ask powercfg for the reason, it says "unknown" :( this is bad by design, and Microsoft should fix this ASAP, took me hours to actually find out what kept waking up my system. Besides, the reboot was totally unnecessary, because I already did it right after the update, but Microsoft decided to reboot anyway :( – Erik Sep 10 '15 at 6:11

I am using Wake On LAN (WOL) feature on my computer so that I can wake up my computer remotely if I need to access it while I am away.. in order for WOL to work is that I have to allow my network card to wake the computer when I send the WOL magic packet.

This is somehow causing my computer to wake up randomly for no apparent reason. To know whether this is causing your computer to wake up randomly, type this command in the command prompt:

powercfg -lastwake

enter image description here

If you see something about your network card (as of mine Realtek PCIe).. then you need to go to your network card properties setting and make sure the Only allow a magic packet to wake the computer check box is checked (mine wasn't):

enter image description here

Then pray to your God...

  • This is the only one that worked for me :D – Jamie Hutber Mar 25 '16 at 11:46
  • 1
    That's a good solution to a different question. The question identifies "TASK\Microsoft\Windows\UpdateOrchestrator\Reboot" in Windows 10 as the cause. WOL is tricky to get set up properly though, so hopefully this helps others too. – user33339 Apr 22 '16 at 20:14

That appears to be the system maintenance task running. If so, you might try disabling system maintenance.

WIN+R control search for "maintenance" in the search box, select "Change Automatic Maintenance settings".

Clear the "allow scheduled maintenance to wake up my computer at the scheduled time".

See if that helps remove the issue. It's going to be a lot more reliable than some of the other mechanisms proposed.

  • I have this checkbox unchecked. (So it won't help in my case.) – TN. Aug 24 '15 at 8:55

Applying Andomar's solution, I also got the error:

  • Set-ScheduledTask : The parameter is incorrect. At C:\Users\Filip\scripts\disable_wakejobs.ps1:1 char:123 + ... Disabled"} | % {$.Settings.WakeToRun = $false; Set-ScheduledTask $} + ~~~~~~~~~~~~~~~~~~~~ + CategoryInfo : InvalidArgument: (PS_ScheduledTask:Root/Microsoft/...S_ScheduledTask) [Set-ScheduledTask], CimException + FullyQualifiedErrorId : HRESULT 0x80070057,Set-ScheduledTask

In my case this was due to a task which cannot be edited (AUSessionConnect within WindowsUpdate to be precise). So I edit the responsible task directly (Reboot within UpdateOrchestrator). The corresponding disable_wakejobs.ps1 file looks like this (for how to use that file, check out Andomar's answer):

Get-ScheduledTask -TaskName "Reboot" | % {$_.Settings.WakeToRun = $false; Set-ScheduledTask $_}

To test the script manually ensure you run it from an elevated PowerShell instance (Run as Admin).

I ran into problem where UpdateOrchestrator re-enabled itself again. This ofcourse caused my computer to wake up from sleep mode by itself (seriously snap you microsoft for also waking me up in the middle of the night). Found some info on reddit that seems to solve it.

Open powershell:

  • run: Get-ScheduledTask | where {$_.settings.waketorun}

Open cmd:

  • Run SCHTASKS /Change /TN "Microsoft\Windows\UpdateOrchestrator\Reboot" /DISABLE
  • Run icacls "%WINDIR%\System32\Tasks\Microsoft\Windows\UpdateOrchestrator\Reboot" /inheritance:r /deny "Everyone:F" /deny "SYSTEM:F" /deny "Local Service:F" /deny "Administrators:F".

This will prevent the task from being enabled again. This assumes you're running an English version of Windows - translate the user names as necessary or find the SIDs, if required.

Original post on reddit. https://www.reddit.com/r/Windows10/comments/48rg7x/is_there_any_way_to_stop_updateorchestrator_for/

windows 10 has two things you can diable for wake timers

when you go into advanced power setting I found under wake timers you will see disable wake timers then under that you will see an important wake timer, disable that one too.

  • It seems to me that it depends whether the PC can have battery or not. I have updated the Nick answer. – TN. Sep 11 '15 at 8:56

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.