The computer started off as running windows 8.1 out of the box. When windows 10 was officially released, the computer was upgraded using a usb drive with windows 10 installation media, rather than waiting for the upgrade that automatically comes from Microsoft. During the install process, it asked for the windows product key. This laptop didn't come with a product on a sticker, rather it had a bios encrypted product key that couldn't be accessed, and should automatically activate windows. There was no skip option, so a sample product key was inserted in order to get past the screen, and it accepted it. Once windows 10 booted, it told us that activation failed, even though we thought that windows would find the real product key. So, I decided to roll the computer back to windows 8.1, and do the upgrade from inside windows, to ensure that it was activated.

However, when I chose "windows rollback" as a boot option, it hung on "restoring to previous build", and then shut down. When I tried to power on the computer, I got a blue screen. I googled, and explored the recovery environment to try and get the system to boot, and eventually I got the computer to restore to windows 8.1. However, now, the mouse and keyboard don't work. I have deleted and rediscovered the mouse and keyboard in the device manager, I have reinstalled the touchpad driver from the OEM, no luck.

I had the idea of using the windows "refresh" feature. I had used it on this computer before, and it had fixed display issues, which I think may have been due to driver problems. I tapped the refresh button, typed in the admin password, and the computer refreshed successfully by itself. (No recovery media required.)

Now, when I hit refresh PC, it asked for recovery media. So I looked on Microsoft's KB, and they said, that if you need refresh/reset media, download the "media creation tool" and create media. So I downloaded that, plugged in a flash drive, and it made the flashdrive into a bootable windows 8.1 flash drive. (Which I could boot from, and use the recovery tools.) But when I pressed refresh again, and it asked me for recovery media, I inserted the flash drive, created by microsoft's offical tool, and it said, "the media inserted is not valid". I've rewritten the drive multiple times, and it still does not work.

Extra info:

  • The touch screen still works.
  • It is not a hardware issue, the mouse and keyboard work in the windows RE environment, that is loaded on the computer.
  • USB mouse and keyboard work

If you need more info, just leave a comment.

  • Have you considered Linux? – yuvi Aug 16 '15 at 23:49
  • Jokes aside, it sounds like a drivers issue. Have you tried installing Windows 10 over 8.1 through the official installer like you planned? It might resolve that along the way – yuvi Aug 16 '15 at 23:50
  • @yuvi Yeah, I ended up running the installation media creation tool from that computer, and the upgrade worked fine. – ak11234 Sep 14 '15 at 22:48

First, if you haven't backed up your data and any product codes or critical settings, do that please.

The reason that the 10 upgrade didn't pick up the product code from the bios could be that your bios was set to auto mode for AHCI, or doesn't have AHCI support. Have you updated your bios and make sure you force AHCI on? That may clear up the first problem. Certainly I had to force AHCI on my Samsung Chronos and to upgrade the BIOS on my wife's Sony laptop. That may help you get back to a functioning Windows 10. Note also if you can run any Windows applications under 8.1 then you can load 3rd party software to get your product key and try typing it in during the reinstall.

If you end up stuck with a disfunctional 8.1, the chances are you are missing critical drivers the manufacturer would have given you hopefully as a cd/dvd or put into a recovery partition. Simply run that if have a CD and do a fresh install, and restore the backed up data and settings (but not system or drivers). A bit painful, but at least it should then allow you to automatically upgrade to Windows 10 when you have run Windows update a few times.

If you don't have (or weren't given) the recover cd/dvd then run windows disk management utility (search for disk management or partition management on your computer and select "create and format hard disk partitions".

Partition Manage

and you may find a OEM recovery partition which you can either add a drive letter (if it is not protected) or copy it using a disk copy tool to your USB drive to rebuild your recovery "disk".

Hope one of the above helps!

  • Thanks for the answer @brianlmerritt That sounds like a good solution, and I appreciate the detailed response. I have already solved the problem, by making windows 10 installation media again, this time from the computer I wanted to upgrade, and the upgrade worked. I don't really know exactly what was going on, but the computer works fine now, and I don't have the time to investigate further. Thanks though. – ak11234 Sep 14 '15 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.