Occasionally Task Manager shows that "Store", "Settings", and/or "Calculator" are mysteriously running as background processes.

  • There's no corresponding foreground application, just the background processes.
  • I haven't interactively run either during the current session.
  • Neither is listed in the "Everything" tab of AutoRuns.

As discussed in my answer to this SuperUser question, these two background processes cause a delay in executing Windows shortcut keys. But besides that, it's just plain weird.

Does anyone know why these foreground apps are mysteriously launching themselves as background processes?

And, ideally, how I can prevent it from happening? As discussed elsewhere (SuperUser and Thomas Vanhoutte), I could uninstall the Calculator and Store apps. But it seems like overkill to uninstall them just to defeat a shortcut key delay.

  • 5
    Check in Start -> Settings -> Privacy >Background apps. If these apps are listed, set them to Off (more info). – harrymc Aug 20 '15 at 6:26
  • +1 Great tip. Store is listed, so I unchecked it and we'll see how things go. Unfortunately Calculator isn't listed, so I expect that will continue to cause problems. I'm befuddled as to why Calculator (or Store) would randomly launch in the background. – Andy Giesler Aug 20 '15 at 14:21
  • Re "these two background processes cause a delay in executing Windows shortcut keys.", Another problem is that they show up in the list of running applications when using a virtual desktop managers like VirtuaWin, and the virtual desktop manager can make them become visible. Both of these things are annoying. – ikegami Feb 10 at 0:34
up vote 22 down vote accepted
+200

Store probably runs for doing automatic update check.

To turn it off, go to Start -> Settings -> Privacy -> Background apps and set it to Off.
More info in the article: How to Turn On or Off Background Apps in Windows 10.

You might also in this case turn off automatically-applied updates by going to
Settings -> Update & Security -> Advanced options
and set "Choose how updates are installed", to "Notify to schedule restart."

For the calculator :

I believe that this Modern app is among those that Windows 10 tends to keep in memory if used once. It probably runs in suspended mode, using very little memory, ready to be launched quickly when called, which is more useful in a tablet than a computer.

Windows might forget about it if you kill it off a few times using the Task Manager before shutting down. If this works, I advise in the future to use a third-party calculator instead of the Modern one, or it will come back.

  • 5
    The peculiar thing about Calculator is that more than once the following has happened: I start my computer, checked task manager, and confirm it's not running; then a while later I find it in the background even though I haven't run it during that session. – Andy Giesler Aug 21 '15 at 21:27
  • 2
    You could use Process Explorer to find in the Properties of the calculator its parent that launched it, but I assume you will find that it's a component of Windows. You can still uninstall the calculator as shown here, as it's not as essential as the Store, and use instead a third-party one or even the one from Windows 7 (Google for it). – harrymc Aug 22 '15 at 6:39

Disabling the SuperFetch service can prevent applications from starting on their own.

We've found out that with SuperFetch running, some applications are started in the suspended state automatically once or twice an hour, even after you explicitly kill their processes. This happens for Windows Store/Modern UI/Metro apps like Photos, Calculator, Maps, Weather, Time and so on.

How to Disable SuperFetch

From the Command Line

Run this command under Administrator:

sc config sysmain start=disabled

Additionally, stop an already running SuperFetch:

sc stop sysmain

From the UI

  1. Press Windows+R, type services.msc and press Enter.
  2. Find SuperFetch in the list, and double-click it to open its properties.
  3. Set Startup type to Disabled.
  4. (Optional.) Click Stop to stop an already running SuperFetch.

    Disable SuperFetch

  5. Click OK to save the changes.

  • SuperFetch does not "launch applications in background". Proof: You wil never find an application process created by the SuperFetch process. (The "process tree" view of Process Explorer will show you which processes created which other processes, at least as long as the creator is around.) – Jamie Hanrahan Sep 10 '15 at 10:05
  • @JamieHanrahan: OK I rephrased that. – Helen Sep 10 '15 at 13:18
  • 1
    +1 - I was a little skeptical, but since disabling SuperFetch there hasn't been a single instance of my problematic apps (Calculator and Store) launching in the background. – Andy Giesler Jan 3 '16 at 19:53
  • Is it a good idea to disable this though? It's meant to decrease boot time and make loading of applications more efficient. It's not entirely clear to me how it does it but since it's been around since Windows Vista I assume it's actually helping. – this.lau_ May 26 '17 at 21:02

I too am seeing the shortcut key delay issue in Windows 10. I believe it is caused by any Metro app sitting in the "suspended" state (as reported by Process Explorer). I have seen it caused by the Photos app, Video app, Calendar app, etc, which seem to launch randomly by themselves as he OP reports.

So it seem the shortcut key delay issue a general issue with (most/all?) apps in the suspended state.

I have checked the Background apps setting in Privacy, but it does not list all the problem apps. E.g. the Calculator and Video apps are not listed there.

Reported on the Microsoft forum: 3 second delay when using shortcut key to launch program

My solution for now is to have a batch file which I can run on demand, killing problem processes using taskkill /f.

Had the same problem, I had changed the settings of background apps, and it didn't change anything, the same apps were showing in the background and staying, the only way to shut them, was to start them and then shut them, then they would disappear from background.

I saw here that disabling superfetch was maybe the way...so I didn't do it. I just deleted all the files in prefetch folder (c://windows/prefetch/) so it would start anew.

All the subsequent restart of Windows have not shown the problematic background apps again.

protected by JakeGould Dec 14 '15 at 7:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.