6

I recently upgraded to Windows 10 from Windows 7. I have pinned File Explorer to the task bar, and if I right click on it I see a list of pinned folders including anything I have under 'quick access', but if I click on any of these, nothing happens. If I right click a folder in the pop-up and select "Open", nothing happens. The only action that opens a new Explorer window for me is selecting "File Explorer" from the pop-up which opens a default window, which I can then use the quick access list to change locations.

Is this what others are seeing? A bug in Win 10? Something wrong with my configuration?

The workaround of opening a default Explorer, then changing locations is fine, but why is it even showing a list of options if I can't select them?

  • 1
    This isn't happening on mine, sadly. Something in your install is wonky. – Cora Aug 16 '15 at 20:55
  • You could try using the System File Checker, enter sfc/ scannow in a Command Prompt to see if it repairs anything. – MC10 Aug 16 '15 at 21:39
  • Good idea MC10, but unfortunately it didn't find any problems. – Still Learning Aug 16 '15 at 23:12
  • I'd try 'Windows all in one Repair' from tweaking.com [free/donationware, with extra purchased 'pro' options not necessary for this task]. My bet is faulty Reparse Points, but just go through the tool, doing every step, exactly as it says. You can skip the sfc part if you've already done it, but do all the rest. (no affiliation, just a happy user) – Tetsujin Aug 17 '15 at 6:14
  • I tried tweaking's repair but unfortunately the problem is still there. Next step is to ask MS for help (though I gave up after 45 mins on hold yesterday) – Still Learning Aug 19 '15 at 14:00
3

I had the same problem, on two computers, which I've been annoyed by for months. The problem instantly disappeared on both when I uninstalled WinCDEmu just now.

Maybe you have that or a similar program installed?

Edit to clarify: WinCDEmu loads up disc images like ISOs as virtual disc drives. Similar programs might include Daemon Tools or PowerISO.

I found this solution here

  • I'm trying to think what Cubby and WinCDEmu have in common. This line from Cubby's website sticks out at me: "Turn folders into cubbies where they live on your computer, and keep file structures in tact". I did report this as a bug at WinCDEmu's forum. Both programs manipulate folders via the right-click menu... not sure what they have in common beyond that. The solution is evidently "uninstall things until it works." And then please post which program was causing the problem for you. – Eric Lofgren Aug 23 '15 at 20:45
  • Thanks Eric, I also had WinCDEmu and removing it allows the instances to open. The only problem I have left is that a new Explorer window often opens (but not always) when double-clicking to open folders. Under File > Options I have chosen "open each folder in the same window". For bonus points can you help with that too? :) – Still Learning Aug 24 '15 at 20:36
  • Not sure I can help with that one; I've never had that happen. Is there a pattern (i.e. do certain folders always open in a new window)? I found a question at microsoft.com where someone always had the Pictures directory open in a new window; they wanted to blame photoshop but hadn't found a solution yet. – Eric Lofgren Aug 25 '15 at 13:33
  • Unfortunately no pattern that I can figure out yet. Sometimes I double-click and it opens within the window properly. Other times the same folder opens in a new windows. Other times I get 2 new windows. But I did find that it doesn't happen on my Administrator account, so it's probably something unique to my user. One possible solution is to create a new user and migrate my data over, then say bye-bye to my original. – Still Learning Aug 25 '15 at 14:26
5

I had the same problem and was able to pinpoint the culprit by using the excellent (and free) Shell Extensions Manager by NirSoft. I tried using autoruns from Sysinternals but the latest version as of this writing was very buggy, so I would strongly recommend against using it.

Here are the steps which worked for me, and not tied to a specific program like WinCDEmu (although it should also fix it).

  1. Save your work.
  2. Launch shexview.exe
  3. Run taskmgr.exe (Task Manager) and kill all explorer processes (in the "Details" tab).
  4. Disable all extensions in Shell Extensions Manager (select them and choose "Disable selected items").
  5. Run explorer.exe from Task Manager > File > Run new task.
  6. Check if the behavior is fixed. If it is, then continue, otherwise, reenable all extensions previously disabled and continue looking for an alternative solution as this one will not help you.
  7. Enable some extensions starting with those you think are unlikely to cause an issue (in my case it was a "Context menu" extension from Boxifier), and repeat steps 3-6 until you have found the culprit.
  8. When the culprit is found, just leave it disabled and the issue should be solved! You can report the bug to the developer of the responsible app so that they can fix it.
  • Thanks! In my case, this was Hubic, which caused this problem after I upgraded to Windows 10. – Yuri Vyatkin Nov 29 '15 at 5:03
  • this is an excellent answer and should be marked as important! In my case, I found autoruns now is working just fine – roberto tomás Mar 11 '17 at 15:27
0

This happened to me a few times in Windows 8.1. I fixed it each time by unpinning File Explorer and then re-pinning it from within the C:\Windows folder.

enter image description here

  • Thanks for the suggestion but it didn't make a difference. Of course to pin it, I had to have it open to view the C:\Windows folder. I tried opening explorer from the command prompt after unpinning it, and then from the C:\Windows folder right clicking on explorer.exe as you showed and selected "Pint to taskbar". The behaviour was unchanged though. Still nothing happens when trying to open something from the popup. – Still Learning Aug 18 '15 at 1:14
  • @stvcisco That's interesting. Is the same behaviour present on the local administrator account or any other account? – Dog Lover Aug 18 '15 at 2:02
  • I've only got one account and it's an Administrator. – Still Learning Aug 18 '15 at 20:11
  • @stvcisco Try in CMD: net user Administrator /active:yes. – Dog Lover Aug 18 '15 at 22:03
  • Ok, I tried that - didn't make any difference. I also switched users to Adminstrator and that id had the same behaviour. – Still Learning Aug 19 '15 at 0:58
0

Many thanks to Erwin. I found the solution. I followed his troubleshooting steps using Shell Extensions Manager by NirSoft and found that my problem was a context menu item added from mov avi video converter appearing as "SimpleShlExt Class". As soon as I disabled It everything works fine with files explorer jumplist pinned on taskbar. Many thanks again to Erwin!!!!!

old answer: "I have the same proplem. Right click on files explorers (on task bar) pinned shortcuts does not work. This happend a week ago. I have upgraded from windows 7 pro to 10 pro about 2 weeks ago.

In another computer I upgrated form windows 8.1 with bing to winodows 10 home. The problem on this computer does not exist. Right click on pinned links work just fine.

If you pin libraries rather than any other folder (i.e. "Libraries\Documents" instead of "this PC\Documents") works on my pc. I hope this can help a little."

  • Many thanks to Erwin. I followed his troubleshooting steps using Shell Extensions Manager by NirSoft and found my problem was a context menu item added from mov avi video converter appearing as "SimpleShlExt Class". As soon as I disabled It everything works fine with files explorer jumplist pinned on taskbar. Many thanks again to Erwin!!!!! – Testantinos Nov 13 '15 at 9:15

protected by Community Aug 25 '15 at 14:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.