In Windows 10, when I search from the Start Menu or Settings, only Control Panel results appear, but not the new Windows 10 settings. For example, if I type "update", the search results are "Update device drivers" and "View installed updates"; "Check for updates" is missing. If I create a new test user account, it has the same problem.

This used to work. It broke when I reinstalled Cortana and rebuilt the index to solve a different problem, which was that desktop apps weren't showing up in search results, and/or after I removed C:\Users from the search index (I wanted more narrow indexing) but then put it back when problems arose. I tried a full reset of Indexing Options by setting HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\SetupCompletedSuccessfully to 0 and restarting the Windows Search service. It didn't help. Any ideas?

  • Do any of the suggestions from this thread help? reddit.com/r/Windows10/comments/317gce/… It was posted during the preview but people have been reporting that it's the same for release. Have you restarted the PC itself?
    – MC10
    Commented Aug 17, 2015 at 1:17
  • @MC10 Nothing there worked, not did restarting, including after the re-index completed. Commented Aug 17, 2015 at 1:52
  • possible duplicate of Windows 10 : Cortana Search Is Not Finding Apps
    – DavidPostill
    Commented Aug 17, 2015 at 9:26
  • 1
    @DavidPostill Unlike the "Not Finding Apps" problem, in my case, all apps and indexed and display properly, as well as documents and even old-school Control Panel items. Only the Settings items are missing. Additionally, the leading answer to that problem - running Get-AppXPackage - had no effect. Commented Aug 17, 2015 at 11:35

9 Answers 9


I ran into this same issue and tried just about everything under the sun to fix it and ended up giving up and reinstalling. My friend recently ran into the very same issue (ONLY things from the new settings panel not showing in search results either from start search or directly from settings), and he said this fixed it for him: %LOCALAPPDATA%\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState

First, make sure Indexed\Settings folder is not empty. You should have a folder such as en-US (depending on your language) with bunch of files in there. If it is empty, you should copy the files from another account or computer as described in the answer below.

Then, right-click the Indexed folder → PropertiesAdvanced → Check Allow files in this folder to have indexed in addition to file properties.

Click Apply and Exit.

He said in his case, it was already checked, but he unchecked it → applied → rechecked it → applied and that fixed it for him.

  • 1
    Worked great thanks! Fixed not being able to go directly to settings from start menu and also searching while inside the settings "app".
    – John
    Commented Jan 22, 2016 at 22:16
  • 4
    You and your friend are lifesafers, kudos! (you may need to reboot or restart Explorer). Been driving me crazy for months, MS should special-case crucial OS folders like this so a user can't accidentally break them just by changing global drive indexing settings.
    – gl-
    Commented Mar 4, 2016 at 13:52
  • This also fixes an issue where it says "These results may be incomplete" (and never completes even though the indexing is done). In my case it was because of the en-us folder missing. Thanks so much! Commented Jan 2, 2017 at 3:01
  • I elaborated on this answer over here superuser.com/questions/950102/… since this seems to be the primary solution. These questions and answers should be deduplicated over time...
    – Wouter
    Commented Feb 23, 2017 at 16:45
  • I used this one windows Server 2016, works perfectly
    – andrew
    Commented Sep 28, 2018 at 23:41

I think I've found the solution to this issue:

Run Lpksetup /u and uninstall any possible duplicate language you find there, restart Windows and wait a few minutes.

  • I tried. Only one language (English) was shown (no duplicates). The wizard wouldn't let me uninstall it even if I wanted to. Commented Aug 23, 2015 at 0:01
  • Add another language from the Control Panel and then remove it. Also, pin any icon from Settings to Start, rebuild the Search Index and restart Windows. Commented Aug 23, 2015 at 0:18
  • Thank you! This is what finally worked for me. I had two copies of "English (English)" installed. Removing one and rebooting finally fixed the problem
    – Alan
    Commented Oct 9, 2015 at 11:39
  • This did really work for me. I will give you the point, because my indexing problem came out after changing from Spanish (Spain) to English (USA)
    – Dazag
    Commented Aug 29, 2016 at 10:08
  • 1
    Unfortunately, that window only lets me uninstall "English", which I want to keep. It doesn't let me uninstall "German", because it "is the system language", even though I removed it everywhere else, and changed all region and locale settings to English.
    – mivk
    Commented Feb 9, 2017 at 15:24

I tried the top answer to this post on the indexing options for the folder at the following link:


It did not work. I noticed that my "indexed" folder only contained an empty "settings" underneath. I logged into a local account on my machine (where search was working properly), and found that it had a folder called "en-US" under "settings" with a bunch of files underneath that my domain account was missing. I copied this folder and pasted it at the following location on my domain account:


After this I restarted, and my search was fixed!

Looks like there is probably a multiple cause issue with same effect going on. For me it was right after a fresh domain install. Perhaps others have a different issue with the same effect where indexing permissions get messed up. For me, the actual items that needed to me indexed were missing.

Hoping this hack of a fix sticks. At least the basic things I use now work, so that's all I need for now. Hopefully this is helpful for others. Good luck!

  • This exact thing happened to me as well. The folder was empty, copying it from another computer and rebooting fixed this.
    – joon
    Commented Dec 10, 2016 at 19:40

Ugly workaround: Don't a use Microsoft account.

Less ugly workaround: Put up with it until Microsoft issues a fix.

Fortunately, there are dozen's of reports of this in the Windows feedback app, which increases the odds of a fix. To that end, I posted the following repro. It certainly seems related to account types.

  1. Clean install Windows 10 Enterprise x64.
  2. Create a local user. (At this point, search works.)
  3. Create a new user via a Microsoft account -or- connect the current account to a Microsoft account.
  4. Sign in via the Microsoft account. (At this point, search is broken. For example, typing "check" does not provide a "Check for updates" result. Old-style Control Panel items appear, but new-style Settings do not.)
  5. If in step 3, you created a new account, sign back into the local account. (At this point, search works again. It is only broken for the Microsoft account.)

@Zediiiii was almost right

  1. PowerShell with Admin rights (uninstall Cortana app)

Get-AppxProvisionedPackage -Online | Where-Object {$_.PackageName -like "*cortana*"} | Remove-AppxProvisionedPackage -Online

  1. Log in with another admin account

  2. Delete %LOCALAPPDATA%\Packages\Microsoft.Windows.Cortana_cw5n1h2txyewy folder. Don't forget to go to the folder of that user account!

  3. Log out and login back to the affected user account

  4. PowerShell with Admin rights (install Cortana app)

Get-AppxPackage -Name Microsoft.Windows.Cortana | foreach {Add-AppxPackage -register "$($_.InstallLocation)\appxmanifest.xml" -DisableDevelopmentMode}

  1. Reboot. Maybe sign out and sign in will work too without reboot.

I spent much time trying to solve this issue. Like @Edward Brey I had search functions working for some things, but not for others and especially not for any settings.

I had broken this because I mucked about in the cortana and indexing settings to try and make my computer run a bit quicker. Reindexing, modifying registry keys, exporting a working search registry key and reimporting, reinstalling cortana, rebuilding index, erasing all index entries... None of these worked for me by themselves. So I tried a shotgun approach and did everything - and it worked.

Before going through my process, I would suggest attempting only the last step and seeing what happens. I suspect it may work alone.

Here was my process:

1-Turn of windows search service. First, run services.msc and find Windows Search and set to disabled. End the windows search process.

2-Uninstall cortana.

Get-AppxProvisionedPackage -Online | Where-Object {$_.PackageName -like "*cortana*"} | Remove-AppxProvisionedPackage -Online

You may have to turn off the "get to know me" setting in privacy settings before this step will work.

3-Deleted all index entries by control panel -> indexing -> modify and then uncheck all the boxes.

4-Turn off indexing for all file content in your main hard drive. This is done by right clicking on the drive in my computer, then unchecking the "allow files on this drive to...". Let it run for all subfiles and folders. Ignore all errors when the option is presented When completed, recheck the box and follow the same steps.

5-Set the DWORD for HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\SetupCompletedSuccessfully to 0.

6-Restart the machine.

7-Reinstall Cortana:

Get-AppxPackage -Name Microsoft.Windows.Cortana | foreach {Add-AppxPackage -register "$($_.InstallLocation)\appxmanifest.xml" -DisableDevelopmentMode}

8-Finally, add the index locations you want back in using the control panel index options. Be sure to add %LocalAppData%\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState

if you want your settings to show up.

This fixed my cortana/search woes, and saved me a refresh install. I'd love to know if using only step 8 fixes the issue.

Also, I must cite http://www.askvg.com/fix-we-are-getting-search-ready-problem-in-windows-10/ for some of the tips. I tried a few other things too, but this was the final method that worked. Hopefully none of the other tweaks were part of the final solution.

  • Note, my search functions worked correctly with Cortana disabled via GPE after this process. I wish I knew about superuser.com/a/963621/210811 before all this nonsense.
    – Zediiiii
    Commented Nov 16, 2015 at 17:48

Old thread, no idea if this will help anyone, but I tried every solution out there, but finally got this fixed. I had tried the following...

  • Modifying the %LOCALAPPDATA%\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState folder indexing options

  • Regedit: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\SetupCompletedSuccessfully > Set to 0 (zero)

  • The various Powershell "Get-AppxPackage" commands

  • SFC

  • DISM
  • Resetting/Rebuilding indexing
  • Lastly, I did an in place "upgrade" using the Microsoft Media Creation Tool, "upgrading" from Windows 10 Pro to the very same (Windows 10 Pro) on my Surface Pro 4. AKA a repair.

...So I'd tried it all. As a side note, I use a domain-joined account, but I doubt that makes a difference because I'd deleted the local Admin account I'd created during initial setup, and created a brand new local account during troubleshooting. I then signed in with the new local account I'd just made, and the search function was still not working correctly. That told me this was a system issue, not a profile issue.

So after the repair, I signed in with my domain account (and the local account), and search was STILL not working properly - no "Settings" results, and limited program, application, and control panel setting results.

But then...I went through and actually finished the Cortana setup by signing in with my personal Microsoft account, and poof everything worked flawlessly. Instantly.

Hope this helps someone out there, I spent all day on this bashing my head against the wall and I don't even feel relieved given how stupid the fix was for me.


The most radical, yet effective solution is to reset Indexing Options to defaults. Since there is no official method to do this, one can use unofficial method, editing Windows Registry. The steps to perform are described here: https://superuser.com/a/963621/210811.


For me the issue came from when changing language to English, and the new index setting language folder is not created.

The solution that worked for me was to go to here:


and copy a ru-RU (as example) and paste as copy folder and rename to en-GB (for UK) en-US (for USA).

Once completed navigate to the following location:


and right click on indexed folder, then Properties>Advanced , Un-Check the Allow files in this blah blah blah and press ok and apply, then go back and check again > OK > Apply.

This should sort it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .