11

After upgrading to Windows 10, after waking the computer from sleep, 3 finger swipe gestures (to minimize all windows or to go to task view), stop working. 3 finger click still brings up Cortana. I'm on a Lenovo Yoga 2 Pro using the Windows 10 19.0.9.5 touchpad drivers. Any help is appreciated!

Edit: This isn't a duplicate of the question linked by Ramhound. That question concerns a touchpad being completely disabled after sleep. In this case, only three finger swipe up doesn't work; everything else is totally fine. The solution is to restart "synaptics touch pad 64 bit enhancements". I don't have access to the laptop in question at the moment, but a simple "taskkill /IM SynTPEnh.exe" will end the process. The process will automatically restart. You might want to put this command in a batch script and schedule it to run on wake up, though I haven't been able to successfully use the Windows event system to do this, and just manually run the script on wake up.

5

until synaptics(the touchpad manufacturer) comes with a fix we had to manually restart the synaptics services after resuming from sleep


start the task manager
look for "synaptics touch pad 64 bit enhancements"
click on it
then click on the "end task" button



by now two finger scrolling shouldn't work don't worry
go to control panel
then hardware and sound then synaptics
it might ask you to unistall driver click NO
the synaptics options window appears
wait for 3 or for seconds and all gestures will start working

  • Looks like for me, simply ending the process causes it to restart and gestures to work again. Thanks! – Slithy Toves Aug 25 '15 at 17:48
  • @SlithyToves Yep, ending the process for me also just works. Lenovo T460s – tk01 Mar 22 '16 at 1:27
4

I've had this same issue, also on a Spectre X360 (Skylake). Once updating to Win10 1511, I would lose multi-finger gesture support on the Touchpad after the machine slept. (Scrolling worked, but 3/4 finger tapping and flicking did not).

Thanks to this post, I found that restarting the SynTPEnhService.exe usually fixed this. However, with the most recent Synaptics driver update, I have found that service is no longer installed or running. Instead, a normal userland process SynTPEnh.exe seems to be taking care of the same tasks. As @firstever notes in the provided script, killing and restarting this process fixes the issue. But that is a pain every time I wake my laptop! As a "permanent" fix, I have done the following.

First, I have created the following batch file: (The powershell script would probably be fine. I'm showing the grey in my beard here!)

taskkill /im SynTPEnh.exe /f 
Start "" "C:\Program Files\Synaptics\SynTP\SynTPEnh.exe"

Then, I used the Windows Task Scheduler to create a new task (not Basic task - all options won't be shown).

Under the Triggers tab, I added a trigger and selected "On Workstation Unlock"

Under the Actions tab, I added a "Start a Program" action and pointed it to the above batch file.

I also made sure to visit the Conditions tab and uncheck the "Start only on AC power" option.

Since doing this, I am never without my gestures for more than a few seconds after waking the machine from sleep. It's not a perfect solution (Synaptics! Fix this!) but the problem is essentially invisible for me now.

  • Hi, is there any new update recently? My laptop has similar problems for years. And it is not 3-finger but 2 finger scroll gesture (other 3-finger 4-finger gestures all work without problem). Only 2-finger scroll failed to work after wakeup. I often use windows Insider fast track to quickly get a new Windows 10 to solve it, but this depends on luck. On some versions of Windows, it is ok, but for some versions of Windows, the 2-finger scroll broke. Thanks for your script this solved my 2-finter problem but I wonder whether there's update or not. – user534498 Dec 16 '18 at 23:02
3

Solved (Tested on Yoga 900)

This is NOT mindless tinkering (killing services, etc), the OP looks like he knew what he was doing and this just worked for me straight off the bat. I'm running a Yoga 900 with stock win 10 64 bit.

http://answers.microsoft.com/en-us/insider/forum/insider_wintp-insider_search/three-finger-swipe-for-task-view-not-working/547d5c1b-7a84-423b-bdbc-3ffc7084526a?auth=1

I'm pasting the link content here for my own future reference and if the link goes down

I had this problem with my Synaptics touchpad on a Lenovo laptop running Windows 10. (Fortunately it only one of two user accounts was broken)

I used Regedit to fix the problem

  1. Press Win and type Regedit
  2. and Navigate
    • HKEY_CURRENT_USER
    • SOFTWARE
    • Synatics
    • SynTP
    • TouchpadPS2 (this has numbers as well)
    • 3FingerGestures
  3. OK we are in the right place For the 3 Finger Swipes to work correctly edit the following ActionIDs to the following ActionID1 = 5c ActionID3 = 5f ActionID5 = 5d ActionID7 = 5e
  4. Exit the Registry Editor and reset (reboot or signout and signin)

The 3 Finger Swipes should now work as intended. HOWEVER. Some people prefer the 3 finger swipe to control the forward and back button in browsers set ActionID3 = 1c ActionID7 = 1c

okay, after making the laptop sleep when the swipe gesture was working made it stick across sleep-wake cycles. I've made the laptop sleep several times and swipe's still working :)

  • 1
    This fixes the wrong association of actions to the swipes but it still gets disabled after sleep-wakeup; still looking for a solution – Dheeraj Bhaskar Aug 20 '16 at 14:50
  • okay, after making the laptop sleep when the swipe gesture was working made it stick across sleep-wake cycles. I've made the laptop sleep several times and swipe's still working :) – Dheeraj Bhaskar Aug 20 '16 at 22:09
  • Do you know how to flip the direction of swipe for backward and forward? I have set ActionID3 and ActionID7 to 1c, when I do three finger scroll from right to left it goes back and when I do three finger scroll from left to right it goes forward. I want it other around. Thanks in advance. – Toyas Oct 15 '20 at 23:19
2

Adding to @amir the following powershell script helps me:

Stop-Process -processname SynTPEnh; & "C:\Program Files\Synaptics\SynTP\SynTPEnh.exe"
  • Could you add a bit more detail as so this can be more worthy of a standalone answer? – Insane Nov 11 '15 at 22:35
  • The powershell script attempts to end the Synaptic task that controls the multi-touch gestures. And it restarts that task usually located in the program files. Restarting the exe fixes the sleep and hibernate issues. – firstever Nov 13 '15 at 13:37
1

Messing around and the registry, I found the problem. The problem has to do with the registry using windows 8 defaults for 3 finger gestures. You need to change the Windows 10 3 finger gestures in HKEY_Current_User, software, Synaptics, syntp, Touchpad to the Windows 10 3 finger gestures under HEY_Local_Machine, software, Synaptics, syntp, win10, 3 finger gestures. You'll notice the HKEY current users settings are different than the windows 10 default settings under HKEY Local Machine.

  • It matches for me, but that's probably because the gestures work. Just requires a restart of the SynTP process every time it wakes up. I think it's possible when you hit "Reset to default" in the GUI settings manager, it restores the Windows 8 settings and screws up the 3 finger gestures entirely. I've just avoided that button ever since. Is there a place where all these registry settings are documented? Because I'm trying to fix yet another touchpad problem by tweaking the registry, but it's kind of hard when I'm just taking shots in the dark. – Slithy Toves Nov 21 '15 at 22:59
1

I have a brand new HP Spectre x360 with the same Synaptics touchpad issue of the 3-finger swipe function disappearing after going to sleep and turning back on. I've read dozens of forums on this problem and it is pervasive whether you have a Dell, Lenovo, HP, ..... It's something to do with the Synaptics "Service" applications that run at startup. I've loaded up the latest drivers from Synaptics (v 19.0.12.98) and still had the same behavior. Also this laptop has was delivered in Dec. 2015 with Windows 10. It’s never seen another OS loaded. However, I did find that the solution of killing (or stopping from the Task Manager window) the SynTPEnhService.exe service seems to fix it. I've even copied over and implemented the scripts that other users have written and nicely posted on other vendor and community forums, that automatically will do this after "reawakening". Not an ideal solution but a solution nonetheless.

There are 3 processes (and one driver) associated with this Synaptics touchpad.

  • 64-bit Synaptics Pointing Enhance Service: SynTPEnhService.exe
  • Synaptics Pointing Device Helper: SynTPHelper.exe
  • Synaptics TouchPad 64-bit Enhancements: SynTPEnh.exe

They all were installed the latest driver version update from Synaptics. That being said, I've been trying a new solution for the last day that seems to fix it. I don't know if this is permanent or what other repercussions this has long term (but it is an EASILY undone fix if it doesn’t work).

Since killing (or stopping) the SynTPEnhService.exe seems to fix the problem, I simply permanently stopped it from starting by changing its settings in Task Manager Services from “Automatic” to “Disabled”. Seemed a bit draconian to me to do this, but so far it’s working. Multiple forced “sleeps”. Full restarts. All functions seem OK. I’ve dug through the web looking for an explanation of what the one program does (versus the other 2). Interesting that it’s the only one that the “User” is listed as “System”. The other 2 programs list the logged on user as “User”.

  • I tried leaving SynTPEnh Caller Service disabled for a couple days, and while it seemed to work when I tested a few sleeps and restarts, leaving it asleep for longer and coming back resulted in the gesture not working again. I had to kill SynTPEnh and reenable the service for the gesture to start working again. It's just ridiculous that Synaptic hasn't fixed this issue after so long. – Slithy Toves Jan 12 '16 at 19:33
0

I ran into the same issue with my ideapad, temporarily what i do is, force laptop to sleep once 3-finger defect is noted and once you wake it back up, IT WILL WORK.

I also downgraded mouse drivers.

welcome.

-1

You might want to replace the driver with older, working version:

  1. Let Lenovo/Windows update your Synaptics to the newest crippled version
  2. Go to Device Management, select the crippled Lenovo driver (it appear to me as Lenovo Pointing Device, but might have another name on your system) and choose Update Driver Software
  3. Now (IMPORTANT) Press Browse my Computer for Driver Softwrare, Let me Pick from a List, Have Disk, and point it to the driver contained in the following archive:
  4. Dell Driver

Restart, and allow Windows to run the Synaptics Helper, if asked.

  • This sort of worked, but unfortunately I don't think that driver works too well with Windows 10 (3 finger swipe up for task view doesn't work). Thanks anyway! – Slithy Toves Aug 25 '15 at 17:49
-1

I was having the same problem on my HP with a Synaptics clickpad. Rather than trying to get Windows to update the driver, I went to http://www.synaptics.com/en/drivers.php and downloaded the "Windows 10 PS/2 and SMBus Devices v19.0.19.1" driver. Once downloaded I extracted it, ran setup and now all gestures are working fine. Hope this helps in your case.

  • It turns out, despite the difference in version numbering, it installs the same driver as the one I got from Lenovo's website. – Slithy Toves Jan 12 '16 at 19:56

Not the answer you're looking for? Browse other questions tagged or ask your own question.