0

I have a Win10 laptop on which I enabled WOL and it works (BIOS enabled for WOL and NIC enabled for WOL). But sometimes when I WOL start it up the NIC negotiates a low speed of 10Mbps (it's a 1Gbps card) when via my ISP I have up to 300Mbps.

So in the Network Connection Properties of the NIC in the 'Advanced' tab I set "Link Speed & Duplex" to 10Mbps instead of "Auto Negotiation" to ensure I always get the fastest speeds.

But after this change WOL will no longer turn on the machine. Why? Is it a requirement for WOL to work to have "Auto Negotiation"? Setting it back to "Auto Negotiation" makes WOL OK, repeated this and some results.

  • Either the NIC on your laptop and the port it is plugged into are set to auto, or they are both set to a specific speed. What device are you plugging into? – Paul Aug 17 '15 at 3:42
  • The PC is connected to a Linksys E4200 v1 router with MTU set to "Auto". I am using a Cat5e cable. Is the "Auto" setting on the router failing WOL if the NIC is set to something other than "Auto"? – John Aug 21 '15 at 5:59
  • MTU is a different thing to link speed. It is unlikely you will be able to hard-set the link speed for the LAN ports on the E4200. The switch ports are gigabit, and so should negotiate full speed. It might be that the PC appears to be 10mpbs when in standby mode, and the E4200 is negotiating to that speed. When you hard code it, it switches to 1Gpbs during wake-up and the E4200 isn't aware of that and stays at 10mbps - and the mismatch prevents traffic passing through. – Paul Aug 21 '15 at 6:45
  • As a power saving technique the Ethernet card on my laptop powers off after a period of idle. When the card wakes it apparently negotiates a lower speed. Solution was to run regedit, search and find SipsEnabled for my network card and change the value from 1 to 0. Card now nevers enter sleep and network speed persists at 1gbps. URLs that helped me: Connection speed drops from 1 Gbps to 10 Mbps and [82567LM Gigabit Network Connection Link disconnected] (communities.intel.com/thread/7057) – John Sep 18 '15 at 19:17
  • Please add this as an answer and accept. This will help others with the same question know there is an answer. – Paul Sep 18 '15 at 22:42
0

The answer that worked for me here was to disable the System Idle Power Saver (SIPS) on my laptops NIC (by opening regedit and changing SipsEnabled from true or "1" and setting it to false or "0"). This answer is from my own comment on this post ("John" from Sep 18 2015 at 19:17), see that comment for more info and links to more pages with more detail on SIPS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.