5

OneDrive will frequently make a Documents folder, even when I keep deleting it.

I use the root OneDrive folder to store my files, so I have no need for this folder -- how can I remove it?

Additionally, just out of curiosity, a file that looks like .XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX (8 characters, 4 characters, 4 characters, 12 characters) will pop up in the same fashion as the Documents folder -- every once in a while, one I delete it.

What is this file and can I delete it?

I'm on w10, but this happened on w8, too.

1

2 Answers 2

0

Have you tried disabling One drive or completely hide it from file explorer?

Here’s how to use Registry Editor to turn off OneDrive everywhere completely:

Press Win + R keyboard accelerator to open Run dialog box. Type RegEdit.exe and hit Enter or OK to open Registry Editor. Navigate to the following registry key: HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows

Right click on Windows and select New -> Key. Name the new key as OneDrive. Note: If OneDrive key already exists, skip this step.

Right click on OneDrive registry key, and select New -> DWORD (32-bit) Value. Name the new value name as DisableFileSyncNGSC Set the data for DisableFileSyncNGSC registry value as 1.

Credits

  1. Disable OneDrive Everywhere in Windows and Apps Completely
0

I've read numerous resources online that it can't be done through an official approach, here are two workarounds for this issue:

  1. Make the "Documents" folder hidden, and uncheck the "Hidden items" option:

    enter image description here

    enter image description here

  2. Deselect the "Documents" folder from syncing:

    enter image description here

Choose whichever you prefer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .