72

Is there any way to set keyboard shortcuts to quickly change to a different language/keyboard layout? The old shortcuts still seem to work (when set back in Windows 7), but I can't seem to find anything to change it in Windows 10.

108

Go to Control PanelClock, Language, and RegionChange input methods (under Language) → Advanced settingsChange language bar hot keys.

"Control Panel → Clock, Language, and Region → Language → Advanced settings" and "Text Services and Input Languages"

  • 3
    Yay, found it, for english users, it is in Control Panel -> Clock, Language, and Region -> Language -> Advanced Settings -> Change language hotbar keys (under Switching input methods). Thanks! – Hand of C'thuhlu Dec 11 '15 at 1:08
  • 2
    I keep hitting one of these default shortcuts without realising it and before I know it I'm typing random nonsense all over 🙄 Is it possible to change the WinKey + Space shortcut somewhere as well? – Toby Sep 27 '16 at 15:11
  • 1
    This seems to have changed in some recent update to Windows 10. The interface is rather different, but this answer still helped me fix the situation. The update apparently cleared all the settings I had made before (in Windows 7 before upgrade to Windows 10)! In addition, the previous default was that the change worked on a per-window basis; now you need to check the checkbox for allowing different application windows to use different keyboard layouts. – Jukka K. Korpela Jan 28 '17 at 18:05
  • 2
    Later update win10 1803 removed this panel, cannot set hotkey anymore. Don't update to 1803. – Tiw May 8 '18 at 7:35
  • 2
    @POW, 1803 just moved this panel. BTW, 1809 moved it again. – i3v Oct 20 '18 at 19:55
23

The menu in the accepted answer does not exist in Control Panel anymore on Windows 10 version 1803 (not sure about 1709 and older).

But the same setting is accessible from Modern Settings app → Time & Language → Region and Language → Advanced keyboard settings (from the Related settings section) → Language bar options → Advanced Key Settings tab.

Update: Windows 10 version 1809 moved this setting again. see i3v's answer.

  • Thank you, you saved me. What a slap from Microsoft again. – Youda008 Oct 29 '18 at 12:17
  • Yes, this should be the accepted answer now! – antimirov Jan 20 at 0:23
21

Windows key + Space is the new shortcut for switching keyboard layout!

  • 7
    Please read the question again carefully. Your answer does not answer the original question. – DavidPostill Dec 1 '16 at 12:22
  • 2
    On my system switching layouts does not work correctly using language switching. The question is asking for switching layouts, not languages. – arkod Dec 1 '16 at 12:34
  • 1
    OP is asking how to change the shortcuts and remove existing ones. Your answer does not address that. – DavidPostill Dec 1 '16 at 12:37
  • If you know how to change the shortcut for changing layout please let me know. Windows key + space is the way to change layout. – arkod Dec 1 '16 at 13:06
  • @arkod - Please read the question again carefully. Your answer does not answer the original question. "I still want to find a way to at least remove the current shortcuts set up" Notice your suggestion, was suggested, over a year ago and the author indicated it didn't answer this question. – Ramhound Dec 1 '16 at 14:48
4

In Windows 10 version 1809, the setting described in the accepted answer is here:

Settings -> Time & Language -> Language -> Spelling, typing, & keyboard settings -> Advanced keyboard settings -> Language bar options -> Advanced Key Settings.

Step-by-step screenshots.


Known issues

These hotkeys are quite buggy since 2012 or so. They may disappear (the setting is cleared or simply not working) after a windows update, after an RDP session, after logout/login, or even without any obvious reason.

There's one well-known workaround, that usually helps:

Settings -> Time & Language -> Language -> Administrative language settings -> Copy settings... -> tick both checkboxes -> OK.

If you ran into this, you may want to upvote some of these items on the FeedbackHub:

As a regular (non-insider) user:

  1. Input language hotkeys keep being reset every time Windows starts

  2. language bar hot keys are not reliable: a) sometimes they disappear ...

  3. Language bar hotkeys get erased after every RDP session

  4. Language bar hot key setting keeps resetting back to default I'm using 3 languages input

  5. When I set up language bar 'hot key' shortcuts to switch to keyboards with other alphabets, they are deleted whenever Windows restarts!

As insider:

  1. Keyboard layout switching shortcuts disappear and do not work
  2. Hot keys for input languages getting erased on each windows feature update
  3. Keyboard layout changes randomly
  4. Windows keeps switching the language and keyboard input methods
3

Just wanted to add to accepted answer. I am using Apple keyboard on Windows 10 here and the best way for me to switch input language is to turn off shortcut "Between input languages" completely and instead set individual shortcuts for each input language, for example:

  • Left Alt + Shift + 1(US Keyboard)
  • Left Alt + Shift + 2(UK Keyboard)
  • Left Alt + Shift + 3(Any other input language)
  • Left Alt + Shift + ...
  • Left Alt + Shift + 0(10th input language)

I find this setting the only one that doesn't disturb my work all the time as occasionally pressing Alt + Shift changes language when it is not needed. Also if to remove all shortcuts from the settings then holding WIN(CMD on apple keyboard) followed by [space](press multiple times to iterate the list) or [1,2,3..] or [Select with mouse] works well too.

3

Unfortunately this has changed in the latest Windows 10 update. You now need to go to 'Languages' and then 'Advanced settings' in Control panel, and choose 'Change language bar hot keys':

enter image description here

Which will then bring up this dialogue from which you can change the hot key by clicking 'Change Key Sequence...'

enter image description here

  • In the current Windows, i can't even easily get to the plain old Control Panel, and when i do, there is no more a 'Language' item. – Youda008 Oct 29 '18 at 12:22
1

For the latest Windows version since late 2018/ early 2019, Microsoft has changed this:

  1. select "Language Preferences" from the Task Bar/ Language options control (docked language bar)
  2. Select "Spelling, typing, & keyboard settings" under "Related Settings" at the top right.
  3. Scroll down to the bottom, then under "More keyboard settings", select "Advanced keyboard settings".
  4. Under "Switching input methods", select "Language bar options".
  5. Choose the "Advanced Key Settings" tab.
  6. Press the button at the bottom of the window: "Change Key Sequence…"

I hope Microsoft will not leave these vital settings in such an obscure place, in the long term (that they will at least give more convenient alternative ways of adjusting these settings!) The default settings are infuriating: I am forever accidentally pressing CTRL+SHIFT and accidentally switching between keyboard layouts…

0

For Windows 10 version 1803 I found the option in this location, they had moved it from the control panel to settings.

  1. Open up "Settings" by searching for it in the windows menu.
  2. Go to "Region & language" on the left hand side and click "Advanced keyboard setting" on the right hand side.
  3. Here you can find the "Language bar option"
  4. Change the hotkey by pressing "Change Key Sequence"

Step 1 picture

Step 2 picture

Step 3 picture

Step 4 picture

  • Welcome to StackOverflow! Given the number of similar answers to this question, this answer would be more helpful if you specified which Windows version and build you are using. As a new contributor, you will find that you will have a better experience if you take moment to take the Stack Overflow tour. If you follow the norms of the Stack Overflow community and approach it with an attitude of helping others too, it will serve you well. – Rey Juna Dec 5 '18 at 22:33
  • Welcome to Super User. Unfortunately, your answer duplicates content from several other answers. The intention is that each answer should contribute something new. – fixer1234 Dec 5 '18 at 22:43

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.