12

I was able to share a folder in local network without asking for credentials in windows 7 and 8. This we use to do by changing settings in Advanced Network and Sharing settings.

After updating to windows 10 it still asks for the user name and password. Even if I add Guest and Everyone with full controll in the permissions. I am sure I need to enable the Guest account before I can add guest account. For checking I went to user accounts but did not see Guest account but I accessed accounts using cmpmgmt.msc and checked the Guest account there which is enabled (because disable account was unchecked)

Has anything changed in windows 10?

17

Question is old but none of the answers fully cover the problem. There are a number of ways to accomplish this. There is one that works every time.

  1. Press the Windows Key key to open the Start menu and, without clicking anything, type sharing.
  2. At the top should be Manage advanced sharing settings. Click that.
  3. Expand the heading for All Networks and find the section called Password protected sharing.
  4. Set that to Turn off password protected sharing.
  5. Click Save changes.
  6. You may need to restart or unshare and reshare for the settings to take effect.

Also make sure that the file permissions of the files and folders being shared also allow access to Everyone. File permissions are managed separately from share permissions and whichever is more restrictive wins.

This should work in Windows 7 through 10 without issue.


Additional Notes:

In versions of windows before Vista, file sharing was unpassworded by default. If you shared files everyone on the same network as your computer could access (and alter) files in the share as they saw fit. Starting in Vista, in addition to a number of other security improvements for sharing, MS made it so sharing without a password was unavailable by default. This is the setting that reverts to the old behavior. Obviously, it shouldn't be turned off without also taking other steps to secure the shared files in shared network environments. Sharing with Everyone in such cases would be unwise.

| improve this answer | |
  • I add to do this in both computers. Important thing, restart the PC, otherwise it doesn't work. – xarlymg89 Aug 31 '17 at 9:41
  • Worked for me immediately, without restart or unshare/reshare. Great answer! Would be interesting, though, to know what purpose of this setting turn off password protected sharing is and what the consequences or side-effects of activating it are. – Glemi Jan 6 '19 at 20:48
0

Would have to ask because it's not mentioned, but can we presume you are connected to homegroup

Another requirement usually is that you'll need to have set a username and password in both the computers

| improve this answer | |
0

Right Click that folder which you want to share and then go to select share with then click For specific people and then add guest and then add it and change the read to read/write . that's all go to their folder by giving IP that's all .. nothing changed in folder sharing in windows 10 OS .

Step 1 :

enter image description here

Step 2 :

enter image description here

| improve this answer | |
0

There could be many reasons why, but one which keeps hunting me is that Windows automatically tries to log into shared folders using currently sign-in user. If this fails it will not try "fall-back" to Guest.

In my case, my NAS has a user 'papo', but on my PC, I am sign in as papo as well. But I use different passwords for everything (with a formula).
The result is, I can't sign-in to NAS as a Guest without a password from my PC.

| improve this answer | |
0

Here is how to access the shared resources using a "Microsoft account username and password" or turning off password protection.

On the network machine whose shared drive or folder or file you are trying to access, set up a LOCAL user account and password for the machine that is doing the accessing. It's counter-intuitive for another machine to use a "local" setting for a different machine, but it works, It's that simple -- why can't Microsoft just document that and tell us?!! There is so much frustration about this all across the WWW.

Here's how to make the setting:

1. Open Control Panel.

2. Click on Administrative Tools, then Computer Management.

3. In the left panel, open Local Users and Groups.

4. Open the Users folder which appears.

5. In the menu at the top, click Action, and the New User in the menu.

6. In the New User box that appears, fill out the Username and Password fields. Optionally, fill out the Full Name and Description fields - they aren't necessary.

7. Uncheck "User must change password at next logon. Put check these two boxes: "User cannot change password" and "Password never expires."

If you ever want to deny access, either go there again and tick the "Account is disabled" box, or just delete the user account.

| improve this answer | |
0

You have to turn media streaming on to access shared folders/files.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.