If I'm on a page that has web notifications (like Slack or others), Firefox asks me if I want to enable them. However, my choices are "Yes" or "Ignore for now". The problem is, if I select "Ignore", every time there is a notification it asks me again. This is incredibly annoying.

How do I disable this completely? (I would accept disabling this feature entirely if that's easiest.)

  • 1
    If you want to see a checkbox in Firefox for this, then please be sure to vote for bug #1368744 in the Firefox bug tracker. (Don't nag in comments on the bug tracker; use the Vote button.) – Aeyoun Aug 25 '17 at 22:27
  • On a site-by-site basis: support.mozilla.org/en-US/kb/… – Andrew Oct 30 '17 at 4:12
  • 1
    Would you consider changing the accepted answer to one that is relevant for Firefox 59 and later? – Thunderforge May 2 at 15:38
up vote 18 down vote accepted

Go into about:config and set dom.webnotifications.enabled to false

You can also disable this on a per-site basis by right-clicking somewhere in a blank spot of the site (or pressing Ctrl-I on Windows or Cmd-I on Mac) and then selecting "View Page Info" from the opening menu. This opens a window with a "Permissions" tab. Scroll down until you see "Receive Notifications", uncheck "Use Default" then select "Block."

enter image description here

  • 3
    Downvoted. This does not answer the question. @pandemonium provided the correct answer to the specific question. It would be appropriate to give that user the Answer credit. – TonyG Sep 29 '17 at 2:13
  • 1
    It was such a relief to disable these pesky notifications. Thanks. – Rolen Koh Jan 24 at 5:22
  • 1
    @TonyG You don't seem to have read the question. – Jamie Kitson Jan 30 at 10:41
  • 1
    The original incorrect response was posted in 2015. In 9/17 I downvoted that. By that time @Pandemonium had posted the correct answer, but the OP hasn't been back to fix the accepted answer. Note that in 12/17 Chin then edited his answer to be the correct one, having seen the correct answer by Pandemonium. Now, I dunno whether to stand by my downvote because this answer was credited incorrectly, and perhaps Chin is still taking credit for what was originally a wrong answer, or if I should remove the downvote because in good spirit Chin corrected himself. Leaving it until clarified. – TonyG Jan 30 at 15:57
  • @TonyG, I am in complete agreement with you. It seems to be rather inappropriate for this answer to be modified years later to include the answer from Pandemonium which obviously works much better. From my perspective, that seems to be unprofessional at best, and it borders on being both manipulative and deceptive. – Run5k Mar 18 at 22:43

Go into about:config and set dom.webnotifications.enabled to false. This seems to work for me in FF 47.

  • 4
    This is real solution !!!!!!! – user956584 Jan 7 '17 at 20:36
  • 4
    Still works in FF v52. So silly that they don't have a setting about it in the normal preferences. Oh well, the web is going south.... – Davide Apr 11 '17 at 16:04
  • 1
    This seems to be the only working solution by now! I've seen elsewhere lots of references to a "Preferences - Contents Windows - Notifications - Do not disturb" button, which seems to not exist anymore, at least in FF 55. It's been very annoying having most websites I visit requiring all my attention to first choose to enable or not notifications, one by one. – Jose Tepedino Sep 13 '17 at 14:55
  • also works in firefox 57 quantum – answerSeeker Nov 22 '17 at 15:21

In about:config I set dom.webnotifications.enabled to false but it didn't work for me in FF 56. I had to set dom.push.enabled to false as well.

  • That's the right answer! – marcus Feb 26 at 12:28

As of Firefox 59, this is in Options

Open the Options window

enter image description here

On the left side of the screen, click "Privacy & Security"

enter image description here

Under the "Permissions" section, find "Notifications" and click the "Settings..." button

enter image description here

Check the box that says "Block new requests asking to allow notifications"

enter image description here

  • 4
    This should now be the accepted answer – Robin Winslow May 2 at 15:34

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.