8

I downloaded a video from YouTube (about 1 hour film) and downloaded subtitle from the Subscene website and I put the video subtitle in the same folder with the same name.

When I play the video with VLC and the subtitle shows automatically but after 1:24 minute it falls out of sync which is annoying.

I have tried VLC’s sync features and g and h keys, they don’t seem to change anything.

The file is a MP4 file and I'm running Linux Mint 17.2 64bit, VLC version is 2.1.6 .

Is there a solution for this problem? Preferably with VLC media player.

2
  • 3
    I've had this problem on Windows machines. VLC subs delay +/- simply does not work when you need larger 8+ second adjustments, even though the ms value ratchets back and forth just fine. Very frustrating. This happens across multiple Windows machines and multiple versions of VLC. Why didn't the .srt standard just have the option to plug a advance/delay value into the top of the text file.... Just seems so obvious that would be an oft needed function.
    – Larry
    Feb 4 '16 at 23:01
  • There seems to be a problem with VLC and subtitle synchronization that's been going on for a long time. These trac tickets from 2012 and 2017 indicate the issue: https://trac.videolan.org/vlc/ticket/5863 and https://trac.videolan.org/vlc/ticket/18744. Currently in 2020 with the latest VLC version subtitle sync still doesn't work for me on Windows10. I've tried a few other players and found potplayer has good subtitle synchronization, so I'm using that for now.
    – Dvaeer
    Dec 7 '20 at 14:26
4

Have you tried the advance synchronization feature (if your subtitles are lagging behind the audio).

Press shift+H when you hear a line spoken, and shift+J when you see that line in the text. Or you can also use the delay time box in the Adjustments -> Synchronization window.

https://wiki.videolan.org/Adjust_Subtitle_Delay/

2
  • 1
    On OSX maybe, on Windows it's Tool -> Track Synchronization.
    – FatalSleep
    Aug 28 '15 at 5:49
  • In case anyone else finds this the way I did, make sure to press shift-k to apply the sync afterward. Sep 4 '19 at 3:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.