2

localectl list-locales lists quite a selection of english language locales, but everything else is missing.

How do I install or generate all locales?

I tried installing all language packs with:

dnf langavailable | sed 's/.*\[/dnf -y langinstall /' | sed 's/\].*//' | sh

but that didn't help, so it seems language packs don't set up the locales for those languages?

2

Answering my own question here, as I got the answer via #fedora:

It turns out the image I was using (a droplet on Digital Ocean) has the following setting in /etc/rpm/macros.image-language-conf:

%_install_langs C:en:en_US:en_US.UTF-8

Changing that to all:

%_install_langs all

And then reinstalling glibc fixed it for me:

sudo dnf reinstall glibc-common
  • Tried adding :fi_FI:fi_FI.UTF-8 to the end of the list but that didn't work. Instead adding fi_FI before the en_US.UTF-8 entry worked.. Wonder if the installer fails to parse the .UTF-8 correcty.. – Jonas Berlin Nov 6 '17 at 21:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.