6

I purchased a used iMac. It has OS X Mavricks installed. I'd like to re-purpose it for my web designer to use here at my office, since she cannot easily run the Adobe suite on the Ubuntu machines we already have. So, I want to wipe all of the user data, essentially doing a "factory reset".

I do not have the login info to the machine.

I have tried the cmd+r reboot and reinstalled OS X but the original user data is still there. I also tried the cmd+opt+p+r thinking that user account info might be stored in NVRAM but that didn't seem to do the trick either (I know it's only supposed to be system settings like: time, locale, monitor res, etc. but thought that it was worth a shot).

Here are the steps I've already done: http://smallbusiness.chron.com/reboot-apple-imac-its-factory-settings-51261.html (Apple also explains the process here:https://support.apple.com/en-us/HT201314 but the instructions at Chron.com seemed easier to follow). In neither of these processes was I ever prompted for an Apple ID.

I have spent hours Googling and it seems that I can do a complete disk wipe and reinstall using a USB flash drive, but I cannot find a downloadable version of Mavericks anywhere. Apple is pushing Yosemite on the OS X page (http://www.apple.com/osx/) and doesn't seem to provide Mavericks anymore.

Furthermore, I am a Linux user and every machine I have available to me is running Linux (Ubuntu 14.04). I do not have, nor have I ever had, an Apple account.

Is this possible? Can I wipe all of the user data from this machine and start anew? Am I going to be required to create an Apple account to be able to use this machine?

EDIT:

An Apple ID is not required. I am now 10,000% certain of that.

  • 1
    I think, after you press CMD + R and go in OSX recovery, you are not using disk utility to erase the data or delete the partition. Yes an apple ID is one of the requirements for installing Mavericks – pun Aug 19 '15 at 5:51
  • Correct, I was choosing the "Reinstall ..." option. – Karl Wilbur Aug 19 '15 at 5:55
  • Your only option at clean install from Internet Recovery is to recover to the OS the device was first shipped with. After that, you can upgrade to Yosemite. Mavericks is not an option unless you have previously 'purchased' it on your own AppleID. – Tetsujin Aug 19 '15 at 6:27
  • @Tetsujin, Mavericks was getting reinstalled in Mac form internet recovery as he was not formatting the disk. After he formats the disk now, he will still get Mavericks & he would need to have an apple ID which he can sign up for anytime. – pun Aug 19 '15 at 6:32
  • Yes, he needs a new AppleID. Whether or not Mavericks gets installed at Recovery is entirely dependant on whether that's what it shipped with. From the quoted KB "If you use Internet Recovery to reinstall OS X, it installs the version of OS X that originally came with your computer. After installation is finished, use the Mac App Store to install related updates or later versions of OS X that you have previously purchased." If it's a brand-new AppleID it won't have any purchase history, hence Yosemite only. – Tetsujin Aug 19 '15 at 6:38
8

I can confirm from resetting many display models in my shop that you need to complete steps 6 and 7 from your first link otherwise the previous owners data will remain.

With Apple when you 'reinstall' you are only refreshing the operating system files and not actually formatting the entire drive like you would on a Windows computer.

The comment by "The_IT_Guy_You_Don't_Like" is exactly correct. I will however expand on the steps required. Also an Apple ID is required - so setup a free generic one.

Steps - From memory

  1. With Mac off Hold CMD + R and tap power button to turn on computer.
  2. Still holding CMD + R wait for recovery screen to appear that gives reinstall option.
  3. Before clicking reinstall click 'disk utility'Click Disk Utility
  4. On disk utility click the 'Macintosh HD' then the erase tab on the right.enter image description here
  5. Now choose 'Mac OS Extended (Journaled)' and name the driveenter image description here
  6. Click erase (doing this step deletes the previous user's data)
  7. Close disk utility with either the red x top left or you may have to click 'disk utility' top left and click quit on the drop-down to get back to the main screen (like first image).
  8. Now click 'Reinstall Max OS X' and it will download the os via the internet.
  9. Now when setting up the computer it would be like brand new, with no data from the previous owner.
  10. Once on the new desktop update to the latest OS by either clicking 'app store' on the dock or Apple logo top left and clicking software update.enter image description here

You will need any Apple ID to complete the updates. With experience in Windows re-installs I have made the similar mistake of missing out the deleting drive steps.

This is My 2nd post on here so I hope it helps.

Regards, Ivan G-S

  • Thanks, Ivan. I'll give it another shot today and report back. – Karl Wilbur Aug 19 '15 at 13:06
  • 2
    It worked!! Apparently I needed to erase the main drive first. Also, for the record, I DID NOT need a an Apple ID to get Mavericks reinstalled. I just Erased the drive as described above and then proceeded to the "Reinstall..." as I had previously. I was prompted for an Apple ID but was given the option to "Don't log in" and was able to "Skip" that step. But I can, with absolute certainty, say that an Apple ID is not required. – Karl Wilbur Aug 19 '15 at 18:51
  • 1
    The only issue I have with this is if the original operating system is no longer on the mac store, you will get an error about the item being temporarily unavailable. It's worth doing cmd+option+r first, and then when you get to the recovery screen, you can install the latest operating system. – Christia Jun 5 '18 at 0:52
  • Yeah I'm getting this issue as well. (Temporarily Unavailable). Not sure how to proceed! – Brad Parks Sep 8 '18 at 1:00

Not the answer you're looking for? Browse other questions tagged or ask your own question.