22

Since updating to win 10, I'm experiencing issues with my disk usage. From time to time (sometimes every 10 minutes, sometimes once every few hours) my system becomes unresponsive because the disk usage is 100%. It usually takes one or two minutes for this blocking to be resolved.

If I have the task manager open, it says the read and write speeds are 0, but still my disk is being used for 100%. I'd expect there's some process blocking IO access to all the others, so I've tried watching the performance monitor for heavy processess, but since I can only see the current read/write speed of each process/service, I haven't been able to pinpoint any abnormal behavior.

Can anyone show me how to diagnose this kind of issue please? As you can imagine it does reduce my productivity, and to be honest I hate it when my pc behaves unexpectatly :p

Regards, klmdb

PS: I've googled 100% disk usage issues and came across many different suggestions (like disabling some windows services), but to be honest I'd prefere not to 'solve' the problem by cutting off pieces of the intended operation of my OS.

8
  • Do you have any 3rd party antivirus installied? If yes try to uninstall it Aug 19, 2015 at 11:44
  • No I only have windows defender.
    – klmdb
    Aug 19, 2015 at 12:27
  • Have you tried to stop it Windows Defender for a while to see if the situation would improve. Also check the system event logs for Event ID129 as per this Microsoft KB. Aug 19, 2015 at 14:14
  • Awesome! I did check the system events and found the exact issue that you linked. I applied the provided solution. Hopefully that does the trick. Thanks very much! If you provide your tip as a solution, and maybe describe how you knew what to look for, I can accept it and you get your hard earned credit :)
    – klmdb
    Aug 19, 2015 at 14:58
  • hmmm still getting the same behavior (maybe a little less frequent), and also still getting id129 events. Investigating the event id further...
    – klmdb
    Aug 20, 2015 at 18:10

1 Answer 1

5

This is a known issue with certain ACHI devices. Microsoft has provided a solution: https://support.microsoft.com/en-us/kb/3083595

If you follow these steps (taken from the article) your problem should be resolved.

  1. Identify if you are running the inbox AHCI driver (StorAHCI.sys):

    1. Open a command prompt with administrator privileges. Then type the following command in the command prompt window and hit Enter: devmgmt.msc

    2. Under IDE ATA/ATAPI Controllers right-click on the AHCI controller node and select Properties. This node is usually called “Standard SATA AHCI Controller.”

    3. Navigate to the driver tab and click Driver Details.

    4. If you see “StorAHCI.sys” in the list, you are running the inbox driver.

  2. Disable MSI for the controller in the registry:

    1. In the same properties window opened in step 1.2, navigate to the Details tab and select Device instance path from the Property drop-down menu. Note this path.

    2. Open the registry editor by typing regedit in the previously opened command prompt.

    3. Navigate to: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Enum\PCI\<AHCI Controller>\Device Parameters\Interrupt Management\MessageSignaledInterruptProperties, where <AHCI Controller> refers to the device instance path you noted in step 2.1.

    4. Change the value of the MSISupported key from 1 to 0.

    5. If you don’t know which controller your boot device is attached to, repeat steps 2.1 through 2.4 for all AHCI controllers found under 1.2.

  3. Reboot the machine.

3
  • 3
    Not only did this not help. But, I tried out over a dozen other solutions from around the web. I'm going to have to revert back to Windows 7.
    – ADH
    May 15, 2016 at 1:59
  • 1
    I'm in the same boat as @ADH. The issue sounds exactly what's described in that M$ article (no tasks or services are doing anything, or using any disk, but the disk is still at 100%), but this definitely didn't fix it. Jan 4, 2017 at 19:26
  • After devmgmt.msc, in 1.1 I get: /c/WINDOWS/system32/devmgmt.msc: line 1: syntax error near unexpected token `newline' /c/WINDOWS/system32/devmgmt.msc: line 1: `<?xml version="1.0"?>' Any help? Jan 18, 2017 at 0:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.