2

Similar to:

Windows 8: how to stop auto login

But for Windows 10. I have my own password protected user account, but my wife doesn't have a password on her's. So whenever I turn on the computer when she was the last one to use it, it automatically boots straight into her account, requiring me to sign out and then sign in with my account. This wasn't a problem with Windows 7 (that I just upgraded from), so is there a reliable way to stop Windows 10 from doing this? It's very annoying.

Edit: for the regular home edition of Windows 10. The accepted answer for the proposed dupe is for pro and I believe (correct me if I'm wrong) that you don't have group policies on the home edition. The other answer basically amounts to forcing all users to have passwords, which I'd prefer not to do.

  • possible duplicate of How to prevent automatic login of the last user in Windows 10? – MC10 Aug 19 '15 at 14:07
  • are you sure she tuned the pc off completely? maybe its hibernated or in sleep mode? – mnmnc Aug 19 '15 at 14:07
  • @mnmnc: I click power and tell it to shutdown. I would hope that's off. It certainly looks off when I restart (goes back through BIOS screens). – Matt Burland Aug 19 '15 at 14:08
  • Ok look at @MC10 answer then – mnmnc Aug 19 '15 at 14:12
  • 1
    @MattBurland If it worked for OP it should be valuable for Windows 10 then. I agree with the concern of the link only answer. If you get it working, perhaps you could answer this question with your own steps to getting it to work. – MC10 Aug 19 '15 at 14:58
1

Not sure if this can be an acceptable answer, but it will definitely work, regardless of what version of windows you have for this particular situation.

Give the account of your wife a password, for example one space or one letter. Any other solution will mean she has to hit CTRL-ALT-DEL and possibly even enter her username which is going to be even more key presses. Having a 1 letter password might be even preferred in this case.

3

After a lot of searching I found a solution for the auto-login problem, a solution that is usable for Windows 10 Home, that has no Local Group Policy My solution also uses the well known registry setting HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserSwitch\Enabled, that should have the value "1". But if you change this registry setting to "1", from that moment on it is not possible anymore to run an application as administrator: normally you get a screen to enter the admin password, but when you change the registry setting you get an error about corrupted files. When that setting is reset, it works normally again.

So I had to set that setting as late as possible, just before the shutdown/reboot. The setting is auto-reset during the next boot.

For that I used the Task Schedular: I created a Task triggered by an event - Log: System; Source: User32; EvenID: 1074, Action: Start a Program. Program/script: C:\Windows\System32\reg.exe; Arguments: add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Authentication\LogonUI\UserSwitch /v Enabled /t REG_DWORD /d 1 /f

All other settings are not touched. Give the Task a name and save it.

To check if it worked (apart from the fact that no auto login is seen anymore) look in the Task Schedular itself: when you select Task Schedular library, you get an overview of all tasks. The last column of that overview contains the results of the last run. The date of the last run is in the previous column.

  • Make sure you uncheck the option "Start the task only if the computer is on AC power" at the Conditions tab. – AntonK Jul 11 '16 at 21:39
  • While evaluating this approch I noticed it worked occasionally on my PC (Windows 10 Home 64-bit): the magic happens only once after the task is modified. So I'd go for the approach with "empty auto-logon" as explained in superuser.com/a/1080931/256121 – AntonK Jul 30 '16 at 22:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.