0

I'm trying to enable the NetFx3 feature on Windows 10, this fails through 'Turn Windows features on or off'. And also fails through DISM. I tried the following commands:

dism /online /enable-feature /featurename:NetFx3 /All 
dism /online /enable-feature /featurename:NetFx3 /All /LimitAccess
dism /online /enable-feature /featurename:NetFx3 /All /source:F:\sources\sxs
dism /online /enable-feature /featurename:NetFx3 /All /source:F:\sources\sxs /LimitAccess

All with the same output at the command line:

Deployment Image Servicing and Management tool
Version: 10.0.10240.16384

Image Version: 10.0.10240.16384

Enabling feature(s)
[==========================100.0%==========================]

Error: 0x800f0922

DISM failed. No operation was performed.
For more information, review the log file.

The DISM log file can be found at C:\WINDOWS\Logs\DISM\dism.log

The DISM log can be found here.

I also already changed the Group policy to get optional component installation and repair from Windows Update directly instead of WSUS, because we use a WSUS server in our domain.

  • "I also already changed the Group policy to get optional component installation and repair from Windows Update directly instead of WSUS, because we use a WSUS server in our domain." I've dealt with this one as well last week. My experience has shown that this policy doesn't (properly) apply to Windows 10. Using gpedit.msc on the local machine and setting it in the Local Policies worked as expected, .Net now installs. I'm thinking it's because I haven't upgraded the AD GP to support Win 10 yet, but I've done no testing/investigating on that (yet). – Ƭᴇcʜιᴇ007 Aug 19 '15 at 15:35
  • I actually changed it on my local machine as you describe. Unfortunately it still did not work. Just to be sure, I now tried it using the built-in local Administrator account (instead of using my domain user, that is also locally an administrator), but that also gives the same error code. – Jorre Meijrink Aug 20 '15 at 6:46
0

I ended up reinstalling RTM version of Windows 10, as I was upgraded from Technical preview before. After installing Windows 10, I immediately turned the Windows Feature Net Framework 3.5 on. And that worked.

Thank you for your efforts.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.