1

I'm trying to connect my 64bit packard bell ixtreme to my wifi but, although the connection is visible, I keep getting an error message saying that there was a problem connecting. I can connect via LAN cable.

The wifi is not the issue as I can connect other devices to it.

The driver is Atheros AR5006GS wireless network adapter, which I have uninstalled and then reinstalled by scanning for hardware changes. It is fully up to date.

I haven't used the wifi in a while (if ever!), and I don't know what changes I may have made to it since it was working (if it ever was).

Network discovery is on, the wireless network connection is enabled and there are no other wireless networks saved that could be conflicting with it.

Does anyone have any suggestions as to what I could do?

Thanks.

  • What driver version do you have? That particular generation of adapters is well known for having buggy drivers that cannot connect to networks with modern security (WPA/2 AES) – qasdfdsaq Aug 20 '15 at 15:02
  • Hi qasdfdsaq. Thanks for your response. It's version 8.0.0.171. – cohara Aug 21 '15 at 15:18
0

Navigate to:

Control Panel > Device Manger > Networks adapter > Right click on Wireless LAN network > Properties > Advanced

Now make sure your options look like this:

  • Bandwidth capability > 11b/g or 11b/g/n

  • Fragmentation Threshold > 2346

  • Power Output > 100%

  • 802.11n > Auto "NOT MIXED"

  • Antenna Diversity > Auto

  • Compatibility Mode > Higher Performance

  • ARB Of loud > Enable

  • BSS > b/g/n Auto

  • Delete the old wireless network from "Manage wireless networks"
  • Sometimes for no reason windows changing IP to static with no reason, check that too.
  • For this card " Atheros AR5006GS wireless " be sure your antenna connected perfectly, weak signal can cause that too.
  • The last tip, restart your router :)
  • 1
    Thanks a lot IT_GUY. In my advanced network adapter properties I don't seem to have all of the options that you specified above. In fact all I have is: 802.11b Preamble (for which my options are 'Long and Short' or 'Long only'), Network Address, Receive Buffers (the value is 256), Scan Valid Interval (the value is 60) and Transmit Buffers (The value is 256). I had deleted the old wireless networks already yesterday, and the IP address is set to be obtained automatically. I guess that only leaves the weak signal problem (I restarted the router :-) ) but the signal is strong on other devices. – cohara Aug 20 '15 at 7:26
  • ok be sure it's "long and short", Are you sure about your wireless router band? maybe it's work on N band only, check that, or change the band from your wireless card to mixed if there is an option for that – Narzan Q. Aug 20 '15 at 7:49
  • Thanks again, this is really helpful. 802.11b is set to long and short, and I've checked and the wireless card is set to mixed. – cohara Aug 20 '15 at 8:31
  • Sorry, Be sure your IBBS "b/g/n auto" not "Auto" – Narzan Q. Aug 20 '15 at 12:38
  • 2
    Ah yes, that should be one of the advanced options on my adapter (right?), but it's not there. If it's possible I might try to get a new adapter... Anyway thanks a lot IT_GUY, you were really helpful. – cohara Aug 21 '15 at 15:14
0

What driver version do you have?

It's version 8.0.0.171. – cohara 23 hours ago

Your drivers are six years old. This is a very old and known broken driver, from 2009. From what I recall, many pre-2011 drivers for Atheros cards were very buggy and unusable when it comes to WPA(2)-AES.

You need to update.

Here's a place to start:

https://www.atheros.cz/atheros-wireless-download.php?chipset=18&system=5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.