2

I have this router TP-LINK TL-WR841N (300 mbps 2.4Ghz). My ISP provided me 30mbps/4mbps and on Wifi I always got about the same.

BUT, today, my ISP has changed and provides me 70mbps/10mbps. With an Ethernet cable, I get about 65mbps/9mbps so... perfect.

BUT, on Wifi, I can't reach more than about 32mbps in download ! Upload is perfect (~9mbps)

Am I wrong or a 300mbps Wifi router should be enough for my 70mbps ISP ? or I'm totally wrong ?

I really hope someone will help me to understand this, thank you =)

5
  • You're totally wrong. Welcome to the sucky world of 2.4GHz. How is the router configured? What channel is it on? What channel width? What other networks are in range of your devices? Commented Aug 19, 2015 at 18:12
  • Hello =) The Wifi router is set to AP mode, DHCP off. It's linked to the main modem via Ethernet cable. Everything is OK for this as it never changed =). My Wifi router is set on channel 6 and widht is set on auto (20/40 mhz). There are some other networks on 1, 6, 11, 9 channels.
    – Radipacuit
    Commented Aug 19, 2015 at 18:19
  • Weird, I made a new test and now I get 42mbps down... but still not 65 ^^
    – Radipacuit
    Commented Aug 19, 2015 at 18:20
  • The problem is the network on channel 9, as it partially overlaps yours. You should try to convince that other network, if you can, to switch to 1, 6, or 11. Otherwise, switch to 1 and 20MHz yourself. Commented Aug 19, 2015 at 18:20
  • Ok thank you I'll try this and let you know. Btw, is that possible it's also related to sth like this sentence I found on another website: "Don't forget that megabits and Megabytes aren't the same units, in fact 300 mbps = only 37.5mb/s" ???
    – Radipacuit
    Commented Aug 19, 2015 at 18:26

1 Answer 1

1

Unlike wired connections, which are stable and reliable, wireless connection on the other hand, as the medium is open and shared, they are not. On wireless connections speeds vary widely depending on various conditions, such as number of overlapping channels (number of AP's and STA near you competing for signal on the same channel), signal attenuation (loss of signal strength because of distance or when it has to go through walls or other objects), and the list goes on and on. For you to achieve the maximum advertised throughput, the PRx has to be equal or higher than a certain power, called the Srx (Sensivity), sometimes the manufacturer advertises this value, other times it does not.

Are you near your router while you're testing, or are you in another room? How many walls are between your router and the STA (Laptop/Desktop) you're testing?

If you go to Control Panel/Network and Internet/Network Connections, and double click your wireless adapter, what's the advertised speed and signal quality?

How many AP's do you have near you? Can you download Inssider --> http://www.techspot.com/downloads/5936-inssider.html and run it to check how many overlapping networks are there?

Regards.

16
  • Hello and thank you for yout answer =) Yes I'm near my Wifi router, it's not far from my desk, on the same room. To be more accurate, I get -39db with Inssider. Then signal quality is Excellent and advertised speed is 144mbps. I also use a USB Wifi adapter that works great and it's a 300mbps device. And here is a screenshot of what Inssider shows me hpics.li/9718544 Thanks a lot !
    – Radipacuit
    Commented Aug 19, 2015 at 18:37
  • Hello. Is your SSID pikachu? If so, the advertised max rate is 54 Mb/s. That's the reason you're only getting 30 something Mb/s. Have you checked the configuration page of your router? Have you chosen N only (Wireless Mode) just to test? It's on this page of your router -- bit.ly/1JiIYjY Commented Aug 19, 2015 at 18:42
  • Hello yes it's Pikachu. That's weird, because when I test with another laptop near the router, with 300mbps on speed on Inssider, I also get about 30mbps, sometimes more ~35mbps. I'll try N only then =)
    – Radipacuit
    Commented Aug 19, 2015 at 18:52
  • Try it and check first on Inssider if the Max Rate goes up. Commented Aug 19, 2015 at 18:53
  • Actually I have another problem, my Wireless router is set on AP mode and I can't find his IP anymore so I can't go into the settings... I'll first have to figure this out lol
    – Radipacuit
    Commented Aug 19, 2015 at 18:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .